aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorPeter Williams <peterw@src.gnome.org>2000-06-26 07:00:29 +0800
committerPeter Williams <peterw@src.gnome.org>2000-06-26 07:00:29 +0800
commit78075bd090ddfe0824c6cd33faa2638ccd0e609e (patch)
tree831934e5a3282c2b0ba41023e495f6059f535543 /configure.in
parent902186dc5eff0f8472c467ecdf2895b220b678ff (diff)
downloadgsoc2013-evolution-78075bd090ddfe0824c6cd33faa2638ccd0e609e.tar.gz
gsoc2013-evolution-78075bd090ddfe0824c6cd33faa2638ccd0e609e.tar.zst
gsoc2013-evolution-78075bd090ddfe0824c6cd33faa2638ccd0e609e.zip
Force thread usage and clean up the configure aspect thereof.
svn path=/trunk/; revision=3734
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in39
1 files changed, 11 insertions, 28 deletions
diff --git a/configure.in b/configure.in
index 28dfd9fcf2..7af7493057 100644
--- a/configure.in
+++ b/configure.in
@@ -136,43 +136,26 @@ dnl **************************************************
dnl * Posix thread support
dnl **************************************************
-have_pthread=false
+dnl Hah! Threads are no longer an option
+dnl AC_ARG_WITH(threads, [ --with-threads Include thread support],[
+dnl FIXME: support more thread types, pth at least
-AC_ARG_WITH(threads, [ --with-threads Include thread support],[
- if test x$withval = xyes; then
- test_thread=true
- else
- test_thread=false
- fi
-],[
- test_thread=false
-])
+GNOME_PTHREAD_CHECK
-if $test_thread; then
- GNOME_PTHREAD_CHECK
- if test "x$PTHREAD_LIB" = "x" ; then
- have_pthread=false
- else
- have_pthread=true
- fi
-else
- have_pthread=false
+if test "x$PTHREAD_LIB" = "x" ; then
+ AC_MSG_ERROR([POSIX threads are currently required for Evolution])
fi
-AM_CONDITIONAL(ENABLE_THREADS, $have_pthread)
-
dnl
dnl Notice that this is a hack, and we wont be able to use this forever, but
dnl at least for some time
dnl
-if $have_pthread; then
- THREADS_LIBS="$PTHREAD_LIB `glib-config --libs gthread`"
- THREADS_CFLAGS="`glib-config --cflags gthread`"
-else
- THREADS_LIBS=""
- THREADS_CFLAGS=""
-fi
+THREADS_LIBS="$PTHREAD_LIB `$GLIB_CONFIG --libs gthread`"
+THREADS_CFLAGS="`$GLIB_CONFIG --cflags gthread`"
+
+AC_SUBST(THREADS_LIBS)
+AC_SUBST(THREADS_CFLAGS)
dnl **************************************************
dnl * Print check
tions'>+3 * Update math/R to 3.0.1-patched, and adjust dependent ports;bf2013-05-281-1/+1 * update math/R to 2.15.3, and adjust dependent portsbf2013-03-071-1/+1 * - Update to my new FreeBSD addressdbn2013-01-171-1/+1 * update the R base ports to 2.15.2 and adjust dependent portsbf2013-01-051-0/+1 span> * Update to 0.99.0Sunpoet Po-Chuan Hsieh2020-01-192-4/+4 * Update to 0.98.0Sunpoet Po-Chuan Hsieh2020-01-182-4/+4 * Update to 0.96.0Sunpoet Po-Chuan Hsieh2020-01-162-4/+4 * Update to 0.95.0Sunpoet Po-Chuan Hsieh2020-01-152-4/+4 * Update to 0.94.0Sunpoet Po-Chuan Hsieh2020-01-142-4/+4 * Update to 0.93.0Sunpoet Po-Chuan Hsieh2020-01-132-4/+4 * Update to 0.92.0Sunpoet Po-Chuan Hsieh2020-01-112-4/+4 * Update to 0.91.0Sunpoet Po-Chuan Hsieh2020-01-112-4/+4 * Update to 0.90.0Sunpoet Po-Chuan Hsieh2020-01-102-4/+4 * Update to 0.89.0Sunpoet Po-Chuan Hsieh2020-01-092-4/+4 * Update to 0.88.0Sunpoet Po-Chuan Hsieh2020-01-082-4/+4 * Update to 0.87.0Sunpoet Po-Chuan Hsieh2020-01-062-4/+4 * Update to 0.86.0Sunpoet Po-Chuan Hsieh2020-01-052-4/+4 * Update to 0.85.0Sunpoet Po-Chuan Hsieh2020-01-052-4/+4 * Update to 0.84.0Sunpoet Po-Chuan Hsieh2020-01-042-4/+4 * Update to 0.83.0Sunpoet Po-Chuan Hsieh2020-01-032-4/+4 * Update to 0.82.0Sunpoet Po-Chuan Hsieh2020-01-022-4/+4 * Update to 0.81.0Sunpoet Po-Chuan Hsieh2020-01-012-4/+4 * Update to 0.80.0Sunpoet Po-Chuan Hsieh2019-12-312-4/+4 * Update to 0.79.0Sunpoet Po-Chuan Hsieh2019-12-302-4/+4 * Update to 0.78.0Sunpoet Po-Chuan Hsieh2019-12-282-4/+4 * Update to 0.77.0Sunpoet Po-Chuan Hsieh2019-12-132-4/+4 * Update to 0.76.0Sunpoet Po-Chuan Hsieh2019-12-122-4/+4 * Update to 0.75.0Sunpoet Po-Chuan Hsieh2019-12-112-4/+4 * Update to 0.74.0Sunpoet Po-Chuan Hsieh2019-12-092-4/+4 * Update to 0.73.0Sunpoet Po-Chuan Hsieh2019-10-302-4/+4 * Update to 0.72.0Sunpoet Po-Chuan Hsieh2019-10-302-4/+4 * Update to 0.71.0Sunpoet Po-Chuan Hsieh2019-10-262-4/+4 * Update to 0.70.0Sunpoet Po-Chuan Hsieh2019-10-212-4/+4 * Update to 0.61.0Sunpoet Po-Chuan Hsieh2019-10-042-4/+4 * Update to 0.60.0Sunpoet Po-Chuan Hsieh2019-09-272-4/+4 * Update to 0.59.0Sunpoet Po-Chuan Hsieh2019-09-262-4/+4 * Update to 0.58.0Sunpoet Po-Chuan Hsieh2019-09-152-4/+4 * Update to 0.57.0Sunpoet Po-Chuan Hsieh2019-09-102-4/+4 * Update to 0.56.0Sunpoet Po-Chuan Hsieh2019-09-092-4/+4 * Update to 0.55.0Sunpoet Po-Chuan Hsieh2019-09-052-4/+4 * Update to 0.54.0Sunpoet Po-Chuan Hsieh2019-08-302-4/+4 * Update to 0.53.0Sunpoet Po-Chuan Hsieh2019-08-292-7/+6 * Update to 0.52.0Sunpoet Po-Chuan Hsieh2019-07-032-4/+4 * Update to 0.51.0Sunpoet Po-Chuan Hsieh2019-06-242-4/+4 * Update to 0.50.0Sunpoet Po-Chuan Hsieh2019-06-232-4/+4 * Update to 0.49.0Sunpoet Po-Chuan Hsieh2019-06-212-4/+4 * Update to 0.48.0Sunpoet Po-Chuan Hsieh2019-06-202-4/+4 * Update to 0.47.0Sunpoet Po-Chuan Hsieh2019-06-122-4/+4 * Update to 0.46.0Sunpoet Po-Chuan Hsieh2019-06-102-4/+4 * Update to 0.45.0Sunpoet Po-Chuan Hsieh2019-06-082-4/+4 * Update to 0.44.0Sunpoet Po-Chuan Hsieh2019-06-052-4/+4 * Update to 0.43.0Sunpoet Po-Chuan Hsieh2019-06-022-4/+4 * Update to 0.42.0Sunpoet Po-Chuan Hsieh2019-05-222-4/+4 * Update to 0.41.0Sunpoet Po-Chuan Hsieh2019-05-212-4/+4 * Update to 0.40.0Sunpoet Po-Chuan Hsieh2019-05-202-4/+4 * Update to 0.39.0Sunpoet Po-Chuan Hsieh2019-05-182-4/+4 * Update to 0.38.0Sunpoet Po-Chuan Hsieh2019-05-172-4/+4 * Update to 0.37.0Sunpoet Po-Chuan Hsieh2019-05-152-4/+4 * Update to 0.36.0Sunpoet Po-Chuan Hsieh2019-05-132-4/+4 * Update to 0.35.0Sunpoet Po-Chuan Hsieh2019-05-012-4/+4 * Update to 0.34.0Sunpoet Po-Chuan Hsieh2019-04-292-4/+4 * Update to 0.33.0Sunpoet Po-Chuan Hsieh2019-04-242-4/+4 * Update to 0.32.0Sunpoet Po-Chuan Hsieh2019-04-182-4/+4 * Update to 0.31.0Sunpoet Po-Chuan Hsieh2019-04-132-4/+4 * Update to 0.30.0Sunpoet Po-Chuan Hsieh2019-04-062-4/+4 * Update to 0.29.0Sunpoet Po-Chuan Hsieh2019-04-062-4/+4 * Update to 0.28.0Sunpoet Po-Chuan Hsieh2019-03-202-4/+4 * Update to 0.27.0Sunpoet Po-Chuan Hsieh2019-03-142-4/+4