aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJeffrey Stedfast <fejj@ximian.com>2001-03-15 06:02:23 +0800
committerJeffrey Stedfast <fejj@src.gnome.org>2001-03-15 06:02:23 +0800
commitf19bb8e86d1b25ef18a4dc060334498b90a01fb9 (patch)
treeee041daa7d29d97e12363a66244b76c964b20e09 /configure.in
parent174adfa471581f0a322b4e381d9671b2b50ac9d4 (diff)
downloadgsoc2013-evolution-f19bb8e86d1b25ef18a4dc060334498b90a01fb9.tar.gz
gsoc2013-evolution-f19bb8e86d1b25ef18a4dc060334498b90a01fb9.tar.zst
gsoc2013-evolution-f19bb8e86d1b25ef18a4dc060334498b90a01fb9.zip
Updated to AC_SUBST the NSPR/NSS flags.
2001-03-12 Jeffrey Stedfast <fejj@ximian.com> * configure.in: Updated to AC_SUBST the NSPR/NSS flags. svn path=/trunk/; revision=8712
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 12 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index c8c62ea26d..cd06730a07 100644
--- a/configure.in
+++ b/configure.in
@@ -600,7 +600,7 @@ dnl = Camel (SSL) and Evolution (S/MIME).
dnl =
dnl = The Evolution security extensions are only built if these libraries are found
dnl ====================================
-with_nspr_includes=/usr/include
+with_nspr_includes=/usr/include/mozilla
AC_ARG_WITH(nspr-includes, [ --with-nspr-includes=PREFIX Location of Mozilla nspr4 libs.])
have_nspr_includes="no"
if test "x${with_nspr_includes}" != "xno"; then
@@ -609,7 +609,7 @@ if test "x${with_nspr_includes}" != "xno"; then
AC_MSG_CHECKING(for Mozilla nspr4 includes in $with_nspr_includes/mozilla)
AC_MSG_RESULT("")
CFLAGS="$CFLAGS -I$with_nspr_includes"
- AC_CHECK_HEADERS(mozilla/prinit.h mozilla/prio.h, [ moz_nspr_includes="yes" ])
+ AC_CHECK_HEADERS(prinit.h prio.h, [ moz_nspr_includes="yes" ])
CFLAGS="$CFLAGS_save"
if test "x{$moz_nspr_includes}" != "xno"; then
@@ -640,6 +640,8 @@ if test "x${with_nspr_libs}" != "xno" -a "x${have_nspr_includes}" != "xno"; then
if test "x$moz_nspr_libs" != "xno"; then
have_nspr_libs="yes"
NSPR_LDFLAGS="-L$with_nspr_libs $nsprlibs"
+ else
+ NSPR_CLFAGS=""
fi
else
AC_MSG_CHECKING(for Mozilla nspr4 libraries)
@@ -664,12 +666,20 @@ if test "x${with_nss}" != "xno" -a "x${have_nspr_libs}" != "xno"; then
msg_nss="yes"
NSS_CFLAGS="-I$with_nss/include"
NSS_LDFLAGS="-L$with_nss/lib $nsslibs"
+ else
+ NSPR_CFLAGS=""
+ NSPR_LDFLAGS=""
fi
else
AC_MSG_CHECKING(for Mozilla nss libraries)
AC_MSG_RESULT(no)
fi
+AC_SUBST(NSPR_CFLAGS)
+AC_SUBST(NSPR_LDFLAGS)
+AC_SUBST(NSS_CFLAGS)
+AC_SUBST(NSS_LDFLAGS)
+
dnl ====================================
dnl = End mozilla hacks
dnl ====================================
pan class='insertions'>+1 * - Add a new port: math/R-cran-quadprogtota2012-12-251-0/+1 * Add libmissing , standard math functions missing from the FreeBSD libm.bf2012-12-211-0/+1 * Math::Int64 adds support for 64 bit integers, signed and unsigned, to Perl.jadawin2012-12-201-0/+1 * - Add a new port: math/R-cran-RHmmtota2012-12-081-0/+1 * 2012-11-26 emulators/gcube: No more public distfilesbapt2012-11-281-1/+0 * 2012-11-27 graphics/morpheus: Depends on the expired gtkglareabapt2012-11-281-1/+0 * This module parses range definitions and returnsjadawin2012-11-261-0/+1 * - Add a new port: math/R-cran-LearnBayestota2012-11-231-0/+1 * - New port: octave-forge-cgi.stephen2012-11-211-0/+1 * - Add a new port: math/R-cran-MCMCpacktota2012-11-181-0/+1 * - Update math octave-forge-miscellaneous to 1.2.0.stephen2012-10-161-2/+0 * - Remove math/guppigahr2012-10-151-1/+0 * - Add a new port: math/R-cran-gtabletota2012-09-051-0/+1 * Add an math/openblas.maho2012-08-261-0/+1 * An R interface to the Lawson-Hanson implementation of an algorithm forskreuzer2012-08-221-0/+1 * Add py-pandas , flexible, high-performance data analysis in Python.rm2012-08-161-0/+1 * - New port, math/octave-forge-lssa.stephen2012-08-151-0/+1 * OpenGL Mathematics (GLM) is a header only C++ mathematics library fordemon2012-08-031-0/+1 * dlmodeler is a set of user-friendly functions to simplify the state-spacewen2012-07-241-0/+1 * - New port math/octave-forge-ncarray.stephen2012-07-211-0/+1 * - Add p5-Number-Uncertainty 0.1sunpoet2012-07-101-0/+1 * add math/metis4 to math/Makefile; update math/metis to 5.0.2; add appropriatebf2012-07-091-0/+1 * - Connect math/eigen3 to the build.avilla2012-06-271-0/+1 * Add arpack-ng 3.1.1, revised Argand library for solving large-scalebf2012-06-271-0/+1 * - Add p5-Math-GMPz 0.35sunpoet2012-06-231-0/+1 * - Add p5-Math-GMPq 0.35sunpoet2012-06-231-0/+1 * - Add p5-Math-GMPf 0.35sunpoet2012-06-231-0/+1 * - New port math/octave-forge-java.stephen2012-06-201-0/+1 * - Update The Glorious Glasgow Haskell Compiler to version 7.4.1pgj2012-06-041-0/+1 * Commons Math is a library of lightweight, self-contained mathematics andmiwi2012-05-251-0/+1 * KDE/FreeBSD team presents long awaited KDE SC 4.8.3!makc2012-05-251-0/+2 * readd php 5.3.13 and all its modules as php53*flo2012-05-161-0/+2 * 2012-05-10 archivers/php4-bz2: php4 is EOLedbapt2012-05-121-2/+0 * - Add a new port: math/R-cran-labelingtota2012-05-101-0/+1 * UFC (Unified Form-assembly Code) is a unified framework for finite elementwen2012-05-071-0/+1 * - Remove.stephen2012-04-191-1/+0 * - fix entries sortingrm2012-04-151-1/+1 * Add new port: math/py-viperjgh2012-04-151-0/+1 * Add new port: math/py-ufljgh2012-04-151-0/+1 * Add new port: math/py-fiatjgh2012-04-151-0/+1 * FFC works as a compiler for multilinear forms by generating code (C++) forrm2012-04-131-0/+1 * Perl module which lets you calculate with strings (specifically passwords, butswills2012-04-091-0/+1 * Scriptable bar graph generator with stacked and clustered bars support, usingcs2012-04-051-0/+1 * - update to 0.6.6pgollucci2012-03-081-1/+0 * - New port: math/carvegahr2012-02-201-0/+1 * - Connect all the previously added hs- ports to the buildpgj2012-02-131-0/+3 * - Add a new port: math/R-cran-KFAStota2012-02-111-0/+1 * -New port octave-forge-queueing.stephen2012-02-071-0/+1 * A Perl module that provides a mechanism to render (La)TeX formulae to ASCIIswills2012-02-051-0/+1 * - Add a new port: math/R-cran-bdsmatrixtota2012-02-041-0/+1 * - Add a new port: math/R-cran-Formulatota2012-02-041-0/+1 * This library provides implementations of special mathematical functionswen2012-02-021-0/+1 * - Add a new port: math/R-cran-memisctota2012-01-311-0/+1 * - Re-add math/R-cran-igraphtota2012-01-281-0/+1 * - Add a couple of pure extensions:pav2012-01-271-0/+1 * - New port sage-4.8.stephen2012-01-251-0/+1 * Adding xlapack:maho2012-01-231-0/+1 * Add crlibm , correctly-rounded mathematics library.bf2012-01-111-0/+1 * Add cblas 1.0, reference implementation of the C interface to the legacybf2012-01-101-0/+1 * Add xblas 1.0.248, extra Precise Basic Linear Algebra Subroutinesbf2012-01-061-0/+1 * Add spblas , NIST Sparse Basic Linear Algebra Subprograms (BLAS).bf2012-01-061-0/+1 * Add libflame , FLAME dense linear algebra library.bf2012-01-051-0/+1 * Add kktdirect 0.5, a direct solver package for saddle-point (KKT)bf2012-01-021-0/+1 * Add slatec 4.1, SLATEC Common Mathematical Library.bf2011-12-281-0/+1 * - New port math/octave-forge-dicom.stephen2011-12-271-0/+1 * - math/mingw32-libgmp4 moved to math/mingw32-libgmpstephen2011-12-261-1/+1 * Add alt-ergo 0.94, an automatic theorem prover dedicated to programbf2011-12-211-0/+1 * - Add p5-Math-Int64 0.17sunpoet2011-12-151-0/+1 * This is a Integer to Roman numerals converter.wen2011-10-28