aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/proxy/Makefile.am
diff options
context:
space:
mode:
authorTor Lillqvist <tml@novell.com>2005-07-13 18:05:44 +0800
committerTor Lillqvist <tml@src.gnome.org>2005-07-13 18:05:44 +0800
commitfab3780e2ef5545adc99ed69f259478abaaa7a66 (patch)
treee7b1f68480bfe77e8e0ecedf618100cf8228f4df /plugins/proxy/Makefile.am
parent9236b073035bef173a77f25c42204ef871edea69 (diff)
downloadgsoc2013-evolution-fab3780e2ef5545adc99ed69f259478abaaa7a66.tar.gz
gsoc2013-evolution-fab3780e2ef5545adc99ed69f259478abaaa7a66.tar.zst
gsoc2013-evolution-fab3780e2ef5545adc99ed69f259478abaaa7a66.zip
Don't return a value from a void funtion.
2005-07-13 Tor Lillqvist <tml@novell.com> * calendar-weather/calendar-weather.c (e_calendar_weather_migrate): Don't return a value from a void funtion. * groupwise-account-setup/org-gnome-gw-account-setup.eplug.xml: Use SOEXT. * groupwise-features/Makefile.am (NO_UNDEFINED_REQUIRED_LIBS): As the code does use functions from libevolution-mail, link with it. But OK, let's do it (at build time) only on Win32, then. * mail-account-disable/Makefile.am (INCLUDES): Remove duplicated line. (LDFLAGS): Use NO_UNDEFINED. (LIBADD): Link with the required libraries, but let's do it only on Win32. * mail-account-disable/org-gnome-mail-account-disable.eplug.xml: Use SOEXT. * proxy/Makefile.am (LIBADD): Link with libeutil. * proxy-login/Makefile.am (LIBADD): Link with libeutil. Link with libevolution-mail on Win32 only. (Have I understood correctly that it isn't considered a good idea on Unix to link plugins at link-time with libevolution-mail?) * proxy-login/org-gnome-proxy-login.eplug.xml: Use SOEXT. svn path=/trunk/; revision=29753
Diffstat (limited to 'plugins/proxy/Makefile.am')
-rw-r--r--plugins/proxy/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/plugins/proxy/Makefile.am b/plugins/proxy/Makefile.am
index 6a72207000..11bc02b96d 100644
--- a/plugins/proxy/Makefile.am
+++ b/plugins/proxy/Makefile.am
@@ -15,6 +15,7 @@ plugin_LTLIBRARIES = liborg-gnome-proxy.la
liborg_gnome_proxy_la_SOURCES = proxy.c proxy.h
liborg_gnome_proxy_la_LDFLAGS = -module -avoid-version $(NO_UNDEFINED)
liborg_gnome_proxy_la_LIBADD = \
+ $(top_builddir)/e-util/libeutil.la \
$(EVOLUTION_MAIL_LIBS) \
$(CAMEL_GROUPWISE_LIBS)
@@ -31,6 +32,6 @@ EXTRA_DIST = \
$(error_DATA) \
$(glade_DATA) \
org-gnome-proxy.eplug.xml \
- org-gnome-proxy-errors.xml
+ org-gnome-proxy-errors.xml
CLEANFILES = $(BUILT_SOURCES)