aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/proxy/Makefile.am
diff options
context:
space:
mode:
authorShreyas Srinivasan <sshreyas@novell.com>2005-07-10 17:41:08 +0800
committerShreyas Srinivasan <shres@src.gnome.org>2005-07-10 17:41:08 +0800
commita5c812f96334d17b3f781204495c24573cdc6240 (patch)
tree723ed9fcdc6f23d1266b0d57dcbafcc8618dc12b /plugins/proxy/Makefile.am
parentceb02ba2d414c7cd3840646d2808046be35d0592 (diff)
downloadgsoc2013-evolution-a5c812f96334d17b3f781204495c24573cdc6240.tar.gz
gsoc2013-evolution-a5c812f96334d17b3f781204495c24573cdc6240.tar.zst
gsoc2013-evolution-a5c812f96334d17b3f781204495c24573cdc6240.zip
Plugin to implement Proxy assignment on a groupwise account.
2005-07-10 Shreyas Srinivasan <sshreyas@novell.com> * plugins/proxy/*: Plugin to implement Proxy assignment on a groupwise account. svn path=/trunk/; revision=29693
Diffstat (limited to 'plugins/proxy/Makefile.am')
-rw-r--r--plugins/proxy/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/plugins/proxy/Makefile.am b/plugins/proxy/Makefile.am
new file mode 100644
index 0000000000..a1563ceda8
--- /dev/null
+++ b/plugins/proxy/Makefile.am
@@ -0,0 +1,30 @@
+INCLUDES = \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/camel \
+ $(EVOLUTION_MAIL_CFLAGS) \
+ $(EVOLUTION_CALENDAR_CFLAGS) \
+ $(CAMEL_GROUPWISE_CFLAGS) \
+ -DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
+ -DEVOLUTION_IMAGESDIR=\""$(imagesdir)"\"
+
+@EVO_PLUGIN_RULE@
+
+plugin_DATA = org-gnome-proxy.eplug
+plugin_LTLIBRARIES = liborg-gnome-proxy.la
+
+liborg_gnome_proxy_la_SOURCES = proxy.c
+liborg_gnome_proxy_la_LDFLAGS = -module -avoid-version
+liborg_gnome_proxy_la_LIBADD = \
+ $(EVOLUTION_MAIL_LIBS) \
+ $(CAMEL_GROUPWISE_LIBS)
+
+glade_DATA = \
+ proxy-add-dialog.glade \
+ proxy-listing.glade
+
+error_DATA = org-gnome-proxy-errors.xml
+errordir = $(privdatadir)/errors
+
+BUILT_SOURCES = $(error_i18n)
+
+EXTRA_DIST = org-gnome-proxy.eplug.xml