aboutsummaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorIain Holmes <ih@csd.abdn.ac.uk>2000-02-09 00:21:19 +0800
committeriholmes <iholmes@localhost>2000-02-09 00:21:19 +0800
commit6e1f98f09afc66e9bdfec631045a250b6c7cace5 (patch)
tree896624676269e4dfaae0ca8eaaf56d3c428f8d38 /shell/Makefile.am
parent6cb60b68f180a2267503cd22c37216704c1750b1 (diff)
downloadgsoc2013-evolution-6e1f98f09afc66e9bdfec631045a250b6c7cace5.tar.gz
gsoc2013-evolution-6e1f98f09afc66e9bdfec631045a250b6c7cace5.tar.zst
gsoc2013-evolution-6e1f98f09afc66e9bdfec631045a250b6c7cace5.zip
Changed the order of the compilation so the CORBA stuff was generated
2000-02-08 Iain Holmes <ih@csd.abdn.ac.uk> * mail/Makefile.am: Changed the order of the compilation so the CORBA stuff was generated before it was needed. * shell/Makefile.am: Same. svn path=/trunk/; revision=1695
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index b9a466b21c..56341d0042 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -16,6 +16,7 @@ EVOLUTION_CORBA_GENERATED = \
Evolution-stubs.c
evolution_SOURCES = \
+ $(EVOLUTION_CORBA_GENERATED) \
main.c \
e-folder.c \
e-folder.h \
@@ -30,8 +31,7 @@ evolution_SOURCES = \
e-shell-view-menu.c \
e-shell-view-menu.h \
e-shortcut.c \
- e-shortcut.h \
- $(EVOLUTION_CORBA_GENERATED)
+ e-shortcut.h
Evolution-impl.o: Evolution.h
be3430.tar.gz
freebsd-ports-gnome-ddc831edbdc0e553f4127cd743e90f69fdbe3430.tar.zst
freebsd-ports-gnome-ddc831edbdc0e553f4127cd743e90f69fdbe3430.zip
Update to KDE 3.5.7 / KOffice 1.6.3
Diffstat (limited to 'x11/kdebase3')
-rw-r--r--x11/kdebase3/Makefile14
-rw-r--r--x11/kdebase3/distinfo6
-rw-r--r--x11/kdebase3/files/extrapatch-kioslave_media_mediamanager-halbackend.cpp545
-rw-r--r--x11/kdebase3/files/extrapatch-kioslave_media_mounthelper-kio_media_mounthelper.cpp49
-rw-r--r--x11/kdebase3/files/patch-kdm-config.def10
-rw-r--r--x11/kdebase3/files/patch-plugin-keyboard-handler.diff77
-rw-r--r--x11/kdebase3/files/pkg-message.in2
-rw-r--r--x11/kdebase3/pkg-plist11
8 files changed, 530 insertions, 184 deletions
diff --git a/x11/kdebase3/Makefile b/x11/kdebase3/Makefile
index 245e12912f34..4747e8238169 100644
--- a/x11/kdebase3/Makefile
+++ b/x11/kdebase3/Makefile
@@ -8,7 +8,7 @@
PORTNAME= kdebase
PORTVERSION= ${KDE_VERSION}
-PORTREVISION= 3
+PORTREVISION= 0
CATEGORIES= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
@@ -18,8 +18,7 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= Basic applications for the KDE system
RUN_DEPENDS= ${KDE_PREFIX}/env/xdg-env.sh:${PORTSDIR}/misc/kde-xdg-env
-BUILD_DEPENDS= mkfontdir:${X_CLIENTS_PORT} \
- xmkmf:${X_IMAKE_PORT}
+BUILD_DEPENDS= xmkmf:${X_IMAKE_PORT}
LIB_DEPENDS= sasl2:${PORTSDIR}/security/cyrus-sasl2 \
smbclient:${PORTSDIR}/net/samba-libsmbclient \
usb-0.1:${PORTSDIR}/devel/libusb
@@ -58,7 +57,11 @@ OPTIONS= ARTSWRAPPER "Suid wrapper for aRts, req'd for realtime prio" on \
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
.include <bsd.port.pre.mk>
-.if ${X_WINDOW_SYSTEM:L} == xorg
+.if ${X_WINDOW_SYSTEM:L} != xorg
+BUILD_DEPENDS+= mkfontdir:${X_CLIENTS_PORT}
+.else
+BUILD_DEPENDS+= bdftopcf:${PORTSDIR}/x11-fonts/bdftopcf \
+ mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir
RUN_DEPENDS+= kompmgr:${PORTSDIR}/x11-wm/kompmgr
.endif
@@ -72,8 +75,7 @@ RUN_DEPENDS+= htdig:${PORTSDIR}/textproc/htdig
.if !defined(WITHOUT_HAL) && ${OSVERSION} > 500035
EXTRA_PATCHES= ${FILESDIR}/extrapatch-kioslave_media_mediamanager-halbackend.cpp \
- ${FILESDIR}/extrapatch-kioslave_media_mediamanager-halbackend.h \
- ${FILESDIR}/extrapatch-kioslave_media_mounthelper-kio_media_mounthelper.cpp
+ ${FILESDIR}/extrapatch-kioslave_media_mediamanager-halbackend.h
LIB_DEPENDS+= dbus-qt-1.1:${PORTSDIR}/devel/dbus-qt3 \
hal.1:${PORTSDIR}/sysutils/hal
PLIST_SUB+= MEDIA=""
diff --git a/x11/kdebase3/distinfo b/x11/kdebase3/distinfo
index 9051c799c5c2..5e51bc436b6b 100644
--- a/x11/kdebase3/distinfo
+++ b/x11/kdebase3/distinfo
@@ -1,3 +1,3 @@
-MD5 (KDE/kdebase-3.5.6.tar.bz2) = a53f589f58012e655a52220a6a151019
-SHA256 (KDE/kdebase-3.5.6.tar.bz2) = 245b35f8b2e1533f9ae92b3b07bee5339a716dfb8db363d0126d2e7409b7bd7e
-SIZE (KDE/kdebase-3.5.6.tar.bz2) = 24155599
+MD5 (KDE/kdebase-3.5.7.tar.bz2) = b421e01b3ee712549ee967f58ed24de0
+SHA256 (KDE/kdebase-3.5.7.tar.bz2) = 3c6d739abefc55b6cb64e1cf37b79f5993b666a5b40492471754794416b5c28d
+SIZE (KDE/kdebase-3.5.7.tar.bz2) = 24395088
diff --git a/x11/kdebase3/files/extrapatch-kioslave_media_mediamanager-halbackend.cpp b/x11/kdebase3/files/extrapatch-kioslave_media_mediamanager-halbackend.cpp
index 0da5609fb97a..61403676bbcb 100644
--- a/x11/kdebase3/files/extrapatch-kioslave_media_mediamanager-halbackend.cpp
+++ b/x11/kdebase3/files/extrapatch-kioslave_media_mediamanager-halbackend.cpp
@@ -1,5 +1,5 @@
---- kioslave/media/mediamanager/halbackend.cpp.orig Mon Jan 15 14:31:32 2007
-+++ kioslave/media/mediamanager/halbackend.cpp Sun Apr 8 02:18:14 2007
+--- kioslave/media/mediamanager/halbackend.cpp.orig Mon May 14 09:55:40 2007
++++ kioslave/media/mediamanager/halbackend.cpp Sat Jun 2 11:40:22 2007
@@ -17,9 +17,15 @@
*/
@@ -39,7 +39,7 @@
return true;
}
-@@ -251,11 +265,11 @@
+@@ -245,11 +259,11 @@
}
}
QMap<QString,QString> options = MediaManagerUtils::splitOptions(mountoptions(udi));
@@ -53,19 +53,19 @@
}
m_mediaList.addMedium(medium, allowNotification);
-@@ -272,6 +286,11 @@
+@@ -264,6 +278,11 @@
+ {
+ /* Create medium */
Medium* medium = new Medium(udi, "");
- setFloppyProperties(medium);
- m_mediaList.addMedium(medium, allowNotification);
+#ifdef Q_OS_FREEBSD
+ m_pollTimer.stop();
+ m_pollMediaList.append(medium);
+ m_pollTimer.start(250);
+#endif
- return;
- }
-
-@@ -293,12 +312,23 @@
+ // if the storage has a volume, we ignore it
+ if ( setFloppyProperties(medium) )
+ m_mediaList.addMedium(medium, allowNotification);
+@@ -290,12 +309,23 @@
void HALBackend::RemoveDevice(const char *udi)
{
@@ -90,7 +90,7 @@
const char* mediumUdi = findMediumUdiFromUdi(udi);
if (!mediumUdi)
return;
-@@ -334,7 +364,7 @@
+@@ -331,7 +361,7 @@
}
const char* mediumUdi = findMediumUdiFromUdi(udi);
@@ -99,7 +99,7 @@
if (!mediumUdi)
return;
-@@ -392,7 +422,7 @@
+@@ -389,7 +419,7 @@
{
Medium m( *cmedium );
if ( setFstabProperties( &m ) ) {
@@ -108,7 +108,7 @@
m_mediaList.changeMediumState(m, false);
}
return;
-@@ -407,6 +437,7 @@
+@@ -404,6 +434,7 @@
setFloppyProperties(m);
if (libhal_device_query_capability(m_halContext, mediumUdi, "camera", NULL))
setCameraProperties(m);
@@ -116,7 +116,7 @@
m_mediaList.changeMediumState(*m, false);
-@@ -479,28 +510,23 @@
+@@ -476,28 +507,23 @@
else
mimeType = "media/dvd" + MOUNT_SUFFIX;
@@ -156,7 +156,7 @@
}
else
{
-@@ -584,7 +610,7 @@
+@@ -581,7 +607,7 @@
}
}
@@ -165,7 +165,40 @@
QString fstype = medium->fsType();
if ( fstype.isNull() )
fstype = "auto";
-@@ -794,7 +820,7 @@
+@@ -766,7 +792,32 @@
+ if (medium && !isInFstab(medium).isNull())
+ return QStringList(); // not handled by HAL - fstab entry
+
++ const char *boolOptionNames[] = { "ro", "quiet", "atime", "uid", "utf8", "flush", "sync", 0 };
++ const char *stringOptionNames[] = { "shortname", "journaling", "mountpoint", "automount",
++#ifdef Q_OS_FREEBSD
++ "filemask", "dirmask", "charset", "locale", "doscodepage",
++#endif
++ 0 };
++
+ KConfig config("mediamanagerrc");
++ config.setGroup("General");
++ QMap<QString,QString> options;
++ for (int index = 0; boolOptionNames[index]; ++index)
++ if (config.hasKey(boolOptionNames[index]))
++ options.insert(boolOptionNames[index],
++ config.readBoolEntry(boolOptionNames[index]) ? "true" : "false");
++ for (int index = 0; stringOptionNames[index]; ++index)
++ if (config.hasKey(stringOptionNames[index]))
++ options.insert(stringOptionNames[index],
++ config.readEntry(stringOptionNames[index]));
++ if (!libhal_device_exists(m_halContext, name.latin1(), NULL))
++ {
++ QStringList result;
++ if (name.lower() == "general")
++ for (QMap<QString,QString>::ConstIterator it = options.begin(); it != options.end(); ++it)
++ result << it.key() + '=' + it.data();
++ return result;
++ }
+ config.setGroup(name);
+
+ char ** array = libhal_device_get_property_strlist(m_halContext, name.latin1(), "volume.mount.valid_options", NULL);
+@@ -777,25 +828,68 @@
if (t.endsWith("="))
t = t.left(t.length() - 1);
valids[t] = true;
@@ -174,20 +207,309 @@
}
libhal_free_string_array(array);
QStringList result;
-@@ -915,12 +941,20 @@
- result << "journaling=ordered";
+ QString tmp;
+
++ QMap<QString,QString> halOptions;
++ LibHalVolume* halVolume = libhal_volume_from_udi(m_halContext, name.latin1());
++ if (!halVolume)
++ {
++ LibHalDrive *halDrive = libhal_drive_from_udi(m_halContext, name.latin1());
++ if (halDrive)
++ {
++ tmp = QString::fromLatin1(libhal_drive_policy_get_mount_options(halDrive, NULL));
++ libhal_drive_free(halDrive);
++ }
++ }
++ else
++ {
++ const char *driveUdi = libhal_volume_get_storage_device_udi(halVolume);
++ LibHalDrive *halDrive = !driveUdi ? 0 : libhal_drive_from_udi(m_halContext, driveUdi);
++ if (halDrive)
++ {
++ tmp = QString::fromLatin1(libhal_volume_policy_get_mount_options(halDrive, halVolume, NULL));
++ libhal_drive_free(halDrive);
++ }
++ libhal_volume_free(halVolume);
++ }
++ if (!tmp.isEmpty())
++ {
++ uint start = 0;
++ while(start < tmp.length())
++ {
++ int end = tmp.find(',', start);
++ if (end == -1) end = tmp.length();
++ QString opt = tmp.mid( start, end - start );
++ start = end + 1;
++ end = opt.find('=');
++ QString key = opt.left(end);
++ if (valids.contains(key))
++ halOptions.insert(key, end == -1 ? QString::null : opt.mid(end + 1));
++ }
++ }
++
+ QString fstype = libhal_device_get_property_QString(m_halContext, name.latin1(), "volume.fstype");
+ if (fstype.isNull())
+ fstype = libhal_device_get_property_QString(m_halContext, name.latin1(), "volume.policy.mount_filesystem");
+
+ QString drive_udi = libhal_device_get_property_QString(m_halContext, name.latin1(), "block.storage_device");
+
++ bool value = false;
+ bool removable = false;
+ if ( !drive_udi.isNull() )
++ {
++ value = libhal_device_get_property_bool(m_halContext, drive_udi.latin1(), "storage.automount_enabled_hint", NULL);
+ removable = libhal_device_get_property_bool(m_halContext, drive_udi.latin1(), "storage.removable", NULL)
+- || libhal_device_get_property_bool(m_halContext, drive_udi.latin1(), "storage.hotpluggable", NULL);
++ || libhal_device_get_property_bool(m_halContext, drive_udi.latin1(), "storage.hotpluggable", NULL);
++ }
+
+ config.setGroup(drive_udi);
+- bool value = config.readBoolEntry("automount", false);
++ value = config.readBoolEntry("automount",
++ !options.contains("automount") ? value : options["automount"] == "true" );
+ config.setGroup(name);
+
+ if (libhal_device_get_property_bool(m_halContext, name.latin1(), "volume.disc.is_blank", NULL)
+@@ -809,44 +903,98 @@
+
+ if (valids.contains("ro"))
+ {
+- value = config.readBoolEntry("ro", false);
++ value = options.contains("ro") ? options["ro"] == "true"
++ : halOptions.contains("ro");
++ value = config.readBoolEntry("ro", value);
+ tmp = QString("ro=%1").arg(value ? "true" : "false");
+ if (fstype != "iso9660") // makes no sense
+ result << tmp;
++ halOptions.remove("ro");
+ }
+
+ if (valids.contains("quiet"))
+ {
+- value = config.readBoolEntry("quiet", false);
++ value = options.contains("quiet") ? options["quiet"] == "true"
++ : halOptions.contains("quiet");
++ value = config.readBoolEntry("quiet", value);
+ tmp = QString("quiet=%1").arg(value ? "true" : "false");
+ if (fstype != "iso9660") // makes no sense
+ result << tmp;
++ halOptions.remove("quiet");
+ }
+
+ if (valids.contains("flush"))
+ {
+- value = config.readBoolEntry("flush", fstype.endsWith("fat"));
++ value = options.contains("flush") ? options["flush"] == "true"
++ : (halOptions.contains("flush") || fstype.endsWith("fat"));
++ value = config.readBoolEntry("flush", value);
+ tmp = QString("flush=%1").arg(value ? "true" : "false");
+ result << tmp;
++ halOptions.remove("flush");
}
+#ifdef Q_OS_FREEBSD
++ if (valids.contains("-u"))
++#else
+ if (valids.contains("uid"))
++#endif
+ {
+- value = config.readBoolEntry("uid", true);
++ value = !options.contains("uid") ? true : options["uid"] == "true";
++ value = config.readBoolEntry("uid", value);
+ tmp = QString("uid=%1").arg(value ? "true" : "false");
+ result << tmp;
++#ifdef Q_OS_FREEBSD
++ halOptions.remove("-u");
++#else
++ halOptions.remove("uid");
++#endif
+ }
+
+ if (valids.contains("utf8"))
+ {
+- value = config.readBoolEntry("utf8", true);
++ value = !options.contains("iocharset") && !halOptions.contains("iocharset")
++ && (options.contains("utf8") ? options["utf8"] == "true"
++ : halOptions.contains("utf8"));
++ value = config.readBoolEntry("utf8", value);
+ tmp = QString("utf8=%1").arg(value ? "true" : "false");
+ result << tmp;
++ halOptions.remove("utf8");
+ }
+
++#ifdef Q_OS_FREEBSD
++ if (valids.contains("nowin95")
++ && valids.contains("longnames")
++ && valids.contains("shortnames"))
++ {
++ QString svalue = "winnt";