aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/common/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'calendar/common/Makefile.am')
-rw-r--r--calendar/common/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/calendar/common/Makefile.am b/calendar/common/Makefile.am
new file mode 100644
index 0000000000..8b0dbdb9e5
--- /dev/null
+++ b/calendar/common/Makefile.am
@@ -0,0 +1,28 @@
+noinst_LTLIBRARIES = libevolution-calendarprivate.la
+
+INCLUDES = \
+ -DG_LOG_DOMAIN=\"calendar-gui\" \
+ -I$(top_builddir)/shell \
+ -I$(top_srcdir)/shell \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/calendar \
+ -I$(top_srcdir)/widgets \
+ -I$(top_srcdir)/a11y/calendar \
+ -DEVOLUTION_DATADIR=\""$(datadir)"\" \
+ -DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
+ -DEVOLUTION_ETSPECDIR=\""$(etspecdir)"\" \
+ -DEVOLUTION_IMAGESDIR=\""$(imagesdir)"\" \
+ -DEVOLUTION_GALVIEWSDIR=\""$(viewsdir)"\" \
+ -DEVOLUTION_UIDIR=\""$(evolutionuidir)"\" \
+ -DPREFIX=\""$(prefix)"\" \
+ $(EVOLUTION_CALENDAR_CFLAGS)
+
+libevolution_calendarprivate_la_SOURCES = \
+ authentication.c \
+ authentication.h
+
+libevolution_calendarprivate_la_LIBADD = \
+ $(top_builddir)/e-util/libeutil.la \
+ $(EVOLUTION_CALENDAR_LIBS)
+
+libevolution_calendarprivate_la_LDFLAGS = -avoid-version -module