aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 8 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index a72648dd7c..2967320752 100644
--- a/configure.in
+++ b/configure.in
@@ -327,8 +327,14 @@ dnl ******************************
dnl Whether to use OAF
dnl ******************************
-AC_ARG_ENABLE(oaf,
- [ --enable-oaf=[no/yes] Use OAF instead of GOAD.],,enable_oaf=no)
+AC_MSG_CHECKING(if Bonobo uses OAF)
+if ( gnome-config --libs bonobo | grep oaf ) > /dev/null 2>&1 ; then
+ enable_oaf="yes"
+else
+ enable_oaf="no"
+fi
+
+AC_MSG_RESULT("$enable_oaf")
if test "x$enable_oaf" = "xyes"; then
AC_PATH_PROG(OAF_CONFIG,oaf-config,no)
4&id=b5d2aec42bf28a6e13f650db00e06869faabd4d3&showmsg=1'>Expand)AuthorAgeFilesLines * Update to 1.0.5. Changes include:hrs2011-02-122-3/+3 * Update to 1.0.4. Changes include:hrs2011-01-173-33/+5 * Update to 1.0.3.hrs2011-01-043-118/+28 * - Retire MASTER_SITE_SOURCEFORGE_EXTENDED, it's no longer needed - all mirror...amdmi32009-09-021-2/+1 * - Install documents in doc directory when !NOPORTDOCS.hrs2008-11-161-1/+13 * Remove USE_REINPLACE from categories starting with Tedwin2006-05-131-1/+0 * - Add SHA256pav2005-11-261-0/+1 * Fix build when textproc/libxslt are compiled with GCRYPTmnag2005-09-292-6/+116 * Update to 1.0.1jylefort2005-05-032-5/+5 * Update to version 0.9.5krion2004-12-203-18/+8 * fix dependencieseik2004-07-071-3/+4 * Fix the build with libxml2-2.6.11.marcus2004-07-071-0/+11