aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in38
1 files changed, 37 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index d809530fdb..2ae87ac430 100644
--- a/configure.in
+++ b/configure.in
@@ -167,7 +167,7 @@ AC_CACHE_CHECK([if ctime_r wants three arguments], ac_cv_ctime_r_three_args,
],[
char *buf;
time_t date;
- ctime_r( &date, buf, 100 );
+ ctime_r (&date, buf, 100);
],[
ac_cv_ctime_r_three_args=yes
],[
@@ -245,6 +245,41 @@ if test "x$ac_cv_gethostbyaddr_r_seven_args" = "xyes" ; then
AC_DEFINE(GETHOSTBYADDR_R_SEVEN_ARGS)
fi
+
+dnl **************************************************
+dnl * IPv6 support
+dnl **************************************************
+AC_ARG_ENABLE(ipv6, [ --enable-ipv6=[no/yes] Enable support for resolving IPv6 addresses.],,enable_ipv6=no)
+if test "x$enable_ipv6" = "xyes"; then
+AC_CACHE_CHECK([if system has necessary structs and functions for IPv6 support], msg_ipv6,
+[
+ AC_TRY_COMPILE([
+ #include "confdefs.h"
+ #include <sys/types.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+ #include <netdb.h>
+
+ ],[
+ struct addrinfo hints, *res;
+ struct sockaddr_in6 sin6;
+ int af = AF_INET6;
+
+ getaddrinfo ("www.ximian.com", NULL, &hints, &res);
+ freeaddrinfo (res);
+ ],[
+ msg_ipv6=yes
+ ],[
+ enable_ipv6=no
+ msg_ipv6=no
+ ])
+])
+else
+ msg_ipv6=no
+fi
+AM_CONDITIONAL(ENABLE_IPv6, test "x$enable_ipv6" = "xyes")
+
+
dnl ***********
dnl * db3 stuff
dnl ***********
@@ -1218,6 +1253,7 @@ echo "\
Pilot conduits: $msg_pilot
Kerberos 4/5: $msg_krb4/$msg_krb5
SSL support: $msg_ssl
+ IPv6 support: $msg_ipv6
Dot Locking: $msg_dot
File Locking: $msg_file
Gtk-doc: $enable_gtk_doc
parent533059e1010028b954372b535bd8cae731d860e4 (diff)downloadfreebsd-ports-gnome-f8cff44e1d36c4e27195454e1d1b8f42b76f9c94.tar.gz
freebsd-ports-gnome-f8cff44e1d36c4e27195454e1d1b8f42b76f9c94.tar.zst
freebsd-ports-gnome-f8cff44e1d36c4e27195454e1d1b8f42b76f9c94.zip
Update postgresql to 8.2.1, 8.1.6, 8.0.10, 7.4.15 and 7.3.17.
Release notes: http://www.postgresql.org/docs/7.3/static/release.html#RELEASE-7-3-17 http://www.postgresql.org/docs/7.4/static/release.html#RELEASE-7-4-15 http://www.postgresql.org/docs/8.0/static/release.html#RELEASE-8-0-10 http://www.postgresql.org/docs/8.1/static/release.html#RELEASE-8-1-6 http://www.postgresql.org/docs/8.2/static/release-8-2-1.html The server-side utilities of postgresql (initdb, initlocation, ipcclean, pg_controldata, pg_ctl, pg_id and pg_resetxlog) are now installed by the respective postgresql*-server port (previously they where installed with the client). If you update the client, you should also update the server to make sure you are not left without the server-side tools. Do something like: portupgrade postgresql-client postgresql-server
Diffstat (limited to 'databases')
-rw-r--r--databases/postgresql73-client/Makefile4
-rw-r--r--databases/postgresql73-server/Makefile9
-rw-r--r--databases/postgresql73-server/distinfo24
-rw-r--r--databases/postgresql73-server/files/patch-src-bin-initdb-Makefile11
-rw-r--r--databases/postgresql73-server/files/pkg-message-server.in26
-rw-r--r--databases/postgresql73-server/files/postgresql.in9
-rw-r--r--databases/postgresql73-server/pkg-plist-client21
-rw-r--r--databases/postgresql73-server/pkg-plist-server23
-rw-r--r--databases/postgresql74-client/Makefile4
-rw-r--r--databases/postgresql74-server/Makefile10
-rw-r--r--databases/postgresql74-server/distinfo24
-rw-r--r--databases/postgresql74-server/files/patch-src-bin-initdb-Makefile11
-rw-r--r--databases/postgresql74-server/files/pkg-message-server.in26
-rw-r--r--databases/postgresql74-server/files/postgresql.in9
-rw-r--r--databases/postgresql74-server/pkg-plist-client34
-rw-r--r--databases/postgresql74-server/pkg-plist-server35
-rw-r--r--databases/postgresql80-client/Makefile4