aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index d828f48f8c..4b2fcf7702 100644
--- a/configure.in
+++ b/configure.in
@@ -147,6 +147,7 @@ case "$host" in
*-mingw*)
os_win32=yes
NO_UNDEFINED='-no-undefined'
+ MWINDOWS='-mwindows'
SOEXT='.dll'
SA_JUNK_PLUGIN=''
BF_JUNK_PLUGIN=''
@@ -156,6 +157,7 @@ case "$host" in
;;
*) os_win32=no
NO_UNDEFINED=''
+ MWINDOWS=''
SOEXT='.so'
SA_JUNK_PLUGIN=sa-junk-plugin
BF_JUNK_PLUGIN=bogo-junk-plugin
@@ -167,6 +169,7 @@ esac
AC_MSG_RESULT([$os_win32])
AM_CONDITIONAL(OS_WIN32, [test $os_win32 = yes])
AC_SUBST(NO_UNDEFINED)
+AC_SUBST(MWINDOWS)
AC_SUBST(SOEXT)
# Check for base dependencies early.