aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in40
1 files changed, 40 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 8971115f0e..c65a56048f 100644
--- a/configure.in
+++ b/configure.in
@@ -884,6 +884,34 @@ AC_SUBST(NSPR_LDFLAGS)
AC_SUBST(NSS_CFLAGS)
AC_SUBST(NSS_LDFLAGS)
+dnl ******************
+dnl CDE dtappintegrate
+dnl ******************
+
+AC_ARG_WITH(cde-path, [ --with-cde-path=PATH Location of CDE installation],
+ [with_cde_path="$withval"])
+if test -z "$with_cde_path"; then
+ with_cde_path="/usr/dt"
+fi
+
+AC_MSG_CHECKING(for dtappintegrate)
+if test -x "$with_cde_path/bin/dtappintegrate" ; then
+ DTAPPINTEGRATE="$with_cde_path/bin/dtappintegrate"
+else
+ DTAPPINTEGRATE="no"
+fi
+AC_MSG_RESULT([$DTAPPINTEGRATE])
+
+AC_SUBST(DTAPPINTEGRATE)
+AM_CONDITIONAL(HAVE_DTAPPINTEGRATE, test "x$DTAPPINTEGRATE" != "xno")
+
+dnl ****************************************************
+dnl GNOME_PREFIX is is needed by shell/evolution-nognome
+dnl ****************************************************
+
+GNOME_PREFIX="`gnome-config --prefix`"
+AC_SUBST(GNOME_PREFIX)
+
dnl ******************************
dnl OpenSSL
dnl ******************************
@@ -1217,6 +1245,17 @@ camel/tests/smime/Makefile
camel/tests/stream/Makefile
composer/Makefile
data/Makefile
+data/cde_app_root/Makefile
+data/cde_app_root/dt/Makefile
+data/cde_app_root/dt/appconfig/Makefile
+data/cde_app_root/dt/appconfig/appmanager/Makefile
+data/cde_app_root/dt/appconfig/appmanager/C/Makefile
+data/cde_app_root/dt/appconfig/appmanager/C/Ximian/Makefile
+data/cde_app_root/dt/appconfig/icons/Makefile
+data/cde_app_root/dt/appconfig/icons/C/Makefile
+data/cde_app_root/dt/appconfig/types/Makefile
+data/cde_app_root/dt/appconfig/types/C/Makefile
+data/cde_app_root/dt/appconfig/types/C/Ximian.dt
default_user/Makefile
default_user/local/Makefile
default_user/local/Calendar/Makefile
@@ -1249,6 +1288,7 @@ my-evolution/Makefile
omf-install/Makefile
po/Makefile.in
shell/Makefile
+shell/evolution-nognome
shell/glade/Makefile
shell/importer/Makefile
sounds/Makefile
/gsoc2013-evolution/commit/?h=EVOLUTION_2_26_2&id=6dc2b5fac8deaa57b0a84f74dec98476a3066849'>If the data wrapper contains raw text, treat the contents as if they wereJeffrey Stedfast2001-09-262-1/+21 * Rebuge demugging printf() - FedericoFederico Mena Quintero2001-09-261-2/+0 * Check that the timeout is not set up before we create a new one; theFederico Mena Quintero2001-09-262-4/+18 * Throw up a warning dialog if we suspect the config database is corrupt.Jeffrey Stedfast2001-09-264-9/+53 * A "safe write" function that always writes out all data asked of it, till52001-09-262-31/+50 * Handle the case when the transport is nothing.Iain Holmes2001-09-262-0/+12 * Check if the transport is NULLIain Holmes2001-09-262-0/+10 * Remove the FIXME menu itemIain Holmes2001-09-262-0/+6 * Only cache the password for the service if it has an entry in the accountJeffrey Stedfast2001-09-263-18/+33 * use bonobo-exception stuff to clean codeJP Rosevear2001-09-2619-2452/+643 * Handle creating the new contact in the current folder if it's a contactsChristopher James Lahey2001-09-252-5/+36 * Attach to the resorted signal instead of the changed signal on the sortedChristopher James Lahey2001-09-253-77/+54 * add evolutionperson.schema (EXTRA_DIST): add LDAP_SCHEMA to the dist (butChris Toshok2001-09-252-1/+15 * Set the exception to FOLDER_INVALID rather than making out it worked. A42001-09-252-0/+12 * Use the correct prototype for the signal handler.Federico Mena Quintero2001-09-252-6/+8 * Use e_strftime_fix_am_pm instead of strftime.Christopher James Lahey2001-09-252-5/+10 * Bumped the required version of gal to 0.12.99.0.Christopher James Lahey2001-09-252-1/+5 * Assert that the virtual method is implemented instead of being forgiving.Federico Mena Quintero2001-09-254-111/+179 * In the 'lose' case, free messages, not fetch_data twice!42001-09-252-1/+4 * Make the printouts here conditionally compiled out.Christopher James Lahey2001-09-252-2/+7 * Fixed some brokennessKevin Breit2001-09-252-1/+4 * Documented Insert -> Link a wee bit moreKevin Breit2001-09-252-1/+32 * Removed unused variables.42001-09-254-42/+81 * If the type is encoded, get the fallback charset from the message42001-09-2512-140/+190 * Updated Lithuanian translation.Gediminas Paulauskas2001-09-242-1897/+1516 * Stanislav Visnovsky <visnovsky@nenya.ms.mff.cuni.cz>Stano Visnovsky2001-09-242-298/+225 * Updated French translation.Christophe Merlet2001-09-242-317/+285 * base text on component typeJP Rosevear2001-09-242-7/+43 * sync the note the to pilot and make sure to blank fields when appropriateJP Rosevear2001-09-242-25/+31 * fixed compile warningJeffrey Stedfast2001-09-241-3/+2 * Always cache POP and IMAP passwords, even if the user didn't tell us to.Jeffrey Stedfast2001-09-242-0/+10 * Don't even try to alert the user if the session isn't interactive.Jeffrey Stedfast2001-09-243-27/+43 * /s/Algún nuve/Algunas nuves/Carlos Perelló Marín2001-09-232-1/+5 * Updated Slovenian translationAndraz Tori2001-09-231-1513/+1513 * Updated Spanish translation.Hector Garcia2001-09-232-167/+63 * Updated Slovenian translationAndraz Tori2001-09-231-5835/+3878 * when creating the cards, don't display any of the subname fields (surname,Chris Toshok2001-09-232-1/+7 * add getters for the additional name fields. (field_data): move FAMILY_NAMEChris Toshok2001-09-233-2/+41 * Bumped the version number to 0.12.99.0.Christopher James Lahey2001-09-233-7/+74 * Updated Polish translationChyla Zbigniew2001-09-222-3679/+3567 * Small fixKjartan Maraas2001-09-221-1/+1 * Updated Norwegian (bokmål) translation. Added camel/camel-vee-store.c andKjartan Maraas2001-09-223-182/+176 * Changed to 99. (VERSION): Added ".$EVOLUTION_MICRO_VERSION" suffix.Nat Friedman2001-09-222-2/+7 * Some grammar changes suggested by my girlfriend Amanda...props to Amanda!Kevin Breit2001-09-222-2/+4 * If we have an operation that failed before, dont show the dialogue for the12001-09-222-1/+32 * Sync for 0.14.Ettore Perazzoli2001-09-2232-50748/+72740 * Remove timezone.png...Iain Holmes2001-09-222-1/+4 * Hooked up print preview button.Christopher James Lahey2001-09-226-4/+121 * Add missing width/height tags to the sunny/cloudy/etc images to make theDan Winship2001-09-222-1/+8 * Set a timezone iconIain Holmes2001-09-222-1/+98 * Add timeszone-16.xpmIain Holmes2001-09-222-1/+7 * updated NEWSJeffrey Stedfast2001-09-221-0/+42 * Updated.12001-09-222-0/+50 * UpdateJP Rosevear2001-09-221-0/+2 * Use the mail-tools convenience functions to remove and restore theJeffrey Stedfast2001-09-223-74/+14 * Beta4 splashJakub Steiner2001-09-222-0/+4 * Expand a ~ in the pathIain Holmes2001-09-222-1/+6 * updated calendar & tasks stuffDamon Chaplin2001-09-221-0/+19 * Added mailer news I forgot earlier.Jon Trowbridge2001-09-221-2/+9 * All made redundant by new mail-folder-cache code. (delete_folders,Michael Zucci2001-09-224-113/+11 * Updated.Ettore Perazzoli2001-09-221-15/+17 * Update.Ettore Perazzoli2001-09-221-25/+52 * Set the exception if create_folder isn't implemented.12001-09-222-0/+8 * Added more NEWS items here.Christopher James Lahey2001-09-222-1/+22 * Go back to not using camel_folder_info_build() here because this seems toJeffrey Stedfast2001-09-222-4/+18 * Use url path as full_name, not shell path. (mail_local_folder_construct):12001-09-222-23/+13 * NEWSIain Holmes2001-09-221-0/+25 * Added some news for Ettore.Jon Trowbridge2001-09-221-0/+19 * Check for a component for the given row *after* trying to handleEttore Perazzoli2001-09-222-5/+14 * Verfied to make sure it was accurate against the calendar inKevin Breit2001-09-222-38/+145 * don't use gnome_vfs_uri_new_private (fixes Ximian #10544)Rodrigo Moya2001-09-213-14/+17 * *** empty log message ***Rodrigo Moya2001-09-211-0/+2 * Updated Slovak translation.Stanislav Visnovsky2001-09-212-850/+940 * Force a refresh of vfolders before storing their count. This essentially12001-09-214-3/+101 * Take a new argument 'done' that can callback when complete. Fixed callers12001-09-217-17/+46 * Instead of using pthread_cancel() which seems to have numerous12001-09-212-62/+56 * Dont let drafts/outbox/sent be added via a generic 'all local folders'02001-09-212-0/+8 * trigger a folder changed event, so the folderinfocache stuff has a chance02001-09-213-10/+29 * New function to just load the summary. Not much use yet, until unreadMichael Zucci2001-09-215-1/+96 * Only add the account if it doesn't already exist in the config db.Jeffrey Stedfast2001-09-214-3/+17 * updated NEWS for 0.14Jeffrey Stedfast2001-09-211-0/+16 * Do not add the account here as this is taken care of inJeffrey Stedfast2001-09-215-38/+48 * Update the status bar here, assuming we've just been activated.02001-09-216-22/+49 * Setup unread count properly, and also setup the url properly.Michael Zucci2001-09-214-13/+36 * move to DocBook 4.1Aaron Weber2001-09-2110-52/+71 * Turn off the o(x) debug set, & include alloca.h & config.h.02001-09-212-1/+10 * Turn off the o(x) debug set.02001-09-212-1/+5 * #include a few files we were missing from libgnomevfs.Federico Mena Quintero2001-09-213-0/+9 * Don't "note" the folder if we failed to get it.Jeffrey Stedfast2001-09-212-10/+10 * Set the sensitivity of the buttons correctlyIain Holmes2001-09-212-1/+8 * Update to reflect changes to mail_get_folder.Jeffrey Stedfast2001-09-212-1/+6 * Fixed a typo here where we were setting the running height based on theChristopher James Lahey2001-09-211-1/+1 * Removed. (folder_bar_popup_map_callback): Don't connect.Ettore Perazzoli2001-09-212-55/+34 * Remove the grab if ->grabbed.Ettore Perazzoli2001-09-211-0/+5 * Lock around hashtable/list manipulation. Also dont try scan vfolder_hash02001-09-219-102/+118 * Build the path on the folderinfo.02001-09-2111-27/+73 * Create nonexistant files.Iain Holmes2001-09-212-12/+8 * Set the folder info path.Jeffrey Stedfast2001-09-212-9/+13 * And finally here.Jeffrey Stedfast2001-09-217-27/+108 * Red Carpet RDFIain Holmes2001-09-212-0/+5 * Register vfolder sources here.02001-09-2111-12/+49 * Make a neater error reportIain Holmes2001-09-213-3/+8 * gets a config db (cal_backend_file_destroy): release config dbJP Rosevear2001-09-214-19/+174 * Dont special case file: url's anymore.02001-09-214-41/+89 * Convert all textual parts to 8bit before saving. Fixes bug #10388.Jeffrey Stedfast2001-09-213-2/+39 * Only start wizard thing if there are no mail accountsIain Holmes2001-09-212-4/+9 * don't free memory that we don't own.Jeffrey Stedfast2001-09-212-5/+11 * No need to have g_warnings here. If it's done properly, therapeutically,Dan Winship2001-09-212-2/+6 * Nuke debug warning.Dan Winship2001-09-212-2/+4 * make sure to release the ref on priv->comp.Larry Ewing2001-09-203-0/+18 * Truncate extremely long subjects. (inspired by bug #9158)Jon Trowbridge2001-09-203-4/+22 * I'm slowly losing my mind.Jon Trowbridge2001-09-201-1/+0 * Yikes... fixing accidental breakage.Jon Trowbridge2001-09-201-1/+1 * Display a notification message always, in addition to playing the sound.Federico Mena Quintero2001-09-205-30/+72 * Use the default e-mail address if we have nothing else to go on.Jon Trowbridge2001-09-207-167/+136 * don't add to the complete list of cards if the card is a listJP Rosevear2001-09-202-5/+33 * Updated exception strings to be more clear.Jeffrey Stedfast2001-09-203-17/+23 * Change the "this should never happen" message into a request for people toJon Trowbridge2001-09-202-1/+10 * Here too.Jeffrey Stedfast2001-09-203-2/+11 * const fixIain Holmes2001-09-201-2/+2 * Fix memory leakIain Holmes2001-09-202-0/+5 * Remove dead directory from AC_OUTPUTJP Rosevear2001-09-202-1/+4 * Display a bell icon if there's an alarm setIain Holmes2001-09-203-3/+9 * Convert the names to the locale charset.Jeffrey Stedfast2001-09-202-14/+24 * Confirm row count here. (etsm_get_row_count): Make sure etsm->model isn'tChristopher James Lahey2001-09-201-1/+5 * Oops, don't fail if `data' isn't a CamelService...cuz it's not supposed toJeffrey Stedfast2001-09-202-1/+7 * Fixed a typo here. esa->rows += count, not esa->rows = count.Christopher James Lahey2001-09-201-1/+1 * Spewage removal Only open folders when they are needed.Iain Holmes2001-09-203-37/+20 * New member `tooltips' in `ETaskWidgetPrivate'. (init): Init to NULL.Ettore Perazzoli2001-09-202-0/+18 * Removed globals `activity_client', `progress'. (timeout_callback_3): GetEttore Perazzoli2001-09-206-8/+155 * be sure to unref the component.Larry Ewing2001-09-202-0/+7 * Open editors for tasks and appointmentsIain Holmes2001-09-203-6/+77 * remove redundant if. (open_callback): free the previous html even if weLarry Ewing2001-09-202-15/+17 * free the temp dup'd string.Larry Ewing2001-09-203-4/+16 * listen for model changes (task_editor_edit_comp): add the attendees to theJP Rosevear2001-09-209-106/+271 * Hack around gdkpixbuf lossage by not trying to display the imagesDan Winship2001-09-202-18/+25 * Fixed weird include pathRodrigo Moya2001-09-201-1/+1 * Freeing name[i] instead of namev[i] is a bad idea. (bug #10270)Jon Trowbridge2001-09-202-1/+4 * Pass the actual unread message count, not just whether or not it's > 0.Dan Winship2001-09-202-2/+8 * add OAFIID parameter to the call to the cal_factory_oaf_register functionRodrigo Moya2001-09-192-1/+8 * add a new parameter (const char *iid) to specify the OAFIID of the factoryRodrigo Moya2001-09-193-6/+27 * Added missing header.92001-09-194-4/+17 * Properly handle our GnomeUIInfo labels so that they won't be leaked ifJon Trowbridge2001-09-192-151/+137 * General cleanup of mail debug printfs.92001-09-1915-1005/+544 * General cleanup of camel debug printfs.92001-09-1918-40/+76 * remove silly debug #if 0JP Rosevear2001-09-194-4/+16 * more meetings-by-mail additions. Had no idea this needed so much work.Aaron Weber2001-09-198-48/+237 * ShushJP Rosevear2001-09-191-0/+1 * reflect file additions/removalsJP Rosevear2001-09-192-2/+10 * A page that shows the meeting time selector and free/busy data forJP Rosevear2001-09-1924-789/+7539 * the meeting-time-sel dir is dead, relevant pieces moved to calendar/guiJP Rosevear2001-09-1914-6000/+5 * Fixes bug #6350.Federico Mena Quintero2001-09-193-142/+174 * Select next rowsIain Holmes2001-09-192-1/+9 * Make the title translatable, and also use the account name when possible.Jeffrey Stedfast2001-09-192-2/+20 * Keep the mail folders in the correct orderIain Holmes2001-09-193-4/+32 * s/List-Owner/List-PostJeffrey Stedfast2001-09-191-1/+1 * New arg @row. Highlight that row. (tree_drag_motion): Pass @row toEttore Perazzoli2001-09-192-1/+11 * Don't add folders multiple timesIain Holmes2001-09-192-1/+15 * Match mailing-list header List-Owner.Jeffrey Stedfast2001-09-192-0/+5 * Attach an X-Evolution-Format header so if people re-edit a message in sayJeffrey Stedfast2001-09-192-11/+18 * Function to get the real receive tpe for ag iven url. IMAP/SPOOL/MAILDIR72001-09-192-9/+21 * If filter inbox is set on the store, and we're opening inbox '', then82001-09-1924-146/+544 * Oops, forgot about X-Evolution-Format.Jeffrey Stedfast2001-09-193-1/+12 * Merged into folder_browser_new: nothing ever changes the URI of anDan Winship2001-09-196-41/+36 * Fixes bug #2830.Federico Mena Quintero2001-09-196-28/+109 * Added verbose error reporting in rdf summariesIain Holmes2001-09-192-6/+26 * new class for managing multiple calendars, with an API very similar to theRodrigo Moya2001-09-1916-364/+1436 * Pass a 'cache-me' argument to mail_get_password.Jeffrey Stedfast2001-09-194-30/+52 * Call mail_content_loaded here rather than blocking if the message dataDan Winship2001-09-192-0/+10 * Virtualize this.Dan Winship2001-09-195-6/+56 * #include "e-gtk-utils.h".Ettore Perazzoli2001-09-192-1/+8 * Added korean charset conversion.Jeffrey Stedfast2001-09-192-0/+5 * add caluri field dataJP Rosevear2001-09-197-13/+232 * Make the canvas backing stored.Ettore Perazzoli2001-09-192-0/+6 * Use ->bin_window [instead of ->window] if the widget is a GtkLayout.Ettore Perazzoli2001-09-192-2/+14 * Added a tip about the always encrypt button.Kevin Breit2001-09-19