aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 6 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 03cc1e6206..85e864a8a6 100644
--- a/configure.in
+++ b/configure.in
@@ -144,12 +144,15 @@ save_CFLAGS="$CFLAGS"
save_LIBS="$LIBS"
CFLAGS="$CFLAGS $ICONV_CFLAGS"
LIBS="$LIBS $ICONV_LIBS -liconv"
-AC_CACHE_CHECK(for iconv in -liconv, ac_cv_libiconv, AC_TRY_LINK([
+AC_CACHE_CHECK(for iconv in -liconv, ac_cv_libiconv, AC_TRY_RUN([
#include <iconv.h>
-], [
+
+int main (int argc, char **argv)
+{
iconv_t cd;
cd = iconv_open ("UTF-8", "ISO-8859-1");
-], ac_cv_libiconv=yes, ac_cv_libiconv=no))
+}
+], ac_cv_libiconv=yes, ac_cv_libiconv=no, ac_cv_libiconv=no))
if test $ac_cv_libiconv = yes; then
ICONV_LIBS="$ICONV_LIBS -liconv"
have_iconv=yes