aboutsummaryrefslogtreecommitdiffstats
path: root/help/devel/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'help/devel/Makefile.am')
-rw-r--r--help/devel/Makefile.am42
1 files changed, 27 insertions, 15 deletions
diff --git a/help/devel/Makefile.am b/help/devel/Makefile.am
index 0d3cec5a1c..0dd533057e 100644
--- a/help/devel/Makefile.am
+++ b/help/devel/Makefile.am
@@ -10,28 +10,42 @@ HTML_DIR=$(datadir)/gnome/html
TARGET_DIR=$(HTML_DIR)/$(DOC_MODULE)
-evolution_devel_guidedir = $(HTML_DIR)
-evolution_devel_guide_DATA = \
- evolution-devel-guide.html
+# Add your toplevel files here
-content_files = \
- evolution-devel-guide.sgml
+content_files = \
+ evolution-devel-guide.sgml \
+ fdl.sgml \
+ preface.sgml \
+ reference.sgml
-EXTRA_DIST = \
- $(evolution_devel_guide_DATA) \
+# Add your module's hand-written and auto-generated files here; these
+# are used for dependency tracking.
+
+local_entities = \
+ calendar/architecture.sgml \
+ calendar/evolution-calendar.sgml \
+ calendar/public-reference.sgml \
+ \
+ calendar/cal-client/sgml/cal-client.sgml \
+ \
+ calendar/cal-util/sgml/cal-component.sgml \
+ calendar/cal-util/sgml/cal-recur.sgml \
+ calendar/cal-util/sgml/cal-util.sgml \
+ calendar/cal-util/sgml/timeutil.sgml
+
+EXTRA_DIST = \
$(content_files)
+all: evolution-devel-guide.html
+
if ENABLE_GTK_DOC
-evolution-devel-guide.html: html/book1.html
- -cd $(srcdir) && cp html/book1.html evolution-devel-guide.html
+evolution-devel-guide.html: html/index.html
+ -cd $(srcdir) && cp html/index.html evolution-devel-guide.html
else
evolution-devel-guide.html:
endif
-html/book1.html: $(content-files)
- $(MAKE) html
-
-html:
+html/index.html: $(content_files) $(local_entities)
test -d $(srcdir)/html || mkdir $(srcdir)/html
-cd $(srcdir)/html && gtkdoc-mkhtml $(DOC_MODULE) ../$(DOC_MAIN_SGML_FILE)
@@ -60,5 +74,3 @@ install-data-local:
dist-hook:
mkdir $(distdir)/html
-cp $(srcdir)/html/*.html $(srcdir)/html/*.css $(distdir)/html
-
-.PHONY: html
n/devel/electron6/files/ini-1.3.8&id=9c32eec0fe3df37ab77099dddc0ec35a2997aaf0'>- Define APACHE_COMPATclement2005-09-191-0/+1 * Change PORTNAME & DISTNAME to reflect repocopy nameache2005-05-161-3/+3 * At Kris's request, back out the MACHINE_ARCH spelling correction untilobrien2005-04-121-1/+1 * Assist getting more ports working on AMD64 by obeying theobrien2005-04-111-1/+1 * Split the postgresql ports into a server and a client part.girgen2005-01-311-2/+1 * Switch to mysql41-client as defaultache2005-01-141-1/+1 * Add missing filekris2004-11-131-0/+1 * OPTIONS not counted when PARALLEL_PACKAGE_BUILD, workaroundache2004-06-151-0/+4 * Issue missing DB specs error at pre-configure stage, allowing all previous.ache2004-06-141-2/+2 * Use LOCALBASE for libtoolache2004-06-142-1/+2 * Properly detect <netinet/ip.h>ache2004-06-142-6/+16 * Use libtool from portsache2004-06-142-2/+49 * Upgrade to 3.1.21ache2004-05-216-53/+47 * Add size data, approved by maintainers.trevor2004-03-211-0/+1 * Whoa there, boy, that's a mighty big commit y'all have there...ade2004-03-14