aboutsummaryrefslogtreecommitdiffstats
path: root/smime/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'smime/lib/Makefile.am')
-rw-r--r--smime/lib/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/smime/lib/Makefile.am b/smime/lib/Makefile.am
index f534fd01f3..a9068e3b18 100644
--- a/smime/lib/Makefile.am
+++ b/smime/lib/Makefile.am
@@ -16,6 +16,7 @@ INCLUDES = \
noinst_LTLIBRARIES = libessmime.la
libessmime_la_SOURCES = \
+ $(MARSHAL_GENERATED) \
e-asn1-object.c \
e-asn1-object.h \
e-cert.c \
@@ -26,3 +27,9 @@ libessmime_la_SOURCES = \
e-cert-db.h \
e-pkcs12.c \
e-pkcs12.h
+
+MARSHAL_GENERATED = smime-marshal.c smime-marshal.h
+@EVO_MARSHAL_RULE@
+
+BUILT_SOURCES = $(MARSHAL_GENERATED)
+CLEANFILES = $(BUILT_SOURCES)