aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-12-18 00:11:01 +0800
committermat <mat@FreeBSD.org>2016-12-18 00:11:01 +0800
commit016e8294ee7d55dfcce48a05e81b740e16f009cf (patch)
treef9b67e6b5995c73db7607eb5b462f9f693a7b27f
parent1c1966c618b44f44cdaac0570b37b6a3be25e5df (diff)
downloadfreebsd-ports-gnome-016e8294ee7d55dfcce48a05e81b740e16f009cf.tar.gz
freebsd-ports-gnome-016e8294ee7d55dfcce48a05e81b740e16f009cf.tar.zst
freebsd-ports-gnome-016e8294ee7d55dfcce48a05e81b740e16f009cf.zip
Whatever you do, ${PORTSDIR}/ keeps creeping back.
Sponsored by: Absolight
-rw-r--r--comms/conserver-com/Makefile2
-rw-r--r--databases/p5-DBIx-Admin-TableInfo/Makefile2
-rw-r--r--databases/php70-memcached/Makefile2
-rw-r--r--devel/p5-Test-DependentModules/Makefile2
-rw-r--r--games/alienarena/Makefile12
-rw-r--r--math/p5-Statistics-Descriptive/Makefile2
-rw-r--r--security/dotdotpwn/Makefile2
7 files changed, 12 insertions, 12 deletions
diff --git a/comms/conserver-com/Makefile b/comms/conserver-com/Makefile
index fddb2f87144e..58d38964a8ac 100644
--- a/comms/conserver-com/Makefile
+++ b/comms/conserver-com/Makefile
@@ -34,7 +34,7 @@ DEFAULTPORT?= 782
DEFAULTHOST?= localhost
FREEIPMI_CONFIGURE_ON= --with-freeipmi=${LOCALBASE}
-FREEIPMI_LIB_DEPENDS= libfreeipmi.so:${PORTSDIR}/sysutils/freeipmi
+FREEIPMI_LIB_DEPENDS= libfreeipmi.so:sysutils/freeipmi
GSSAPI_CONFIGURE_WITH= gssapi
GSSAPIONLY_EXTRA_PATCHES= ${FILESDIR}/extra-patch-conserver__master.c
STRIPREALM_CONFIGURE_WITH= striprealm
diff --git a/databases/p5-DBIx-Admin-TableInfo/Makefile b/databases/p5-DBIx-Admin-TableInfo/Makefile
index 822bfdef09c4..6214ae21b43f 100644
--- a/databases/p5-DBIx-Admin-TableInfo/Makefile
+++ b/databases/p5-DBIx-Admin-TableInfo/Makefile
@@ -20,7 +20,7 @@ BUILD_DEPENDS= p5-DBI>=0:databases/p5-DBI \
p5-Data-Dumper-Concise>=2.022:devel/p5-Data-Dumper-Concise \
p5-Lingua-EN-PluralToSingular>=0.18:textproc/p5-Lingua-EN-PluralToSingular \
p5-Moo>=2.002004:devel/p5-Moo \
- p5-Text-Table-Manifold>=1:${PORTSDIR}/textproc/p5-Text-Table-Manifold
+ p5-Text-Table-Manifold>=1:textproc/p5-Text-Table-Manifold
RUN_DEPENDS:= ${BUILD_DEPENDS}
NO_ARCH= yes
diff --git a/databases/php70-memcached/Makefile b/databases/php70-memcached/Makefile
index 768146b06bda..d1e5ff138058 100644
--- a/databases/php70-memcached/Makefile
+++ b/databases/php70-memcached/Makefile
@@ -29,6 +29,6 @@ GH_TAGNAME= c032fba
PHP_MODNAME= memcached
SASL_CONFIGURE_ENABLE= memcached-sasl
-SASL_LIB_DEPENDS= libsasl2.so:${PORTSDIR}/security/cyrus-sasl2
+SASL_LIB_DEPENDS= libsasl2.so:security/cyrus-sasl2
.include <bsd.port.mk>
diff --git a/devel/p5-Test-DependentModules/Makefile b/devel/p5-Test-DependentModules/Makefile
index 2688de858901..e4595267087b 100644
--- a/devel/p5-Test-DependentModules/Makefile
+++ b/devel/p5-Test-DependentModules/Makefile
@@ -33,7 +33,7 @@ USES= perl5
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} >= 502200
-TEST_DEPENDS+= p5-Module-Build>=0:${PORTSDIR}/devel/p5-Module-Build
+TEST_DEPENDS+= p5-Module-Build>=0:devel/p5-Module-Build
.endif
.include <bsd.port.post.mk>
diff --git a/games/alienarena/Makefile b/games/alienarena/Makefile
index 9f07ca5dbb50..7c3bda38c53d 100644
--- a/games/alienarena/Makefile
+++ b/games/alienarena/Makefile
@@ -14,7 +14,7 @@ DISTNAME= ${PORTNAME}-7.66-linux20130827
MAINTAINER= acm@FreeBSD.org
COMMENT= Alien Arena (native version)
-RUN_DEPENDS= ${DATADIR}/data1/default.cfg:${PORTSDIR}/games/alienarena-data
+RUN_DEPENDS= ${DATADIR}/data1/default.cfg:games/alienarena-data
USES= compiler:c++11-lib dos2unix gmake
USE_CXXSTD= c++11
@@ -49,11 +49,11 @@ LIBDIR= ${PREFIX}/lib/${PORTNAME}
.if ${PORT_OPTIONS:MCLIENT}
USES+= openal:soft,alut pkgconfig
-LIB_DEPENDS+= libcurl.so:${PORTSDIR}/ftp/curl \
- libfreetype.so:${PORTSDIR}/print/freetype2 \
- libjpeg.so:${PORTSDIR}/graphics/jpeg \
- libpng16.so:${PORTSDIR}/graphics/png \
- libvorbis.so:${PORTSDIR}/audio/libvorbis
+LIB_DEPENDS+= libcurl.so:ftp/curl \
+ libfreetype.so:print/freetype2 \
+ libjpeg.so:graphics/jpeg \
+ libpng16.so:graphics/png \
+ libvorbis.so:audio/libvorbis
BUILD_DEPENDS+= ${LOCALBASE}/lib/libode.a:devel/ode
USE_GL= yes
USE_XORG= xxf86dga xxf86vm
diff --git a/math/p5-Statistics-Descriptive/Makefile b/math/p5-Statistics-Descriptive/Makefile
index 48ce2054ba3d..4961e843dd12 100644
--- a/math/p5-Statistics-Descriptive/Makefile
+++ b/math/p5-Statistics-Descriptive/Makefile
@@ -11,7 +11,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
COMMENT= Perl module that supplies statistical methods for perl5
-RUN_DEPENDS= p5-List-MoreUtils>=0:${PORTSDIR}/lang/p5-List-MoreUtils
+RUN_DEPENDS= p5-List-MoreUtils>=0:lang/p5-List-MoreUtils
USES= perl5
USE_PERL5= configure
diff --git a/security/dotdotpwn/Makefile b/security/dotdotpwn/Makefile
index ff15dde9445d..7d1d91db67cc 100644
--- a/security/dotdotpwn/Makefile
+++ b/security/dotdotpwn/Makefile
@@ -23,7 +23,7 @@ OPTIONS_SUB= yes
NMAP_DESC= ENABLE OS DETECTION FEATURE - REQUIRES NMAP
OPTIONS_DEFAULT= NMAP
-OSDETECTION_RUN_DEPENDS= nmap:${PORTSDIR}/security/nmap
+OSDETECTION_RUN_DEPENDS= nmap:security/nmap
USES= perl5 shebangfix