aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2017-10-08 03:10:45 +0800
committerrakuco <rakuco@FreeBSD.org>2017-10-08 03:10:45 +0800
commit08057b435210654d0ba7d65317863423d778ca57 (patch)
treed578b111637ed2600237d7cfc15b73681c1ffb75
parent32c5ecb7e4afb67f7fa79427c5a728a1de752f6c (diff)
downloadfreebsd-ports-gnome-08057b435210654d0ba7d65317863423d778ca57.tar.gz
freebsd-ports-gnome-08057b435210654d0ba7d65317863423d778ca57.tar.zst
freebsd-ports-gnome-08057b435210654d0ba7d65317863423d778ca57.zip
Pass -fPIC on armv7 as well.
This fixes the following build error: /usr/bin/ld: 7zEncode.o(.text+0x2d04): unresolvable R_ARM_MOVW_ABS_NC relocation against symbol `_ZTIi@@CXXABI_1.3' /usr/bin/ld: final link failed: Nonrepresentable section on output c++: error: linker command failed with exit code 1 (use -v to see invocation) PR: 222852 Submitted by: guyyur@gmail.com
-rw-r--r--archivers/p7zip/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/archivers/p7zip/Makefile b/archivers/p7zip/Makefile
index fbaaf469975c..9e2c2a21deec 100644
--- a/archivers/p7zip/Makefile
+++ b/archivers/p7zip/Makefile
@@ -20,6 +20,7 @@ MAKEFILE= makefile
MAKE_ARGS= OPTFLAGS="${CXXFLAGS}"
WRKSRC= ${WRKDIR}/${PORTNAME}_${PORTVERSION}
+CFLAGS_armv7= -fPIC
CFLAGS_aarch64= -fPIC
CFLAGS_amd64= -fPIC
CFLAGS_powerpc= -fPIC