aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorcrees <crees@FreeBSD.org>2013-12-29 22:50:31 +0800
committercrees <crees@FreeBSD.org>2013-12-29 22:50:31 +0800
commit123489578fa6fcb82a44689c62d4337729da8276 (patch)
treecec4a5c2ac8fb6e3e87cbc537549aefc29e453b1
parent4cfed2b80d6bad3f51afc627871862ff319dd492 (diff)
downloadfreebsd-ports-gnome-123489578fa6fcb82a44689c62d4337729da8276.tar.gz
freebsd-ports-gnome-123489578fa6fcb82a44689c62d4337729da8276.tar.zst
freebsd-ports-gnome-123489578fa6fcb82a44689c62d4337729da8276.zip
Stage devel and database ports maintained by me.
While here, add missing cvs dep and general cleanups
-rw-r--r--databases/vfront/Makefile8
-rw-r--r--devel/cvs2html/Makefile16
-rw-r--r--devel/fmake/Makefile14
-rw-r--r--devel/libcfu/Makefile3
-rw-r--r--devel/maven-ant-tasks/Makefile11
-rw-r--r--devel/maven-ant-tasks/pkg-descr2
-rw-r--r--devel/pybugz/Makefile1
-rw-r--r--devel/rclint/Makefile11
-rw-r--r--devel/ucpp/Makefile14
9 files changed, 34 insertions, 46 deletions
diff --git a/databases/vfront/Makefile b/databases/vfront/Makefile
index f6cc9cb322e0..3bdc883448e9 100644
--- a/databases/vfront/Makefile
+++ b/databases/vfront/Makefile
@@ -1,4 +1,3 @@
-# Created by: crees
# $FreeBSD$
PORTNAME= vfront
@@ -20,7 +19,6 @@ OPTIONS_MULTI= database
OPTIONS_MULTI_database= MYSQL PGSQL
OPTIONS_DEFAULT= MYSQL PGSQL
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MMYSQL}
@@ -45,10 +43,10 @@ pre-install:
${FIND} * -type d | ${SORT} -r | \
${SED} 's,^,@dirrmtry %%WWWDIR%%/,' >> ${PLIST})
@${ECHO_CMD} '@dirrmtry %%WWWDIR%%' >> ${PLIST}
+ @${ECHO_CMD} '@exec ${CHOWN} -R ${WWWOWN} %D/%%WWWDIR%%' >> ${PLIST}
+ @${ECHO_CMD} '@exec ${CHMOD} 700 %D/%%WWWDIR%%/conf' >> ${PLIST}
do-install:
- (cd ${WRKSRC} && ${COPYTREE_SHARE} \* ${WWWDIR})
- ${CHOWN} -R ${WWWOWN} ${WWWDIR}
- ${CHMOD} 700 ${WWWDIR}/conf
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} \* ${STAGEDIR}${WWWDIR})
.include <bsd.port.mk>
diff --git a/devel/cvs2html/Makefile b/devel/cvs2html/Makefile
index 18d314d2b51b..f99863e13b15 100644
--- a/devel/cvs2html/Makefile
+++ b/devel/cvs2html/Makefile
@@ -16,19 +16,19 @@ COMMENT= Perl script to turn ``cvs log'' output into HTML
LICENSE= GPLv2
+RUN_DEPENDS= cvs:${PORTSDIR}/devel/cvs
+
PLIST_FILES= bin/cvs2html
-USES= perl5
+NO_WRKSUBDIR= yes
NO_BUILD= yes
+USES= perl5 shebangfix
+SHEBANG_FILES= ${PORTNAME}
-NO_STAGE= yes
do-extract:
- @${MKDIR} ${WRKDIR}
- @${CP} ${DISTDIR}/${PORTNAME} ${WRKDIR}
-
-post-patch:
- ${REINPLACE_CMD} -e '1s|\(#!\).*$$|\1${PERL}|' ${WRKDIR}/${PORTNAME}
+ @${MKDIR} ${WRKSRC}
+ @${CP} ${DISTDIR}/${PORTNAME} ${WRKSRC}
do-install:
- ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/devel/fmake/Makefile b/devel/fmake/Makefile
index 2970924738c6..834be2a6208f 100644
--- a/devel/fmake/Makefile
+++ b/devel/fmake/Makefile
@@ -2,22 +2,22 @@
PORTNAME= fmake
PORTVERSION= r250982
+CATEGORIES= devel
MASTER_SITES= LOCAL/crees/${PORTNAME}/ \
http://www.bayofrum.net/dist/${PORTNAME}/
-CATEGORIES= devel
MAINTAINER= crees@FreeBSD.org
COMMENT= Legacy FreeBSD pmake
-PLIST_FILES= bin/${PORTNAME}
-MAN1= ${PORTNAME}.1
+LICENSE= BSD3CLAUSE # UCB third clause nullified
+
+PLIST_FILES= bin/${PORTNAME} man/man1/${PORTNAME}.1.gz
MAKE_ARGS+= PROG=fmake NO_MAN=yes
-NO_STAGE= yes
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
- ${INSTALL_MAN} ${WRKSRC}/make.1 \
- ${MAN1PREFIX}/man/man1/${PORTNAME}.1
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_MAN} ${WRKSRC}/make.1 \
+ ${STAGEDIR}${PREFIX}/man/man1/${PORTNAME}.1
.include <bsd.port.mk>
diff --git a/devel/libcfu/Makefile b/devel/libcfu/Makefile
index f8fa0456cdc3..5ceeb2e07559 100644
--- a/devel/libcfu/Makefile
+++ b/devel/libcfu/Makefile
@@ -8,7 +8,7 @@ MASTER_SITES= GH
MAINTAINER= crees@FreeBSD.org
COMMENT= Simple library of tools for developing multithreaded software
-LICENSE= BSD
+LICENSE= BSD3CLAUSE
USE_GITHUB= yes
GH_ACCOUNT= crees
@@ -25,7 +25,6 @@ INFO= ${PORTNAME}
# XXX: work around an issue with automake-1.13 erroring out on a
# non-existent m4 directory before libtoolize creates it
-NO_STAGE= yes
pre-configure::
@${MKDIR} ${WRKSRC}/m4
diff --git a/devel/maven-ant-tasks/Makefile b/devel/maven-ant-tasks/Makefile
index 08d8132e60af..986408a155b2 100644
--- a/devel/maven-ant-tasks/Makefile
+++ b/devel/maven-ant-tasks/Makefile
@@ -1,4 +1,3 @@
-# Created by: Chris Rees <utisoft@gmail.com>
# $FreeBSD$
PORTNAME= maven-ant-tasks
@@ -10,21 +9,19 @@ EXTRACT_SUFX= .jar
EXTRACT_ONLY=
MAINTAINER= crees@FreeBSD.org
-COMMENT= Allows Maven's artifact handling to be used from within an Ant build
-
-RUN_DEPENDS= ant:${PORTSDIR}/devel/apache-ant
+COMMENT= Allows Maven artifact handling to be used from within an Ant build
LICENSE= AL2
+RUN_DEPENDS= ant:${PORTSDIR}/devel/apache-ant
+
USE_JAVA= 1.5+
NO_BUILD= yes
-
PLIST_FILES= %%JAVASHAREDIR%%/apache-ant/lib/${DISTNAME}${EXTRACT_SUFX}
-NO_STAGE= yes
do-install:
@${INSTALL_DATA} ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} \
- ${JAVASHAREDIR}/apache-ant/lib/
+ ${STAGEDIR}${JAVASHAREDIR}/apache-ant/lib/
.include <bsd.port.mk>
diff --git a/devel/maven-ant-tasks/pkg-descr b/devel/maven-ant-tasks/pkg-descr
index a80668fe51da..6aac565de750 100644
--- a/devel/maven-ant-tasks/pkg-descr
+++ b/devel/maven-ant-tasks/pkg-descr
@@ -7,4 +7,4 @@ used from within an Ant build. These include:
integrated, other with extensions)
- POM processing - for reading and writing a Maven 2 pom.xml file
-WWW: http://maven.apache.org/ant-tasks/index.html
+WWW: http://maven.apache.org/ant-tasks/index.html
diff --git a/devel/pybugz/Makefile b/devel/pybugz/Makefile
index 116659839cdc..c2ac3a1bd3f2 100644
--- a/devel/pybugz/Makefile
+++ b/devel/pybugz/Makefile
@@ -20,5 +20,4 @@ PLIST_FILES= bin/bugz
DATADIR= ${PYTHONPREFIX_SITELIBDIR}/bugz
PORTDATA= *
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/devel/rclint/Makefile b/devel/rclint/Makefile
index f5766e9c98d0..b490167f29b7 100644
--- a/devel/rclint/Makefile
+++ b/devel/rclint/Makefile
@@ -9,7 +9,7 @@ MASTER_SITES= http://www.bayofrum.net/dist/rclint/ \
MAINTAINER= crees@FreeBSD.org
COMMENT= Checks rc scripts for style and common errors
-LICENSE= BSD
+LICENSE= BSD2CLAUSE
NO_BUILD= yes
USE_PYTHON= yes
@@ -18,16 +18,13 @@ SUB_FILES= ${PORTNAME}
PLIST_FILES= bin/${PORTNAME}
PORTDATA= ${PORTNAME}.py errors.en
-NO_STAGE= yes
post-patch:
${REINPLACE_CMD} -e "s,\(DATADIR = \)'\.',\1'${DATADIR}'," \
${WRKSRC}/${PORTNAME}.py
do-install:
- ${MKDIR} ${DATADIR}
-.for f in ${PORTDATA}
- ${INSTALL_SCRIPT} ${WRKSRC}/$f ${DATADIR}
-.endfor
- ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_SCRIPT} ${PORTDATA:S,^,${WRKSRC}/,} ${STAGEDIR}${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/devel/ucpp/Makefile b/devel/ucpp/Makefile
index 1dbd468a223d..425a323a852e 100644
--- a/devel/ucpp/Makefile
+++ b/devel/ucpp/Makefile
@@ -9,17 +9,15 @@ MASTER_SITES= GOOGLE_CODE
MAINTAINER= crees@FreeBSD.org
COMMENT= A C preprocessor and lexer
-LICENSE= BSD
+LICENSE= BSD3CLAUSE
-MAN1= ucpp.1
-PLIST_FILES= bin/ucpp
-USE_GMAKE= yes
+PLIST_FILES= bin/ucpp man/man1/ucpp.1.gz
+USES= gmake
-WRKSRC= ${WRKDIR}/${PORTNAME}
+WRKSRC= ${WRKDIR}/${PORTNAME}
-NO_STAGE= yes
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MAN1PREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${PREFIX}/man/man1/
.include <bsd.port.mk>