aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2019-06-03 20:43:33 +0800
committermat <mat@FreeBSD.org>2019-06-03 20:43:33 +0800
commit14342c90dc5499533fd00fca7990efb4ea6aa1ca (patch)
tree7dbdca46816de610cfc94363aa2cdb1cf8e3b7e0
parented9cb3eaaaf09e955551d821578abdf2d5f2c11e (diff)
downloadfreebsd-ports-gnome-14342c90dc5499533fd00fca7990efb4ea6aa1ca.tar.gz
freebsd-ports-gnome-14342c90dc5499533fd00fca7990efb4ea6aa1ca.tar.zst
freebsd-ports-gnome-14342c90dc5499533fd00fca7990efb4ea6aa1ca.zip
Update to latest commit.
-rw-r--r--dns/bind9-devel/Makefile6
-rw-r--r--dns/bind9-devel/distinfo6
-rw-r--r--dns/bind9-devel/files/extrapatch-bind-min-override-ttl12
-rw-r--r--dns/bind9-devel/files/patch-configure8
-rw-r--r--dns/bind9-devel/files/patch-lib_isc_include_isc_endian.h29
-rw-r--r--dns/bind9-devel/pkg-plist2
6 files changed, 47 insertions, 16 deletions
diff --git a/dns/bind9-devel/Makefile b/dns/bind9-devel/Makefile
index 4f51dfaf15c5..b57d88c81494 100644
--- a/dns/bind9-devel/Makefile
+++ b/dns/bind9-devel/Makefile
@@ -41,13 +41,13 @@ RUN_DEPENDS= bind-tools>0:dns/bind-tools
# XXX: remove tar:bz2
USES= compiler:c11 cpe libedit ssl tar:bz2
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.15.0a0.2019.05.17
+ISCVERSION= 9.15.0a0.2019.06.03
# XXX: Remove gitlab
USE_GITLAB= yes
GL_SITE= https://gitlab.isc.org
GL_ACCOUNT= isc-projects
GL_PROJECT= bind9
-GL_COMMIT= 4d30aee3e22052e7d9eb7d37f0ba79690b711570
+GL_COMMIT= bae12f569d19ce02e32718c5f7e55be93bef1f21
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
@@ -173,7 +173,7 @@ IDN_CONFIGURE_ON= --with-libidn2=${LOCALBASE} ${ICONV_CONFIGURE_BASE}
IDN_LIB_DEPENDS= libidn2.so:dns/libidn2
IDN_USES= iconv
-JSON_CONFIGURE_WITH= libjson=${LOCALBASE}
+JSON_CONFIGURE_WITH= json-c
JSON_LIB_DEPENDS= libjson-c.so:devel/json-c
LARGE_FILE_CONFIGURE_ENABLE= largefile
diff --git a/dns/bind9-devel/distinfo b/dns/bind9-devel/distinfo
index 50229bc7fc7c..98157afcdd82 100644
--- a/dns/bind9-devel/distinfo
+++ b/dns/bind9-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1558349753
-SHA256 (isc-projects-bind9-4d30aee3e22052e7d9eb7d37f0ba79690b711570_GL0.tar.gz) = dcab63fa391aa0502bbd32de10248fa45fd5da556b5abf796d4af8e8da1eeee6
-SIZE (isc-projects-bind9-4d30aee3e22052e7d9eb7d37f0ba79690b711570_GL0.tar.gz) = 6299222
+TIMESTAMP = 1559556042
+SHA256 (isc-projects-bind9-bae12f569d19ce02e32718c5f7e55be93bef1f21_GL0.tar.gz) = da35b424687c38b82961b16bfc2722c936a4e0b254edadc87a39fd7da97e9825
+SIZE (isc-projects-bind9-bae12f569d19ce02e32718c5f7e55be93bef1f21_GL0.tar.gz) = 6304252
diff --git a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
index 1983c34d0af9..aa291b688f2e 100644
--- a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
@@ -1,4 +1,4 @@
---- bin/named/config.c.orig 2019-05-13 03:51:14 UTC
+--- bin/named/config.c.orig 2019-06-03 05:32:29 UTC
+++ bin/named/config.c
@@ -176,6 +176,7 @@ options {\n\
notify-source *;\n\
@@ -8,7 +8,7 @@
provide-ixfr true;\n\
qname-minimization relaxed;\n\
query-source address *;\n\
---- bin/named/server.c.orig 2019-05-13 03:51:14 UTC
+--- bin/named/server.c.orig 2019-06-03 05:32:29 UTC
+++ bin/named/server.c
@@ -4231,6 +4231,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
}
@@ -22,7 +22,7 @@
result = named_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asuint32(obj);
---- lib/dns/include/dns/view.h.orig 2019-05-13 03:51:14 UTC
+--- lib/dns/include/dns/view.h.orig 2019-06-03 05:32:29 UTC
+++ lib/dns/include/dns/view.h
@@ -152,6 +152,7 @@ struct dns_view {
bool requestnsid;
@@ -32,9 +32,9 @@
dns_ttl_t maxncachettl;
dns_ttl_t mincachettl;
dns_ttl_t minncachettl;
---- lib/dns/resolver.c.orig 2019-05-13 03:51:14 UTC
+--- lib/dns/resolver.c.orig 2019-06-03 05:32:29 UTC
+++ lib/dns/resolver.c
-@@ -6024,6 +6024,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_adb
+@@ -6048,6 +6048,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_adb
}
/*
@@ -47,7 +47,7 @@
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl) {
---- lib/isccfg/namedconf.c.orig 2019-05-13 03:51:14 UTC
+--- lib/isccfg/namedconf.c.orig 2019-06-03 05:32:29 UTC
+++ lib/isccfg/namedconf.c
@@ -1899,6 +1899,7 @@ view_clauses[] = {
#endif
diff --git a/dns/bind9-devel/files/patch-configure b/dns/bind9-devel/files/patch-configure
index 9619115acf59..ca050e859bf4 100644
--- a/dns/bind9-devel/files/patch-configure
+++ b/dns/bind9-devel/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2019-05-13 03:51:14 UTC
+--- configure.orig 2019-06-03 05:32:29 UTC
+++ configure
-@@ -16598,27 +16598,9 @@ done
+@@ -16656,27 +16656,9 @@ done
# problems start to show up.
saved_libs="$LIBS"
for TRY_LIBS in \
@@ -30,7 +30,7 @@
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking linking as $TRY_LIBS" >&5
$as_echo_n "checking linking as $TRY_LIBS... " >&6; }
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-@@ -16661,47 +16643,7 @@ $as_echo "no" >&6; } ;;
+@@ -16719,47 +16701,7 @@ $as_echo "no" >&6; } ;;
no) as_fn_error $? "could not determine proper GSSAPI linkage" "$LINENO" 5 ;;
esac
@@ -79,7 +79,7 @@
DNS_GSSAPI_LIBS="$LIBS"
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: using GSSAPI from $use_gssapi/lib and $use_gssapi/include" >&5
-@@ -21187,7 +21129,7 @@ $as_echo "" >&6; }
+@@ -21310,7 +21252,7 @@ $as_echo "" >&6; }
# Check other locations for includes.
# Order is important (sigh).
diff --git a/dns/bind9-devel/files/patch-lib_isc_include_isc_endian.h b/dns/bind9-devel/files/patch-lib_isc_include_isc_endian.h
new file mode 100644
index 000000000000..c44460fc4c2a
--- /dev/null
+++ b/dns/bind9-devel/files/patch-lib_isc_include_isc_endian.h
@@ -0,0 +1,29 @@
+--- lib/isc/include/isc/endian.h.orig 2019-06-03 12:08:25 UTC
++++ lib/isc/include/isc/endian.h
+@@ -43,14 +43,26 @@
+
+ # include <sys/endian.h>
+
++#ifndef be16toh
+ # define be16toh(x) betoh16(x)
++#endif
++#ifndef le16toh
+ # define le16toh(x) letoh16(x)
++#endif
+
++#ifndef be32toh
+ # define be32toh(x) betoh32(x)
++#endif
++#ifndef le32toh
+ # define le32toh(x) letoh32(x)
++#endif
+
++#ifndef be64toh
+ # define be64toh(x) betoh64(x)
++#endif
++#ifndef le64toh
+ # define le64toh(x) letoh64(x)
++#endif
+
+ #elif defined(_WIN32)
+ /* Windows is always little endian */
diff --git a/dns/bind9-devel/pkg-plist b/dns/bind9-devel/pkg-plist
index 62d74c06f798..a07d83f71408 100644
--- a/dns/bind9-devel/pkg-plist
+++ b/dns/bind9-devel/pkg-plist
@@ -139,6 +139,7 @@ include/isc/counter.h
include/isc/crc64.h
include/isc/deprecated.h
include/isc/dir.h
+include/isc/endian.h
include/isc/errno.h
include/isc/error.h
include/isc/event.h
@@ -196,6 +197,7 @@ include/isc/resultclass.h
include/isc/rwlock.h
include/isc/safe.h
include/isc/serial.h
+include/isc/siphash.h
include/isc/sockaddr.h
include/isc/socket.h
include/isc/stat.h