aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2018-01-16 06:05:30 +0800
committermadpilot <madpilot@FreeBSD.org>2018-01-16 06:05:30 +0800
commit149daa525570c6fdf5f6ee5c68c7340119a30dc9 (patch)
treec65441bf889d4d6fd555ea702103d8a49933c4b9
parenta93e2d42c7dc15e62b5d841dfd755819e29de33e (diff)
downloadfreebsd-ports-gnome-149daa525570c6fdf5f6ee5c68c7340119a30dc9.tar.gz
freebsd-ports-gnome-149daa525570c6fdf5f6ee5c68c7340119a30dc9.tar.zst
freebsd-ports-gnome-149daa525570c6fdf5f6ee5c68c7340119a30dc9.zip
Merge the nox11 version of unison with the main port as a flavor.
Reviewed by: bsam, mat Approved by: bsam, portmgr (mat) Differential Revision: https://reviews.freebsd.org/D13783
-rw-r--r--MOVED1
-rw-r--r--net/unison-nox11/Makefile14
-rw-r--r--net/unison/Makefile67
3 files changed, 44 insertions, 38 deletions
diff --git a/MOVED b/MOVED
index f52928c58c8d..54bc533b41ec 100644
--- a/MOVED
+++ b/MOVED
@@ -9857,3 +9857,4 @@ devel/ruby-calendar||2018-01-15|Has expired: Does not build with current version
devel/ruby-rbbr||2018-01-15|Has expired: Does not build with current versions of ruby
devel/ruby-date2||2018-01-15|Has expired: Does not build with current versions of ruby
audio/ruby-xmms2||2018-01-15|Has expired: Does not build with current versions of ruby
+net/unison-nox11|net/unison@nox11|2018-01-15|Moved to a flavored, generic, version
diff --git a/net/unison-nox11/Makefile b/net/unison-nox11/Makefile
deleted file mode 100644
index 167b54954514..000000000000
--- a/net/unison-nox11/Makefile
+++ /dev/null
@@ -1,14 +0,0 @@
-# Created by: Boris Samorodov <bsam@FreeBSD.org>
-# $FreeBSD$
-
-PKGNAMESUFFIX= -nox11
-
-MAINTAINER= bsam@FreeBSD.org
-COMMENT= User-level file synchronization tool (without x11 stuff)
-
-CONFLICTS= unison-[0-9]* unison-devel-[0-9]*
-
-OPTIONS_EXCLUDE= X11
-MASTERDIR= ${.CURDIR}/../unison
-
-.include "${MASTERDIR}/Makefile"
diff --git a/net/unison/Makefile b/net/unison/Makefile
index 56370df9b7ea..5cf0ae7e6355 100644
--- a/net/unison/Makefile
+++ b/net/unison/Makefile
@@ -3,24 +3,37 @@
PORTNAME= unison
PORTVERSION= 2.48.4
-PORTREVISION?= 2
+PORTREVISION= 3
CATEGORIES= net
MASTER_SITES= http://www.cis.upenn.edu/~bcpierce/unison/download/releases/${DISTNAME}/
DISTFILES= ${EXTRACT_ONLY} ${EXTRA_DOCS}
DIST_SUBDIR= ${DISTNAME}
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
-MAINTAINER?= madpilot@FreeBSD.org
-COMMENT?= User-level file synchronization tool
+MAINTAINER= madpilot@FreeBSD.org
+COMMENT= User-level file synchronization tool
LICENSE= GPLv3
+FLAVORS= x11 nox11
+FLAVOR?= ${FLAVORS[1]}
+
+nox11_PKGNAMESUFFIX= -nox11
+nox11_CONFLICTS_INSTALL= unison
+
+x11_CONFLICTS_INSTALL= unison-nox11
+x11_BUILD_DEPENDS= lablgtk2:x11-toolkits/ocaml-lablgtk2 \
+ icotool:graphics/icoutils
+x11_LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2
+x11_RUN_DEPENDS= lablgtk2:x11-toolkits/ocaml-lablgtk2
+
PLIST_SUB= PORTVERSION=${PORTVERSION}
USES= gmake localbase
USE_OCAML= yes
WRKSRC= ${WRKDIR}/src
NO_OCAML_RUNDEPENDS=yes
-CONFLICTS?= unison-devel-[0-9]* unison-nox11-[0-9]*
+CONFLICTS= unison-devel-[0-9]*
MAKE_ENV= CLIBS="${LIBS:S/^-/-ccopt -/}" COFLAGS="${CFLAGS:C/ *(-[^ ]*) */ -ccopt \"\1 \"/gW}"
MAKE_JOBS_UNSAFE= yes
ALL_TARGET= unison all
@@ -29,8 +42,8 @@ DOCS= BUGS.txt NEWS README
EXTRA_DOCS= ${DISTNAME}-manual.html \
${DISTNAME}-manual.pdf ${DISTNAME}-manual.ps
-OPTIONS_DEFINE= DOCS FSMONITOR X11
-OPTIONS_DEFAULT?= FSMONITOR X11
+OPTIONS_DEFINE= DOCS FSMONITOR
+OPTIONS_DEFAULT?= FSMONITOR
FSMONITOR_DESC= Compile and install fsmonitor plugin
@@ -38,46 +51,52 @@ OPTIONS_SUB= YES
FSMONITOR_LIB_DEPENDS= libinotify.so:devel/libinotify
-X11_MAKE_ARGS= UISTYLE=gtk2
-X11_BUILD_DEPENDS= lablgtk2:x11-toolkits/ocaml-lablgtk2 \
- icotool:graphics/icoutils
-X11_RUN_DEPENDS= lablgtk2:x11-toolkits/ocaml-lablgtk2
-X11_SUB_FILES= ${PORTNAME}.desktop
-
-X11_MAKE_ARGS_OFF= UISTYLE=text
-X11_VARS_OFF= PKGMESSAGE=${PKGDIR}/pkg-message.nox11
+.if ${FLAVOR} == nox11
+MAKE_ARGS= UISTYLE=text
+PKGMESSAGE= ${PKGDIR}/pkg-message.nox11
+PLIST_SUB+= X11="@comment "
+.else
+MAKE_ARGS= UISTYLE=gtk2
+SUB_FILES= ${PORTNAME}.desktop
+USE_GNOME+= atk cairo gdkpixbuf2 glib20 gtk20 pango
+USES+= gettext-runtime
+PLIST_SUB+= X11=""
+.endif
post-patch-FSMONITOR-off:
@${REINPLACE_CMD} -e 's/-include fsmonitor/#&/' \
${WRKSRC}/Makefile.OCaml
-post-patch-X11-off:
+post-patch:
+.if ${FLAVOR} == nox11
@${REINPLACE_CMD} -e 's/CFLAGS/COFLAGS/g' \
${WRKSRC}/Makefile.OCaml ${WRKSRC}/fsmonitor/linux/Makefile
-
-post-patch-X11-on:
+.else
@${REINPLACE_CMD} -Ee 's@(\+|/)(lablgtk2)@\1site-lib/\2@' \
- -e 's/CFLAGS/COFLAGS/g' \
+ -e 's/CFLAGS/COFLAGS/g' \
${WRKSRC}/Makefile.OCaml ${WRKSRC}/fsmonitor/linux/Makefile
+.endif
-post-build-X11-on:
+.if ${FLAVOR} == x11
+post-build:
@${ECHO} Building text-only version
@${ECHO} ${WRKSRC}
${SETENV} ${MAKE_ENV} ${MAKE_CMD} -C ${WRKSRC} UISTYLE=text NAME=unison-text
@cd ${WRKSRC}/win32rc && ${LOCALBASE}/bin/icotool -x U.ico
+.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
@${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${STAGEDIR}${DOCSDIR}
cd ${DISTDIR}/${DIST_SUBDIR} && ${INSTALL_DATA} ${EXTRA_DOCS} ${STAGEDIR}${DOCSDIR}
-
-do-install-FSMONITOR-on:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME}-fsmonitor ${STAGEDIR}${PREFIX}/bin
-
-do-install-X11-on:
+.if ${FLAVOR} == x11
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME}-text ${STAGEDIR}${PREFIX}/bin
${INSTALL_DATA} ${WRKDIR}/${PORTNAME}.desktop ${STAGEDIR}${DESKTOPDIR}
${INSTALL_DATA} ${WRKSRC}/win32rc/U_4_48x48x32.png ${STAGEDIR}${PREFIX}/share/pixmaps/${PORTNAME}.png
+.endif
+
+do-install-FSMONITOR-on:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME}-fsmonitor ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>