aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2016-06-28 19:56:03 +0800
committerehaupt <ehaupt@FreeBSD.org>2016-06-28 19:56:03 +0800
commit17f6229ad661e33b0aa8f9e950a77dd86e644b15 (patch)
tree1299cb471fd91f8fdb61e47bff484f1d8fed40fa
parent9e924aa390f37da5056970225fb281640c4508e5 (diff)
downloadfreebsd-ports-gnome-17f6229ad661e33b0aa8f9e950a77dd86e644b15.tar.gz
freebsd-ports-gnome-17f6229ad661e33b0aa8f9e950a77dd86e644b15.tar.zst
freebsd-ports-gnome-17f6229ad661e33b0aa8f9e950a77dd86e644b15.zip
Remove stray ICONV patch that breaks unicode support if NLS is disabled.
PR: 210654 Submitted by: yuri@rawbw.com
-rw-r--r--shells/bash/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/shells/bash/Makefile b/shells/bash/Makefile
index dde03018d86d..50abc1563fac 100644
--- a/shells/bash/Makefile
+++ b/shells/bash/Makefile
@@ -4,7 +4,7 @@
PORTNAME= bash
PATCHLEVEL= 46
PORTVERSION= 4.3.${PATCHLEVEL:S/^0//g}
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= shells
MASTER_SITES= GNU/${PORTNAME}
DISTNAME= ${PORTNAME}-${PORTVERSION:R}
@@ -52,7 +52,8 @@ PORTDOCS= FAQ INTRO CHANGES COMPAT NEWS POSIX RBASH README \
CONFIGURE_ARGS+= --without-bash-malloc \
--disable-rpath \
- --enable-disabled-builtins
+ --enable-disabled-builtins \
+ --with-libiconv-prefix=${ICONV_PREFIX}
CFLAGS+= -DUSE_MKTEMP=1 -DUSE_MKSTEMP=1
@@ -96,10 +97,6 @@ post-patch:
post-configure:
@${FIND} ${WRKSRC} -name Makefile -print0 | ${XARGS} -0 \
${REINPLACE_CMD} -e "s|^DESTDIR *=|& ${DESTDIR}|"
-.if empty(PORT_OPTIONS:MNLS)
- @${REINPLACE_CMD} -e "s|#define HAVE_ICONV 1|#undef HAVE_ICONV|g" \
- ${WRKSRC}/config.h
-.endif
pre-build:
@${ECHO_CMD} $$((${PORTREVISION}-1)) > ${WRKSRC}/.build