aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-04-22 17:35:08 +0800
committerbapt <bapt@FreeBSD.org>2014-04-22 17:35:08 +0800
commit1e40632456a67d3576f908ad441fc21537321a98 (patch)
tree870fa844aff55197e5f4cf4f209aaf3fca5511d9
parent5d272e8864cc889dbc2adf6435aa16640504ad02 (diff)
downloadfreebsd-ports-gnome-1e40632456a67d3576f908ad441fc21537321a98.tar.gz
freebsd-ports-gnome-1e40632456a67d3576f908ad441fc21537321a98.tar.zst
freebsd-ports-gnome-1e40632456a67d3576f908ad441fc21537321a98.zip
Support stage
respect EXAMPLES
-rw-r--r--x11-toolkits/py-gnome2/Makefile33
-rw-r--r--x11-toolkits/py-gnome2/pkg-plist62
2 files changed, 45 insertions, 50 deletions
diff --git a/x11-toolkits/py-gnome2/Makefile b/x11-toolkits/py-gnome2/Makefile
index 76485846a4c7..1f6e0a1913dd 100644
--- a/x11-toolkits/py-gnome2/Makefile
+++ b/x11-toolkits/py-gnome2/Makefile
@@ -4,7 +4,7 @@
PORTNAME= gnome
PORTVERSION= 2.28.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= x11-toolkits python gnome
MASTER_SITES= GNOME
MASTER_SITE_SUBDIR= sources/gnome-python/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
@@ -15,35 +15,30 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= A set of Python bindings for GNOME 2
+OPTIONS_DEFINE= EXAMPLES
+
+OPTIONS_SUB= yes
+
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/ORBit.so:${PORTSDIR}/devel/py-orbit
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/ORBit.so:${PORTSDIR}/devel/py-orbit
-LATEST_LINK= py-gnome2
-USE_BZIP2= yes
USE_PYTHON= 2
USE_LDCONFIG= yes
-USES= gettext gmake pkgconfig
-USE_GNOME= gnomehack libgnomeui pygtk2
+USES= gettext gmake libtool pathfix pkgconfig tar:bzip2
+USE_GNOME= libgnomeui pygtk2
GNU_CONFIGURE= yes
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
CPPFLAGS+= -I${LOCALBASE}/include
+INSTALL_TARGET= install-strip
EG_SRC_DIR= ${WRKSRC}/examples
EG_DST_DIR= ${PREFIX}/share/examples/py-gnome
-CONFLICTS= py*-gnome-1*
-
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
-.if !defined(NOPORTDOCS)
post-install:
- ${MKDIR} ${EG_DST_DIR}
- ${TAR} -C ${EG_SRC_DIR} -cf - . | ${TAR} -C ${EG_DST_DIR} -xf -
- ${CHOWN} -R ${BINOWN}:${BINGRP} ${EG_DST_DIR}
- ${FIND} ${EG_DST_DIR} -type d -print | ${XARGS} ${CHMOD} 0755
- ${FIND} ${EG_DST_DIR} -type f -print | ${XARGS} ${CHMOD} 0444
-.endif
-
-.include <bsd.port.post.mk>
+ @${MKDIR} ${STAGEDIR}${EG_DST_DIR}
+ cd ${EG_SRC_DIR}; ${PAX} -rw . ${STAGEDIR}${EG_DST_DIR}
+ ${FIND} ${STAGEDIR}${EG_DST_DIR} -type d -print | ${XARGS} ${CHMOD} 0755
+ ${FIND} ${STAGEDIR}${EG_DST_DIR} -type f -print | ${XARGS} ${CHMOD} 0444
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/py-gnome2/pkg-plist b/x11-toolkits/py-gnome2/pkg-plist
index e3cca9b7284c..569785ef7f98 100644
--- a/x11-toolkits/py-gnome2/pkg-plist
+++ b/x11-toolkits/py-gnome2/pkg-plist
@@ -36,28 +36,28 @@ lib/gnome-vfs-2.0/modules/libpythonmethod.so
%%PYTHON_SITELIBDIR%%/gtk-2.0/gnomevfs/gnomevfsbonobo.la
%%PYTHON_SITELIBDIR%%/gtk-2.0/gnomevfs/gnomevfsbonobo.so
libdata/pkgconfig/gnome-python-2.0.pc
-%%PORTDOCS%%share/examples/py-gnome/bonobo/bonobo-application.py
-%%PORTDOCS%%share/examples/py-gnome/bonobo/bonoboui/Bonobo_Sample_Hello.xml
-%%PORTDOCS%%share/examples/py-gnome/bonobo/bonoboui/hello.py
-%%PORTDOCS%%share/examples/py-gnome/bonobo/echo/README
-%%PORTDOCS%%share/examples/py-gnome/bonobo/echo/echo-client.py
-%%PORTDOCS%%share/examples/py-gnome/bonobo/unknown.py
-%%PORTDOCS%%share/examples/py-gnome/bug-buddy-integration.py
-%%PORTDOCS%%share/examples/py-gnome/canvas/canvas-curve.py
-%%PORTDOCS%%share/examples/py-gnome/canvas/canvas-example.py
-%%PORTDOCS%%share/examples/py-gnome/gconf/basic-gconf-app.py
-%%PORTDOCS%%share/examples/py-gnome/gconf/simple-controller.py
-%%PORTDOCS%%share/examples/py-gnome/gconf/simple-view.py
-%%PORTDOCS%%share/examples/py-gnome/popt/goption.py
-%%PORTDOCS%%share/examples/py-gnome/popt/popt.py
-%%PORTDOCS%%share/examples/py-gnome/vfs/async-xfer.py
-%%PORTDOCS%%share/examples/py-gnome/vfs/async.py
-%%PORTDOCS%%share/examples/py-gnome/vfs/cancellation.py
-%%PORTDOCS%%share/examples/py-gnome/vfs/pygvfsmethod/README
-%%PORTDOCS%%share/examples/py-gnome/vfs/pygvfsmethod/pyfs.conf
-%%PORTDOCS%%share/examples/py-gnome/vfs/pygvfsmethod/pyfs.py
-%%PORTDOCS%%share/examples/py-gnome/vfs/shell.py
-%%PORTDOCS%%share/examples/py-gnome/vfs/sync-xfer.py
+%%EXAMPLES%%share/examples/py-gnome/bonobo/bonobo-application.py
+%%EXAMPLES%%share/examples/py-gnome/bonobo/bonoboui/Bonobo_Sample_Hello.xml
+%%EXAMPLES%%share/examples/py-gnome/bonobo/bonoboui/hello.py
+%%EXAMPLES%%share/examples/py-gnome/bonobo/echo/README
+%%EXAMPLES%%share/examples/py-gnome/bonobo/echo/echo-client.py
+%%EXAMPLES%%share/examples/py-gnome/bonobo/unknown.py
+%%EXAMPLES%%share/examples/py-gnome/bug-buddy-integration.py
+%%EXAMPLES%%share/examples/py-gnome/canvas/canvas-curve.py
+%%EXAMPLES%%share/examples/py-gnome/canvas/canvas-example.py
+%%EXAMPLES%%share/examples/py-gnome/gconf/basic-gconf-app.py
+%%EXAMPLES%%share/examples/py-gnome/gconf/simple-controller.py
+%%EXAMPLES%%share/examples/py-gnome/gconf/simple-view.py
+%%EXAMPLES%%share/examples/py-gnome/popt/goption.py
+%%EXAMPLES%%share/examples/py-gnome/popt/popt.py
+%%EXAMPLES%%share/examples/py-gnome/vfs/async-xfer.py
+%%EXAMPLES%%share/examples/py-gnome/vfs/async.py
+%%EXAMPLES%%share/examples/py-gnome/vfs/cancellation.py
+%%EXAMPLES%%share/examples/py-gnome/vfs/pygvfsmethod/README
+%%EXAMPLES%%share/examples/py-gnome/vfs/pygvfsmethod/pyfs.conf
+%%EXAMPLES%%share/examples/py-gnome/vfs/pygvfsmethod/pyfs.py
+%%EXAMPLES%%share/examples/py-gnome/vfs/shell.py
+%%EXAMPLES%%share/examples/py-gnome/vfs/sync-xfer.py
share/gtk-doc/html/pygnomevfs/class-gnomevfs-context.html
share/gtk-doc/html/pygnomevfs/class-gnomevfs-directoryhandle.html
share/gtk-doc/html/pygnomevfs/class-gnomevfs-drive.html
@@ -90,15 +90,15 @@ share/pygtk/2.0/defs/ui.defs
@dirrm share/gtk-doc/html/pygnomevfs
@dirrmtry share/gtk-doc/html
@dirrmtry share/gtk-doc
-%%PORTDOCS%%@dirrm share/examples/py-gnome/vfs/pygvfsmethod
-%%PORTDOCS%%@dirrm share/examples/py-gnome/vfs
-%%PORTDOCS%%@dirrm share/examples/py-gnome/popt
-%%PORTDOCS%%@dirrm share/examples/py-gnome/gconf
-%%PORTDOCS%%@dirrm share/examples/py-gnome/canvas
-%%PORTDOCS%%@dirrm share/examples/py-gnome/bonobo/echo
-%%PORTDOCS%%@dirrm share/examples/py-gnome/bonobo/bonoboui
-%%PORTDOCS%%@dirrm share/examples/py-gnome/bonobo
-%%PORTDOCS%%@dirrm share/examples/py-gnome
+%%EXAMPLES%%@dirrm share/examples/py-gnome/vfs/pygvfsmethod
+%%EXAMPLES%%@dirrm share/examples/py-gnome/vfs
+%%EXAMPLES%%@dirrm share/examples/py-gnome/popt
+%%EXAMPLES%%@dirrm share/examples/py-gnome/gconf
+%%EXAMPLES%%@dirrm share/examples/py-gnome/canvas
+%%EXAMPLES%%@dirrm share/examples/py-gnome/bonobo/echo
+%%EXAMPLES%%@dirrm share/examples/py-gnome/bonobo/bonoboui
+%%EXAMPLES%%@dirrm share/examples/py-gnome/bonobo
+%%EXAMPLES%%@dirrm share/examples/py-gnome
@dirrm %%PYTHON_SITELIBDIR%%/gtk-2.0/gnomevfs
@dirrm %%PYTHON_SITELIBDIR%%/gtk-2.0/gnome
@dirrm %%PYTHON_SITELIBDIR%%/gtk-2.0/bonobo