aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbrnrd <brnrd@FreeBSD.org>2018-04-08 19:28:27 +0800
committerbrnrd <brnrd@FreeBSD.org>2018-04-08 19:28:27 +0800
commit22b1a13e4d73269ff7a645f7abad1725ebd873e2 (patch)
tree2155848219b7d4b3daaefc75acca1de5eb09fa42
parent308cb1e42b58aa4aaa9eb07499f76e5e71706ba5 (diff)
downloadfreebsd-ports-gnome-22b1a13e4d73269ff7a645f7abad1725ebd873e2.tar.gz
freebsd-ports-gnome-22b1a13e4d73269ff7a645f7abad1725ebd873e2.tar.zst
freebsd-ports-gnome-22b1a13e4d73269ff7a645f7abad1725ebd873e2.zip
deskutils: Convert to USES=php
- While here convert some USE_APACHE Approved by: infrastructure modernization blanket
-rw-r--r--deskutils/moregroupware/Makefile6
-rw-r--r--deskutils/myitcrm/Makefile6
-rw-r--r--deskutils/tine20/Makefile4
3 files changed, 6 insertions, 10 deletions
diff --git a/deskutils/moregroupware/Makefile b/deskutils/moregroupware/Makefile
index 5a8e886ad054..d224ac4a6a9a 100644
--- a/deskutils/moregroupware/Makefile
+++ b/deskutils/moregroupware/Makefile
@@ -18,9 +18,7 @@ USE_PHP= curl \
session \
xml
-USES= gettext
-
-WANT_PHP_MOD= yes
+USES= gettext php:mod
OPTIONS_DEFINE= ADDONS NLS
OPTIONS_SINGLE= DB
@@ -32,7 +30,7 @@ OPTIONS_SUB= yes
NLS_USES= gettext
PGSQL_USES= pgsql
WANT_PGSQL= server
-MYSQL_USE= MYSQL=server
+MYSQL_USES= mysql:server
ADDONS_DISTFILES= ${PORTNAME}-addons-${PORTVERSION}${EXTRACT_SUFX}
NO_BUILD= yes
diff --git a/deskutils/myitcrm/Makefile b/deskutils/myitcrm/Makefile
index ad12041acbb7..886546418bc3 100644
--- a/deskutils/myitcrm/Makefile
+++ b/deskutils/myitcrm/Makefile
@@ -30,16 +30,16 @@ OPTIONS_DEFAULT= APACHE
PHPMOD_DESC= Use PHP module for Apache
NGINX_DESC= Use Nginx
-APACHE_USE= APACHE_RUN=22+
+APACHE_USES= apache:run,2.2+
LIGHTTPD_RUN_DEPENDS= lighttpd:www/lighttpd
NGINX_RUN_DEPENDS= nginx:www/nginx
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MPHPMOD}
-WANT_PHP_MOD= yes
+USES+= php:mod
.else
-WANT_PHP_CGI= yes
+USES+= php:cgi
.endif
# Set files to ignore.
diff --git a/deskutils/tine20/Makefile b/deskutils/tine20/Makefile
index 28dd05554021..74bc9b110e0b 100644
--- a/deskutils/tine20/Makefile
+++ b/deskutils/tine20/Makefile
@@ -13,7 +13,7 @@ COMMENT= Professional Open Source Groupware and CRM
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= tar:bzip2 gettext
+USES= gettext mysql php:web tar:bzip2
NO_BUILD= yes
EXTRACT_AFTER_ARGS= --no-same-owner --no-same-permissions -C ${WRKSRC}
@@ -23,10 +23,8 @@ SUB_LIST= DISTNAME=${DISTNAME}
OPTIONS_DEFINE= LDAP MEMCACHE
MEMCACHE_DESC= Enable pecl-memcache support
-USE_MYSQL= yes
USE_PHP= ctype dom gd iconv json mcrypt pdo_mysql simplexml \
spl xml zip
-WANT_PHP_WEB= yes
LDAP_USE= php=ldap
MEMCACHE_USE= php=memcache