aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-09-03 21:17:36 +0800
committeraz <az@FreeBSD.org>2013-09-03 21:17:36 +0800
commit23bfaa0421546878c7d4e22c4707e0111349177f (patch)
treea507080c4718994dbb9e93ebb3f1b19ece9aab47
parent9e35185bd4d0ef72c54aa3bcb2084b7c59b66409 (diff)
downloadfreebsd-ports-gnome-23bfaa0421546878c7d4e22c4707e0111349177f.tar.gz
freebsd-ports-gnome-23bfaa0421546878c7d4e22c4707e0111349177f.tar.zst
freebsd-ports-gnome-23bfaa0421546878c7d4e22c4707e0111349177f.zip
- convert to the new perl5 framework
Approved by: portmgr (bapt@, blanket)
-rw-r--r--www/p5-CGI-Session-ExpireSessions/Makefile3
-rw-r--r--www/p5-Catalyst-Authentication-Credential-HTTP/Makefile3
-rw-r--r--www/p5-Catalyst-Plugin-AtomServer/Makefile3
-rw-r--r--www/p5-HTML-ExtractContent/Makefile3
-rw-r--r--www/p5-HTML-Field/Makefile3
-rw-r--r--www/p5-HTML-StickyQuery-DoCoMoGUID/Makefile3
-rw-r--r--www/p5-HTTP-MobileAgent-Plugin-Locator/Makefile3
-rw-r--r--www/p5-Net-FireEagle/Makefile3
-rw-r--r--www/p5-Plack-Middleware-AMF/Makefile3
-rw-r--r--www/p5-Plack-Server-ReverseHTTP/Makefile3
-rw-r--r--www/p5-Protocol-WebSocket/Makefile3
-rw-r--r--www/p5-WWW-Contact/Makefile3
-rw-r--r--www/p5-WWW-HatenaStar/Makefile3
-rw-r--r--www/p5-WWW-Shorten-Bitly/Makefile3
-rw-r--r--www/p5-WWW-Shorten-KUSO/Makefile3
-rw-r--r--www/p5-WWW-Shorten-Yourls/Makefile3
-rw-r--r--www/p5-Web-Scraper-Config/Makefile3
-rw-r--r--www/p5-WebService-Google-Reader/Makefile3
-rw-r--r--www/p5-jQuery-File-Upload/Makefile3
19 files changed, 38 insertions, 19 deletions
diff --git a/www/p5-CGI-Session-ExpireSessions/Makefile b/www/p5-CGI-Session-ExpireSessions/Makefile
index 4359a72bc049..bf38b7d1ef44 100644
--- a/www/p5-CGI-Session-ExpireSessions/Makefile
+++ b/www/p5-CGI-Session-ExpireSessions/Makefile
@@ -23,6 +23,7 @@ TEST_DEPENDS= p5-Test-Pod>=0:${PORTSDIR}/devel/p5-Test-Pod
MAN3= CGI::Session::ExpireSessions.3
MANCOMPRESSED= no
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/www/p5-Catalyst-Authentication-Credential-HTTP/Makefile b/www/p5-Catalyst-Authentication-Credential-HTTP/Makefile
index 653e0e4649c0..55e2fe24f639 100644
--- a/www/p5-Catalyst-Authentication-Credential-HTTP/Makefile
+++ b/www/p5-Catalyst-Authentication-Credential-HTTP/Makefile
@@ -23,7 +23,8 @@ BUILD_DEPENDS= p5-Catalyst-Runtime>=0:${PORTSDIR}/www/p5-Catalyst-Runtime \
p5-URI>=0:${PORTSDIR}/net/p5-URI
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Catalyst::Authentication::Credential::HTTP.3
diff --git a/www/p5-Catalyst-Plugin-AtomServer/Makefile b/www/p5-Catalyst-Plugin-AtomServer/Makefile
index 941ea262736f..2678d066d133 100644
--- a/www/p5-Catalyst-Plugin-AtomServer/Makefile
+++ b/www/p5-Catalyst-Plugin-AtomServer/Makefile
@@ -23,7 +23,8 @@ RUN_DEPENDS= p5-Catalyst-Runtime>=0:${PORTSDIR}/www/p5-Catalyst-Runtime \
p5-Digest-SHA1>=0:${PORTSDIR}/security/p5-Digest-SHA1 \
p5-XML-Atom>=0:${PORTSDIR}/textproc/p5-XML-Atom
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Catalyst::Plugin::AtomServer.3 \
Catalyst::Plugin::Authentication::Credential::Atom.3 \
diff --git a/www/p5-HTML-ExtractContent/Makefile b/www/p5-HTML-ExtractContent/Makefile
index ae2d4a0c7da8..58d2b1067be8 100644
--- a/www/p5-HTML-ExtractContent/Makefile
+++ b/www/p5-HTML-ExtractContent/Makefile
@@ -20,7 +20,8 @@ RUN_DEPENDS= \
p5-HTML-Parser>0:${PORTSDIR}/www/p5-HTML-Parser
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= HTML::ExtractContent.3
diff --git a/www/p5-HTML-Field/Makefile b/www/p5-HTML-Field/Makefile
index d3192ccb4e33..c347bce0cefa 100644
--- a/www/p5-HTML-Field/Makefile
+++ b/www/p5-HTML-Field/Makefile
@@ -17,6 +17,7 @@ COMMENT= A perl module to generate HTML form elements
MAN3= HTML::Field.3 \
HTML::FieldForm.3
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/www/p5-HTML-StickyQuery-DoCoMoGUID/Makefile b/www/p5-HTML-StickyQuery-DoCoMoGUID/Makefile
index 362c52ca7d9b..53dd1cb7ac29 100644
--- a/www/p5-HTML-StickyQuery-DoCoMoGUID/Makefile
+++ b/www/p5-HTML-StickyQuery-DoCoMoGUID/Makefile
@@ -19,7 +19,8 @@ RUN_DEPENDS= \
p5-HTML-StickyQuery>0:${PORTSDIR}/www/p5-HTML-StickyQuery
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= HTML::StickyQuery::DoCoMoGUID.3
diff --git a/www/p5-HTTP-MobileAgent-Plugin-Locator/Makefile b/www/p5-HTTP-MobileAgent-Plugin-Locator/Makefile
index d4e42a64b878..f8179d331967 100644
--- a/www/p5-HTTP-MobileAgent-Plugin-Locator/Makefile
+++ b/www/p5-HTTP-MobileAgent-Plugin-Locator/Makefile
@@ -23,7 +23,8 @@ RUN_DEPENDS= \
BUILD_DEPENDS:= ${RUN_DEPENDS}
TEST_DEPENDS= p5-Test-Requires>=0:${PORTSDIR}/devel/p5-Test-Requires
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= HTTP::MobileAgent::Plugin::Locator.3
diff --git a/www/p5-Net-FireEagle/Makefile b/www/p5-Net-FireEagle/Makefile
index a5962c5dfe57..3627c5dbe07e 100644
--- a/www/p5-Net-FireEagle/Makefile
+++ b/www/p5-Net-FireEagle/Makefile
@@ -21,7 +21,8 @@ RUN_DEPENDS= p5-Net-OAuth-Simple>=1.0:${PORTSDIR}/net/p5-Net-OAuth-Simple \
p5-Net-SSLeay>=1.30:${PORTSDIR}/security/p5-Net-SSLeay
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= fireeagle.1
MAN3= Net::FireEagle.3
diff --git a/www/p5-Plack-Middleware-AMF/Makefile b/www/p5-Plack-Middleware-AMF/Makefile
index f012ef3b3253..23351ae0ca3b 100644
--- a/www/p5-Plack-Middleware-AMF/Makefile
+++ b/www/p5-Plack-Middleware-AMF/Makefile
@@ -20,7 +20,8 @@ RUN_DEPENDS= \
p5-UNIVERSAL-require>0:${PORTSDIR}/devel/p5-UNIVERSAL-require
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Plack::Middleware::AMF.3
diff --git a/www/p5-Plack-Server-ReverseHTTP/Makefile b/www/p5-Plack-Server-ReverseHTTP/Makefile
index c9252c9e60d5..f5efb012b923 100644
--- a/www/p5-Plack-Server-ReverseHTTP/Makefile
+++ b/www/p5-Plack-Server-ReverseHTTP/Makefile
@@ -21,7 +21,8 @@ RUN_DEPENDS= \
p5-Plack>0:${PORTSDIR}/www/p5-Plack
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Plack::Server::ReverseHTTP.3
diff --git a/www/p5-Protocol-WebSocket/Makefile b/www/p5-Protocol-WebSocket/Makefile
index b4b8b1952d56..110f72c71596 100644
--- a/www/p5-Protocol-WebSocket/Makefile
+++ b/www/p5-Protocol-WebSocket/Makefile
@@ -19,7 +19,8 @@ COMMENT= Client/server WebSocket message and frame parser/constructor
BUILD_DEPENDS= p5-Digest-SHA1>=0:${PORTSDIR}/security/p5-Digest-SHA1
RUN_DEPENDS= p5-Digest-SHA1>=0:${PORTSDIR}/security/p5-Digest-SHA1
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Protocol::WebSocket.3 \
Protocol::WebSocket::Cookie.3 \
diff --git a/www/p5-WWW-Contact/Makefile b/www/p5-WWW-Contact/Makefile
index d1e3a264eaf9..6b198760eb33 100644
--- a/www/p5-WWW-Contact/Makefile
+++ b/www/p5-WWW-Contact/Makefile
@@ -27,7 +27,8 @@ BUILD_DEPENDS= p5-Crypt-SSLeay>=0:${PORTSDIR}/security/p5-Crypt-SSLeay \
p5-WWW-Mechanize-GZip>=0:${PORTSDIR}/www/p5-WWW-Mechanize-GZip
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= WWW::Contact.3 \
WWW::Contact::AOL.3 \
diff --git a/www/p5-WWW-HatenaStar/Makefile b/www/p5-WWW-HatenaStar/Makefile
index f49ceff7feb1..16acfa314609 100644
--- a/www/p5-WWW-HatenaStar/Makefile
+++ b/www/p5-WWW-HatenaStar/Makefile
@@ -24,6 +24,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN3= WWW::HatenaStar.3
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/www/p5-WWW-Shorten-Bitly/Makefile b/www/p5-WWW-Shorten-Bitly/Makefile
index 0e337d6169f5..ed019ef507a2 100644
--- a/www/p5-WWW-Shorten-Bitly/Makefile
+++ b/www/p5-WWW-Shorten-Bitly/Makefile
@@ -19,7 +19,8 @@ BUILD_DEPENDS= p5-JSON-Any>=1.18:${PORTSDIR}/converters/p5-JSON-Any \
p5-XML-Simple>=2.18:${PORTSDIR}/textproc/p5-XML-Simple
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= bitly_url.1
MAN3= WWW::Shorten::Bitly.3
diff --git a/www/p5-WWW-Shorten-KUSO/Makefile b/www/p5-WWW-Shorten-KUSO/Makefile
index b40e880b6794..d646db13f2ec 100644
--- a/www/p5-WWW-Shorten-KUSO/Makefile
+++ b/www/p5-WWW-Shorten-KUSO/Makefile
@@ -17,7 +17,8 @@ COMMENT= Shorten URL using http://KUSO.CC/
BUILD_DEPENDS= p5-WWW-Shorten>=0:${PORTSDIR}/www/p5-WWW-Shorten
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= WWW::Shorten::KUSO.3
diff --git a/www/p5-WWW-Shorten-Yourls/Makefile b/www/p5-WWW-Shorten-Yourls/Makefile
index 831943b6034a..8fccebc5dc2b 100644
--- a/www/p5-WWW-Shorten-Yourls/Makefile
+++ b/www/p5-WWW-Shorten-Yourls/Makefile
@@ -15,7 +15,8 @@ BUILD_DEPENDS= p5-JSON-Any>=1.18:${PORTSDIR}/converters/p5-JSON-Any \
p5-XML-Simple>=2.18:${PORTSDIR}/textproc/p5-XML-Simple
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= WWW::Shorten::Yourls.3
diff --git a/www/p5-Web-Scraper-Config/Makefile b/www/p5-Web-Scraper-Config/Makefile
index af3e104b7379..7db3849e2dc2 100644
--- a/www/p5-Web-Scraper-Config/Makefile
+++ b/www/p5-Web-Scraper-Config/Makefile
@@ -23,7 +23,8 @@ RUN_DEPENDS= p5-Config-Any>=0:${PORTSDIR}/devel/p5-Config-Any \
p5-URI>=0:${PORTSDIR}/net/p5-URI \
p5-Web-Scraper>=0:${PORTSDIR}/www/p5-Web-Scraper
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Web::Scraper::Config.3
diff --git a/www/p5-WebService-Google-Reader/Makefile b/www/p5-WebService-Google-Reader/Makefile
index 1360c15cd981..c41c020f912d 100644
--- a/www/p5-WebService-Google-Reader/Makefile
+++ b/www/p5-WebService-Google-Reader/Makefile
@@ -27,7 +27,8 @@ BUILD_DEPENDS= p5-JSON-XS>=2:${PORTSDIR}/converters/p5-JSON-XS \
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= WebService::Google::Reader.3 \
WebService::Google::Reader::Constants.3 \
diff --git a/www/p5-jQuery-File-Upload/Makefile b/www/p5-jQuery-File-Upload/Makefile
index e00e38dd82a3..6a5f2f45c3e8 100644
--- a/www/p5-jQuery-File-Upload/Makefile
+++ b/www/p5-jQuery-File-Upload/Makefile
@@ -16,7 +16,8 @@ RUN_DEPENDS= \
p5-URI>0:${PORTSDIR}/net/p5-URI
BUILD_DEPENDS= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= jQuery::File::Upload.3