aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordumbbell <dumbbell@FreeBSD.org>2017-04-15 21:47:55 +0800
committerdumbbell <dumbbell@FreeBSD.org>2017-04-15 21:47:55 +0800
commit261a9b6a6361f4cd956c2da7d0f2f26984ed22f7 (patch)
tree6afac877c73c751a7eaee6e4b4785c49a2a7075f
parent466c789baeb1610056102cf1e78980d6da402eab (diff)
downloadfreebsd-ports-gnome-261a9b6a6361f4cd956c2da7d0f2f26984ed22f7.tar.gz
freebsd-ports-gnome-261a9b6a6361f4cd956c2da7d0f2f26984ed22f7.tar.zst
freebsd-ports-gnome-261a9b6a6361f4cd956c2da7d0f2f26984ed22f7.zip
graphics/darktable: Use LLVM 4.0 at build time
We try to keep the same LLVM version as Mesa to avoid the need to have several versions of LLVM. Approved by: bapt (mentor) Differential Revision: https://reviews.freebsd.org/D10403
-rw-r--r--graphics/darktable/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/graphics/darktable/Makefile b/graphics/darktable/Makefile
index 17443a5d5a46..04c0fe73d108 100644
--- a/graphics/darktable/Makefile
+++ b/graphics/darktable/Makefile
@@ -96,8 +96,8 @@ WEBP_CMAKE_OFF= -DUSE_WEBP:BOOL=OFF
.include <bsd.port.pre.mk>
.if ${ARCH} == amd64 && ${CHOSEN_COMPILER_TYPE} == clang
-# Enable OpenMP support with Clang 3.9.
-LLVM_VER= 39
+# Enable OpenMP support with Clang 4.0.
+LLVM_VER= 40
BUILD_DEPENDS+= clang${LLVM_VER}:devel/llvm${LLVM_VER}
CPP= clang-cpp${LLVM_VER}