aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornobutaka <nobutaka@FreeBSD.org>2015-03-14 12:22:37 +0800
committernobutaka <nobutaka@FreeBSD.org>2015-03-14 12:22:37 +0800
commit2a6d6ce3695b9db19eb3f8b5fd6635dd5f70bf7e (patch)
tree167c0d833f4447e353ced7c2a74c51882b44b11f
parente4c800b37fa4d6ff45589511155624a1328c5aba (diff)
downloadfreebsd-ports-gnome-2a6d6ce3695b9db19eb3f8b5fd6635dd5f70bf7e.tar.gz
freebsd-ports-gnome-2a6d6ce3695b9db19eb3f8b5fd6635dd5f70bf7e.tar.zst
freebsd-ports-gnome-2a6d6ce3695b9db19eb3f8b5fd6635dd5f70bf7e.zip
Fix package building error.
-rw-r--r--net/dshell/Makefile3
-rw-r--r--net/dshell/files/patch-Makefile13
2 files changed, 14 insertions, 2 deletions
diff --git a/net/dshell/Makefile b/net/dshell/Makefile
index 4e9383b50c0d..c942d1595787 100644
--- a/net/dshell/Makefile
+++ b/net/dshell/Makefile
@@ -28,11 +28,14 @@ GH_COMMIT= 46e691c
OPTIONS_DEFINE= DOCS
+MAKE_ENV+= PYTHON_CMD=${PYTHON_CMD}
+
.include <bsd.port.options.mk>
post-patch:
.for f in bin/generate-dshellrc.py doc/generate-doc.sh
${REINPLACE_CMD} -e 's|/bin/bash|${LOCALBASE}/bin/bash|' ${WRKSRC}/${f}
+ ${REINPLACE_CMD} -e 's|pydoc|${LOCALBASE}/bin/pydoc${PYTHON_VER}|' ${WRKSRC}/${f}
.endfor
post-build:
diff --git a/net/dshell/files/patch-Makefile b/net/dshell/files/patch-Makefile
index e810386e905b..e9c5945ad550 100644
--- a/net/dshell/files/patch-Makefile
+++ b/net/dshell/files/patch-Makefile
@@ -1,5 +1,14 @@
---- Makefile.orig 2015-02-04 22:30:21.000000000 +0900
-+++ Makefile 2015-02-04 22:30:50.000000000 +0900
+--- Makefile.orig 2015-02-20 03:44:33.000000000 +0900
++++ Makefile 2015-03-12 23:44:40.000000000 +0900
+@@ -6,7 +6,7 @@
+
+ rc:
+ # Generating .dshellrc and dshell files
+- python $(PWD)/bin/generate-dshellrc.py $(PWD)
++ $(PYTHON_CMD) $(PWD)/bin/generate-dshellrc.py $(PWD)
+ chmod 755 $(PWD)/dshell
+ chmod 755 $(PWD)/dshell-decode
+ chmod 755 $(PWD)/bin/decode.py
@@ -15,7 +15,7 @@
initpy:
find $(PWD)/decoders -type d -not -path \*.svn\* -print -exec touch {}/__init__.py \;