aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2005-05-22 01:31:00 +0800
committerkris <kris@FreeBSD.org>2005-05-22 01:31:00 +0800
commit2b03593e32431ba7432bae4b82c4ffb481f46a0a (patch)
tree33f9eaf1f85927ef5958a54fc8b8400bdaec6ee4
parentbc6bbff0b6371d28c0cbb63b2a16ab37e1904930 (diff)
downloadfreebsd-ports-gnome-2b03593e32431ba7432bae4b82c4ffb481f46a0a.tar.gz
freebsd-ports-gnome-2b03593e32431ba7432bae4b82c4ffb481f46a0a.tar.zst
freebsd-ports-gnome-2b03593e32431ba7432bae4b82c4ffb481f46a0a.zip
BROKEN on 4.x: Does not compile
-rw-r--r--graphics/enblend/Makefile8
-rw-r--r--net-p2p/apollon/Makefile8
-rw-r--r--net/apollon/Makefile8
3 files changed, 21 insertions, 3 deletions
diff --git a/graphics/enblend/Makefile b/graphics/enblend/Makefile
index 80b3cc356abd..0f75bb288511 100644
--- a/graphics/enblend/Makefile
+++ b/graphics/enblend/Makefile
@@ -26,4 +26,10 @@ USE_GETOPT_LONG=yes
PLIST_FILES= bin/enblend
MAN1= enblend.1
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile on FreeBSD 4.x"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net-p2p/apollon/Makefile b/net-p2p/apollon/Makefile
index b858e7cf3fe8..22db96e18375 100644
--- a/net-p2p/apollon/Makefile
+++ b/net-p2p/apollon/Makefile
@@ -23,10 +23,16 @@ GNU_CONFIGURE= yes
USE_REINPLACE= yes
USE_LIBTOOL_VER=15
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile on FreeBSD 4.x"
+.endif
+
post-patch:
.ifdef(NOPORTDOCS)
@${REINPLACE_CMD} -E -e 's/^(all:)[[:space:]]+docs-am/\1/; s/^(SUBDIRS.+)doc/\1/' \
${WRKSRC}/Makefile.in
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/apollon/Makefile b/net/apollon/Makefile
index b858e7cf3fe8..22db96e18375 100644
--- a/net/apollon/Makefile
+++ b/net/apollon/Makefile
@@ -23,10 +23,16 @@ GNU_CONFIGURE= yes
USE_REINPLACE= yes
USE_LIBTOOL_VER=15
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile on FreeBSD 4.x"
+.endif
+
post-patch:
.ifdef(NOPORTDOCS)
@${REINPLACE_CMD} -E -e 's/^(all:)[[:space:]]+docs-am/\1/; s/^(SUBDIRS.+)doc/\1/' \
${WRKSRC}/Makefile.in
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>