aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-09-28 07:46:04 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-09-28 07:46:04 +0800
commit2c45f4a7458c50aa77928131870566a37f320276 (patch)
treef42d5b1d607a3d24ca85d15a41f093ea07cd1667
parentfc7a32abadfcb44d184e4196d28bc06aa4c5ffc6 (diff)
downloadfreebsd-ports-gnome-2c45f4a7458c50aa77928131870566a37f320276.tar.gz
freebsd-ports-gnome-2c45f4a7458c50aa77928131870566a37f320276.tar.zst
freebsd-ports-gnome-2c45f4a7458c50aa77928131870566a37f320276.zip
Add graphics/ansilove:
ANSi / ASCII art to PNG converter - Supports 7 textmode formats: ANS/PCB/BiN/ADF/iDF/TND/XBiN - Supports 14 MS-DOS charsets - 80x25, 80x50 and Amiga fonts - Supports SAUCE and iCE colors - Small output size (4-bit PNG) WWW: https://github.com/ansilove/ansilove
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/ansilove/Makefile39
-rw-r--r--graphics/ansilove/distinfo3
-rw-r--r--graphics/ansilove/pkg-descr10
4 files changed, 53 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 001d222c364c..ce9493ef4404 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -46,6 +46,7 @@
SUBDIR += ampasACES-container
SUBDIR += ampasCTL
SUBDIR += animorph
+ SUBDIR += ansilove
SUBDIR += aoi
SUBDIR += apngasm
SUBDIR += apngdis
diff --git a/graphics/ansilove/Makefile b/graphics/ansilove/Makefile
new file mode 100644
index 000000000000..efbcfb05b3ac
--- /dev/null
+++ b/graphics/ansilove/Makefile
@@ -0,0 +1,39 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= ansilove
+PORTVERSION= 3.0.4
+CATEGORIES= graphics textproc
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= ANSi / ASCII art to PNG converter
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libgd.so:graphics/gd
+
+USE_GITHUB= yes
+
+USES= cmake
+CMAKE_ARGS= -DCMAKE_INSTALL_MANDIR=man
+
+PORTDOCS= AUTHORS ChangeLog README.md THANKS TODO
+PORTEXAMPLES= *
+
+PLIST_FILES= bin/ansilove \
+ man/man1/ansilove.1.gz
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}/
+.endfor
+
+post-install-EXAMPLES-on:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}/
+
+.include <bsd.port.mk>
diff --git a/graphics/ansilove/distinfo b/graphics/ansilove/distinfo
new file mode 100644
index 000000000000..a14e3e1dd429
--- /dev/null
+++ b/graphics/ansilove/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1474927624
+SHA256 (ansilove-ansilove-3.0.4_GH0.tar.gz) = b115242186e7e5d98311b49c57503cf8dbe6955cbc9880fb3ef7ad831d1f03de
+SIZE (ansilove-ansilove-3.0.4_GH0.tar.gz) = 151101
diff --git a/graphics/ansilove/pkg-descr b/graphics/ansilove/pkg-descr
new file mode 100644
index 000000000000..205d18af8569
--- /dev/null
+++ b/graphics/ansilove/pkg-descr
@@ -0,0 +1,10 @@
+ANSi / ASCII art to PNG converter
+
+- Supports 7 textmode formats:
+ ANS/PCB/BiN/ADF/iDF/TND/XBiN
+- Supports 14 MS-DOS charsets
+- 80x25, 80x50 and Amiga fonts
+- Supports SAUCE and iCE colors
+- Small output size (4-bit PNG)
+
+WWW: https://github.com/ansilove/ansilove