aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2007-04-05 20:54:18 +0800
committertobez <tobez@FreeBSD.org>2007-04-05 20:54:18 +0800
commit3034973666acece80cca7172ff543519de3bd8d2 (patch)
treeecd2b69ae243f12d05ba84ca31802cc143126ff7
parent0f355ae726e36c86300b33373c0ec2a7ef5466c7 (diff)
downloadfreebsd-ports-gnome-3034973666acece80cca7172ff543519de3bd8d2.tar.gz
freebsd-ports-gnome-3034973666acece80cca7172ff543519de3bd8d2.tar.zst
freebsd-ports-gnome-3034973666acece80cca7172ff543519de3bd8d2.zip
Add textproc/p5-HTML-SBC 0.15.
Simple Blog Code is a simple markup language. You can use it for guest books, blogs, wikis, boards and various other web applications. It produces valid and semantic (X)HTML from input and is patterned on that tiny usenet markups like *bold* and _underline_.
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-HTML-SBC/Makefile26
-rw-r--r--textproc/p5-HTML-SBC/distinfo3
-rw-r--r--textproc/p5-HTML-SBC/pkg-descr6
-rw-r--r--textproc/p5-HTML-SBC/pkg-plist5
5 files changed, 41 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index cb15306dadee..2dbc70c0b20c 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -357,6 +357,7 @@
SUBDIR += p5-HTML-EscapeEvil
SUBDIR += p5-HTML-Format
SUBDIR += p5-HTML-Fraction
+ SUBDIR += p5-HTML-SBC
SUBDIR += p5-HTML-TagFilter
SUBDIR += p5-HTML-Tidy
SUBDIR += p5-HTML-Truncate
diff --git a/textproc/p5-HTML-SBC/Makefile b/textproc/p5-HTML-SBC/Makefile
new file mode 100644
index 000000000000..79bd43d9d654
--- /dev/null
+++ b/textproc/p5-HTML-SBC/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: textproc/p5-HTML-SBC
+# Date created: 05 April 2007
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML-SBC
+PORTVERSION= 0.15
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= HTML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Simple blog code to valid XHTML
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils \
+ ${SITE_PERL}/Test/Exception.pm:${PORTSDIR}/devel/p5-Test-Exception
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= HTML::SBC.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-HTML-SBC/distinfo b/textproc/p5-HTML-SBC/distinfo
new file mode 100644
index 000000000000..d5522887081e
--- /dev/null
+++ b/textproc/p5-HTML-SBC/distinfo
@@ -0,0 +1,3 @@
+MD5 (HTML-SBC-0.15.tar.gz) = e79c5de8e9e2bc6ebc2d6d77485a772e
+SHA256 (HTML-SBC-0.15.tar.gz) = 209d4e3a8590b9b92311f4a14e2bad5f1888c28169206957e1bafb38d68b4874
+SIZE (HTML-SBC-0.15.tar.gz) = 26154
diff --git a/textproc/p5-HTML-SBC/pkg-descr b/textproc/p5-HTML-SBC/pkg-descr
new file mode 100644
index 000000000000..fe26e0543507
--- /dev/null
+++ b/textproc/p5-HTML-SBC/pkg-descr
@@ -0,0 +1,6 @@
+Simple Blog Code is a simple markup language. You can use it for guest
+books, blogs, wikis, boards and various other web applications. It
+produces valid and semantic (X)HTML from input and is patterned on that
+tiny usenet markups like *bold* and _underline_.
+
+WWW: http://search.cpan.org/dist/HTML-SBC/
diff --git a/textproc/p5-HTML-SBC/pkg-plist b/textproc/p5-HTML-SBC/pkg-plist
new file mode 100644
index 000000000000..ade36e47cb16
--- /dev/null
+++ b/textproc/p5-HTML-SBC/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/HTML/SBC.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/SBC/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/SBC
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML
+@dirrmtry %%SITE_PERL%%/HTML