aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2018-08-22 22:10:34 +0800
committerswills <swills@FreeBSD.org>2018-08-22 22:10:34 +0800
commit32472b5af999588b3349f0166a5b9303fae74e34 (patch)
treee7a53473f7c302bef56b4377c6f22c5da8a5d448
parent5dc743137d1636fc52c6e8c48a069aedc8ac3f41 (diff)
downloadfreebsd-ports-gnome-32472b5af999588b3349f0166a5b9303fae74e34.tar.gz
freebsd-ports-gnome-32472b5af999588b3349f0166a5b9303fae74e34.tar.zst
freebsd-ports-gnome-32472b5af999588b3349f0166a5b9303fae74e34.zip
devel/libruin: Update to 0.2.0
While here, assign maintainership to submitter. This fixes build with new guile-lib. PR: 230751 Submitted by: Nathan <ndowens@yahoo.com>
-rw-r--r--devel/libruin/Makefile40
-rw-r--r--devel/libruin/distinfo5
-rw-r--r--devel/libruin/pkg-plist5
3 files changed, 42 insertions, 8 deletions
diff --git a/devel/libruin/Makefile b/devel/libruin/Makefile
index ed898bbb1e54..e1baa2eaac59 100644
--- a/devel/libruin/Makefile
+++ b/devel/libruin/Makefile
@@ -2,22 +2,50 @@
# $FreeBSD$
PORTNAME= libruin
-PORTVERSION= 0.1.4
-PORTREVISION= 3
+PORTVERSION= 0.2.0
CATEGORIES= devel scheme
MASTER_SITES= SAVANNAH
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ndowens@yahoo.com
COMMENT= Renderer for User Interfaces in Ncurses
-BUILD_DEPENDS= ${LOCALBASE}/share/guile/site/config/load.scm:devel/guile-lib
-RUN_DEPENDS= ${LOCALBASE}/share/guile/site/config/load.scm:devel/guile-lib
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+NOT_FOR_ARCHS= mips
+NOT_FOR_ARCHS_REASON= glib needs gcc7(Not available for mips)
+
+BUILD_DEPENDS= guile-lib>0:devel/guile-lib
+LIB_DEPENDS= libguile-2.0.so:lang/guile2 \
+ libgc-threaded.so:devel/boehm-gc-threaded
+RUN_DEPENDS= guile-lib>0:devel/guile-lib
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-USES= libtool ncurses
+USES= libtool ncurses pkgconfig
+USE_GNOME= glib20
USE_LDCONFIG= yes
INFO= libruin
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+PORTDOCS= ChangeLog
+PORTEXAMPLES= css21-conformance-uris.txt ruinview.c
+
+.include <bsd.port.options.mk>
+
+post-configure:
+ # Avoid compiling examples, which fails to compile
+ # As the examples needs the library to be already installed
+ ${REINPLACE_CMD} -e '/^SUBDIRS/s,examples,,' ${WRKSRC}/Makefile
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC}/doc && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR})
+
+do-install-EXAMPLES-on:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ (cd ${WRKSRC}/examples && ${INSTALL_DATA} ${PORTEXAMPLES} ${STAGEDIR}${EXAMPLESDIR})
+
.include <bsd.port.mk>
diff --git a/devel/libruin/distinfo b/devel/libruin/distinfo
index 42a2f89aabd1..3a81a9098c68 100644
--- a/devel/libruin/distinfo
+++ b/devel/libruin/distinfo
@@ -1,2 +1,3 @@
-SHA256 (libruin-0.1.4.tar.gz) = 9b62981fd7cbe1e3d7103a2196963ebf09d596d35fa28739dd97715b495e5347
-SIZE (libruin-0.1.4.tar.gz) = 525357
+TIMESTAMP = 1534656203
+SHA256 (libruin-0.2.0.tar.gz) = ae2b45d1152b4150dbe982637fe683de9117f476e3825cc29d7df96efb6090ef
+SIZE (libruin-0.2.0.tar.gz) = 516597
diff --git a/devel/libruin/pkg-plist b/devel/libruin/pkg-plist
index 2207be1a541d..0347bb7d384e 100644
--- a/devel/libruin/pkg-plist
+++ b/devel/libruin/pkg-plist
@@ -5,10 +5,15 @@ lib/libruin.so.0
lib/libruin.so.0.0.0
lib/libruin/css/xhtml.css
lib/libruin/css/xul.css
+lib/libruin/scheme/scss/common.scm
+lib/libruin/scheme/scss/interface/sdom.scm
lib/libruin/scheme/scss/lexer.scm
lib/libruin/scheme/scss/parser.scm
+lib/libruin/scheme/scss/properties.scm
lib/libruin/scheme/scss/scss.scm
+lib/libruin/scheme/sdom/common.scm
lib/libruin/scheme/sdom/core.scm
lib/libruin/scheme/sdom/events.scm
+lib/libruin/scheme/sdom/parser.scm
man/man3/ruin.3.gz
%%DATADIR%%/ChangeLog