aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2016-05-17 05:33:13 +0800
committerantoine <antoine@FreeBSD.org>2016-05-17 05:33:13 +0800
commit32c271fcda64c5d8b724399dbea7f0ab65bcc910 (patch)
tree4487ba43643e4db92a05104c62d982375c3a6535
parentab075dce60525fffda141b8a5293376ff279b711 (diff)
downloadfreebsd-ports-gnome-32c271fcda64c5d8b724399dbea7f0ab65bcc910.tar.gz
freebsd-ports-gnome-32c271fcda64c5d8b724399dbea7f0ab65bcc910.tar.zst
freebsd-ports-gnome-32c271fcda64c5d8b724399dbea7f0ab65bcc910.zip
Revive net/samba-smbclient to unbreak INDEX
-rw-r--r--MOVED1
-rw-r--r--net/Makefile1
-rw-r--r--net/samba-smbclient/Makefile36
-rw-r--r--net/samba-smbclient/files/smb-client.conf.sample9
-rw-r--r--net/samba-smbclient/pkg-descr6
-rw-r--r--net/samba-smbclient/pkg-plist3
6 files changed, 55 insertions, 1 deletions
diff --git a/MOVED b/MOVED
index 4ad53af8a4d3..f0b0fa9b2fab 100644
--- a/MOVED
+++ b/MOVED
@@ -8319,7 +8319,6 @@ devel/rubygem-redmine_acts_as_taggable_on|www/rubygem-redmine_acts_as_taggable_o
lang/gcc-aux||2016-05-16|Has expired: Use newer lang/gcc5-aux or lang/gcc6-aux compilers instead
audio/deadbeef-mpris-plugin|audio/deadbeef-mpris2-plugin|2016-05-16|Has expired: Abandonware; use `audio/deadbeef-mpris2-plugin' instead
net/samba41||2016-05-16|Has expired: not supported by the upstream
-net/samba-smbclient||2016-05-16|Has expired: not supported by the upstream
databases/postgresql90-contrib||2016-05-16|Has expired: "EOL was reached in September 2015"
databases/postgresql90-pltcl||2016-05-16|Has expired: "EOL was reached in September 2015"
databases/postgresql90-docs||2016-05-16|Has expired: "EOL was reached in September 2015"
diff --git a/net/Makefile b/net/Makefile
index a6cebbece112..5cb7bd621942 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1182,6 +1182,7 @@
SUBDIR += rwhoisd
SUBDIR += samba-libsmbclient
SUBDIR += samba-nmblookup
+ SUBDIR += samba-smbclient
SUBDIR += samba36
SUBDIR += samba42
SUBDIR += samba43
diff --git a/net/samba-smbclient/Makefile b/net/samba-smbclient/Makefile
new file mode 100644
index 000000000000..8f3b91dab093
--- /dev/null
+++ b/net/samba-smbclient/Makefile
@@ -0,0 +1,36 @@
+# Created by: garga
+# $FreeBSD$
+
+PORTREVISION= 0
+PORTEPOCH= 0
+PKGNAMESUFFIX= -smbclient
+
+COMMENT= Samba "ftp-like" client
+
+CONFLICTS= ja-samba-[23].* samba-[2-4].*
+
+SAMBA_PORT= samba36
+SAMBA_SUBPORT= yes
+
+SAMBA_CONFIG= smb-client.conf
+
+MASTERDIR= ${.CURDIR}/../${SAMBA_PORT}
+FILESDIR= ${.CURDIR}/files
+PKGDIR= ${.CURDIR}
+
+WITHOUT_ADS= yes
+
+PLIST_SUB+= SAMBA_CONFDIR="${SAMBA_CONFDIR:S,^${PREFIX}/,,}" \
+ SAMBA_CONFIG="${SAMBA_CONFIG}"
+
+ALL_TARGET= bin/smbclient
+
+do-install:
+ -@${MKDIR} ${STAGEDIR}${SAMBA_CONFDIR}
+ ${INSTALL_DATA} ${FILESDIR}/smb-client.conf.sample ${STAGEDIR}${SAMBA_CONFDIR}/${SAMBA_CONFIG}.sample
+ -@${MKDIR} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/smbclient ${STAGEDIR}${PREFIX}/bin
+ -@${MKDIR} ${STAGEDIR}${MAN1PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKDIR}/${DISTNAME}/docs/manpages/smbclient.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
+
+.include "${MASTERDIR}/Makefile"
diff --git a/net/samba-smbclient/files/smb-client.conf.sample b/net/samba-smbclient/files/smb-client.conf.sample
new file mode 100644
index 000000000000..e493fd5c8419
--- /dev/null
+++ b/net/samba-smbclient/files/smb-client.conf.sample
@@ -0,0 +1,9 @@
+[global]
+
+# workgroup = NT-Domain-Name or Workgroup-Name, eg: MIDEARTH
+; workgroup = MYGROUP
+
+# Charset settings
+; display charset = koi8-r
+; unix charset = koi8-r
+; dos charset = cp866
diff --git a/net/samba-smbclient/pkg-descr b/net/samba-smbclient/pkg-descr
new file mode 100644
index 000000000000..4e691cb33725
--- /dev/null
+++ b/net/samba-smbclient/pkg-descr
@@ -0,0 +1,6 @@
+smbclient is samba client with an "ftp like" interface. It is a useful tool to
+test connectivity to a Windows share. It can be used to transfer files, or to
+look at share names. In addition, it has a nifty ability to 'tar' (backup) and
+restore files from a server to a client and visa versa.
+
+WWW: http://www.samba.org/
diff --git a/net/samba-smbclient/pkg-plist b/net/samba-smbclient/pkg-plist
new file mode 100644
index 000000000000..23dd7f363bf8
--- /dev/null
+++ b/net/samba-smbclient/pkg-plist
@@ -0,0 +1,3 @@
+bin/smbclient
+man/man1/smbclient.1.gz
+%%SAMBA_CONFDIR%%/%%SAMBA_CONFIG%%.sample