aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-05-20 20:44:34 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-05-20 20:44:34 +0800
commit3492ad77bd50358a528f213930aaecf58b787c22 (patch)
tree74ed50f924e717d1b427b7362316cb5767d9503f
parentdb58c4d604fb2f9ac9eb520dc6bfb1d862b7182b (diff)
downloadfreebsd-ports-gnome-3492ad77bd50358a528f213930aaecf58b787c22.tar.gz
freebsd-ports-gnome-3492ad77bd50358a528f213930aaecf58b787c22.tar.zst
freebsd-ports-gnome-3492ad77bd50358a528f213930aaecf58b787c22.zip
- Add LICENSE
- Simplify installation: switch to static plist, use WWWDIR - Use @sample - Handle owner/group from plist, fixing staging as plain user - Whitespace fixes
-rw-r--r--www/hastymail/Makefile37
-rw-r--r--www/hastymail/pkg-plist195
2 files changed, 209 insertions, 23 deletions
diff --git a/www/hastymail/Makefile b/www/hastymail/Makefile
index a3f0692ba57b..4c1f74663322 100644
--- a/www/hastymail/Makefile
+++ b/www/hastymail/Makefile
@@ -1,26 +1,25 @@
# Created by: Bartlomiej Rutkowski <r@robakdesign.com>
# $FreeBSD$
-PORTNAME= hastymail
-PORTVERSION= 1.5
-PORTREVISION= 3
-CATEGORIES= www
-MASTER_SITES= SF/${PORTNAME}/OldFiles
+PORTNAME= hastymail
+PORTVERSION= 1.5
+PORTREVISION= 3
+CATEGORIES= www
+MASTER_SITES= SF/${PORTNAME}/OldFiles
MAINTAINER= ports@FreeBSD.org
COMMENT= Small, fast and secure yet powerful IMAP webmail
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+LICENSE= GPLv2 # or later
+LICENSE_FILE= ${WRKSRC}/COPYING
+
NO_BUILD= yes
SUB_FILES= pkg-message
-INSTALL_DIR?= www/${PORTNAME}
-PLIST= ${WRKDIR}/pkg-plist
-
WANT_PHP_WEB= yes
USE_PHP= session imap pcre
-.include <bsd.port.pre.mk>
+PLIST_SUB= WWWOWN="${WWWOWN}" WWWGRP="${WWWGRP}"
# Don't install automatically CVS directories, patched files and the default config file.
FIND_SKIP_OPTS= -not -name hastymail.conf-example -not -name '*.orig' \
@@ -30,19 +29,11 @@ post-patch:
@${REINPLACE_CMD} -e "s,%%PREFIX%%,${PREFIX}," \
${WRKSRC}/lib/constant.php
-pre-install:
- @${FIND} -s -d ${WRKSRC}/ -type f ${FIND_SKIP_OPTS} | \
- ${SED} "s?${WRKSRC}?${INSTALL_DIR}?g" >${PLIST}
- @${FIND} -s -d ${WRKSRC}/ -type d ${FIND_SKIP_OPTS} | \
- ${SED} "s?${WRKSRC}?@dirrm ${INSTALL_DIR}?g" >> ${PLIST}
- @${ECHO_CMD} etc/hastymail.conf.sample >> ${PLIST}
-
do-install:
- @${MKDIR} ${STAGEDIR}${PREFIX}/${INSTALL_DIR}
- @cd ${WRKSRC} && ${FIND} . ${FIND_SKIP_OPTS} | \
- ${PAX} -rwd ${STAGEDIR}${PREFIX}/${INSTALL_DIR}
- @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${STAGEDIR}${PREFIX}/${INSTALL_DIR}
- @${INSTALL_DATA} ${WRKSRC}/hastymail.conf-example \
+ @${MKDIR} ${STAGEDIR}${WWWDIR}
+ cd ${WRKSRC} && ${FIND} . ${FIND_SKIP_OPTS} | \
+ ${PAX} -rwd ${STAGEDIR}${WWWDIR}
+ ${INSTALL_DATA} ${WRKSRC}/hastymail.conf-example \
${STAGEDIR}${PREFIX}/etc/hastymail.conf.sample
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/hastymail/pkg-plist b/www/hastymail/pkg-plist
new file mode 100644
index 000000000000..442d5df5477d
--- /dev/null
+++ b/www/hastymail/pkg-plist
@@ -0,0 +1,195 @@
+etc/hastymail.conf.sample
+@owner %%WWWOWN%%
+@group %%WWWGRP%%
+%%WWWDIR%%/CHANGES
+%%WWWDIR%%/COPYING
+%%WWWDIR%%/DEVELOPMENT
+%%WWWDIR%%/INSTALL
+%%WWWDIR%%/README
+%%WWWDIR%%/RELEASE.NOTES
+%%WWWDIR%%/TODO
+%%WWWDIR%%/debian/hastymail.prerm.debhelper
+%%WWWDIR%%/filter/README.htmlfilter
+%%WWWDIR%%/filter/filter.php
+%%WWWDIR%%/filter/htmlfilter.inc
+%%WWWDIR%%/filter/index.php
+%%WWWDIR%%/html/about.php
+%%WWWDIR%%/html/compose.php
+%%WWWDIR%%/html/contacts.php
+%%WWWDIR%%/html/download.php
+%%WWWDIR%%/html/folders.php
+%%WWWDIR%%/html/iframe.php
+%%WWWDIR%%/html/index.php
+%%WWWDIR%%/html/login.php
+%%WWWDIR%%/html/logout.php
+%%WWWDIR%%/html/mailbox.php
+%%WWWDIR%%/html/message.php
+%%WWWDIR%%/html/new.php
+%%WWWDIR%%/html/options.php
+%%WWWDIR%%/html/redirect.php
+%%WWWDIR%%/html/search.php
+%%WWWDIR%%/html/style.php
+%%WWWDIR%%/html/thread_view.php
+%%WWWDIR%%/idna/README.idna
+%%WWWDIR%%/idna/idna.php
+%%WWWDIR%%/idna/idna_convert.class.php
+%%WWWDIR%%/idna/idna_convert.class.php5.php
+%%WWWDIR%%/idna/index.php
+%%WWWDIR%%/images/hastymail.ico
+%%WWWDIR%%/images/hastymail.png
+%%WWWDIR%%/images/index.php
+%%WWWDIR%%/images/php.png
+%%WWWDIR%%/images/sf.png
+%%WWWDIR%%/images/trans.gif
+%%WWWDIR%%/images/w3c.png
+%%WWWDIR%%/index.php
+%%WWWDIR%%/lang/bg_BG.php
+%%WWWDIR%%/lang/ca_ES.php
+%%WWWDIR%%/lang/charsets.php
+%%WWWDIR%%/lang/cs_CZ.php
+%%WWWDIR%%/lang/de_DE.php
+%%WWWDIR%%/lang/en_US.php
+%%WWWDIR%%/lang/es_ES.php
+%%WWWDIR%%/lang/fi_FI.php
+%%WWWDIR%%/lang/fr_FR.php
+%%WWWDIR%%/lang/hu_HU.php
+%%WWWDIR%%/lang/index.php
+%%WWWDIR%%/lang/it_IT.php
+%%WWWDIR%%/lang/lang_index.php
+%%WWWDIR%%/lang/nl_NL.php
+%%WWWDIR%%/lang/no_NO.php
+%%WWWDIR%%/lang/pl_PL.php
+%%WWWDIR%%/lang/ru_RU.php
+%%WWWDIR%%/lang/sv_SE.php
+%%WWWDIR%%/lang/tr_TR.php
+%%WWWDIR%%/lib/bodystructure.php
+%%WWWDIR%%/lib/constant.php
+%%WWWDIR%%/lib/general.php
+%%WWWDIR%%/lib/general_2.php
+%%WWWDIR%%/lib/html_functions.php
+%%WWWDIR%%/lib/html_functions_2.php
+%%WWWDIR%%/lib/imap.php
+%%WWWDIR%%/lib/imap_2.php
+%%WWWDIR%%/lib/imap_3.php
+%%WWWDIR%%/lib/index.php
+%%WWWDIR%%/lib/post_and_get.php
+%%WWWDIR%%/lib/session.php
+%%WWWDIR%%/lib/session_2.php
+%%WWWDIR%%/lib/smtp.php
+%%WWWDIR%%/lib/wrapper_functions.php
+%%WWWDIR%%/templates/default/about_template.php
+%%WWWDIR%%/templates/default/compose_template.php
+%%WWWDIR%%/templates/default/contacts_template.php
+%%WWWDIR%%/templates/default/folder_delete_template.php
+%%WWWDIR%%/templates/default/folder_preview_template.php
+%%WWWDIR%%/templates/default/folders_template.php
+%%WWWDIR%%/templates/default/imaperror_template.php
+%%WWWDIR%%/templates/default/index.php
+%%WWWDIR%%/templates/default/loggedout_template.php
+%%WWWDIR%%/templates/default/login_template.php
+%%WWWDIR%%/templates/default/logout_template.php
+%%WWWDIR%%/templates/default/mailbox_template.php
+%%WWWDIR%%/templates/default/message_template.php
+%%WWWDIR%%/templates/default/new_template.php
+%%WWWDIR%%/templates/default/options_template.php
+%%WWWDIR%%/templates/default/print_view_template.php
+%%WWWDIR%%/templates/default/search_template.php
+%%WWWDIR%%/templates/default/spellcheck_template.php
+%%WWWDIR%%/templates/default/thread_view_template.php
+%%WWWDIR%%/templates/default/toolbar_template.php
+%%WWWDIR%%/templates/folder_tree/about_template.php
+%%WWWDIR%%/templates/folder_tree/compose_template.php
+%%WWWDIR%%/templates/folder_tree/contacts_template.php
+%%WWWDIR%%/templates/folder_tree/folder_delete_template.php
+%%WWWDIR%%/templates/folder_tree/folder_preview_template.php
+%%WWWDIR%%/templates/folder_tree/folders_template.php
+%%WWWDIR%%/templates/folder_tree/imaperror_template.php
+%%WWWDIR%%/templates/folder_tree/index.php
+%%WWWDIR%%/templates/folder_tree/loggedout_template.php
+%%WWWDIR%%/templates/folder_tree/login_template.php
+%%WWWDIR%%/templates/folder_tree/logout_template.php
+%%WWWDIR%%/templates/folder_tree/mailbox_template.php
+%%WWWDIR%%/templates/folder_tree/message_template.php
+%%WWWDIR%%/templates/folder_tree/new_template.php
+%%WWWDIR%%/templates/folder_tree/options_template.php
+%%WWWDIR%%/templates/folder_tree/print_view_template.php
+%%WWWDIR%%/templates/folder_tree/search_template.php
+%%WWWDIR%%/templates/folder_tree/spellcheck_template.php
+%%WWWDIR%%/templates/folder_tree/thread_view_template.php
+%%WWWDIR%%/templates/folder_tree/toolbar_template.php
+%%WWWDIR%%/templates/index.php
+%%WWWDIR%%/templates/simple/compose_template.php
+%%WWWDIR%%/templates/simple/contacts_template.php
+%%WWWDIR%%/templates/simple/folder_delete_template.php
+%%WWWDIR%%/templates/simple/folders_template.php
+%%WWWDIR%%/templates/simple/imaperror_template.php
+%%WWWDIR%%/templates/simple/index.php
+%%WWWDIR%%/templates/simple/loggedout_template.php
+%%WWWDIR%%/templates/simple/login_template.php
+%%WWWDIR%%/templates/simple/logout_template.php
+%%WWWDIR%%/templates/simple/mailbox_template.php
+%%WWWDIR%%/templates/simple/message_template.php
+%%WWWDIR%%/templates/simple/new_template.php
+%%WWWDIR%%/templates/simple/options_template.php
+%%WWWDIR%%/templates/simple/toolbar_template.php
+%%WWWDIR%%/templates/stb/compose_template.php
+%%WWWDIR%%/templates/stb/imaperror_template.php
+%%WWWDIR%%/templates/stb/index.php
+%%WWWDIR%%/templates/stb/loggedout_template.php
+%%WWWDIR%%/templates/stb/login_template.php
+%%WWWDIR%%/templates/stb/logout_template.php
+%%WWWDIR%%/templates/stb/mailbox_template.php
+%%WWWDIR%%/templates/stb/message_template.php
+%%WWWDIR%%/templates/stb/new_template.php
+%%WWWDIR%%/templates/stb/toolbar_template.php
+%%WWWDIR%%/themes/avenueblue.css
+%%WWWDIR%%/themes/avenuecoolblue.css
+%%WWWDIR%%/themes/avenuecopper.css
+%%WWWDIR%%/themes/avenueorange.css
+%%WWWDIR%%/themes/avenuered.css
+%%WWWDIR%%/themes/avenuespace.css
+%%WWWDIR%%/themes/avenuespace.gif
+%%WWWDIR%%/themes/black.css
+%%WWWDIR%%/themes/bliss.css
+%%WWWDIR%%/themes/blue.css
+%%WWWDIR%%/themes/blue_brown.css
+%%WWWDIR%%/themes/candybar.css
+%%WWWDIR%%/themes/default.css
+%%WWWDIR%%/themes/green.css
+%%WWWDIR%%/themes/grey.css
+%%WWWDIR%%/themes/index.php
+%%WWWDIR%%/themes/lightblue.css
+%%WWWDIR%%/themes/sea.css
+%%WWWDIR%%/themes/smokeblue.css
+%%WWWDIR%%/themes/smokecopper.css
+%%WWWDIR%%/themes/smokegreen.css
+%%WWWDIR%%/themes/smokelavender.css
+%%WWWDIR%%/themes/smokepeach.css
+%%WWWDIR%%/themes/smokered.css
+%%WWWDIR%%/themes/smokesilver.css
+%%WWWDIR%%/themes/smokesky.css
+%%WWWDIR%%/themes/smokesky_nn4.css
+%%WWWDIR%%/themes/smokesteel.css
+%%WWWDIR%%/themes/smoketeal.css
+%%WWWDIR%%/themes/spring.css
+%%WWWDIR%%/themes/stb.css
+%%WWWDIR%%/themes/swamp.css
+%%WWWDIR%%/themes/tan.css
+%%WWWDIR%%/themes/white.css
+@dir %%WWWDIR%%/themes
+@dir %%WWWDIR%%/templates/stb
+@dir %%WWWDIR%%/templates/simple
+@dir %%WWWDIR%%/templates/folder_tree
+@dir %%WWWDIR%%/templates/default
+@dir %%WWWDIR%%/templates
+@dir %%WWWDIR%%/lib
+@dir %%WWWDIR%%/lang/code_pages
+@dir %%WWWDIR%%/lang
+@dir %%WWWDIR%%/images
+@dir %%WWWDIR%%/idna
+@dir %%WWWDIR%%/html
+@dir %%WWWDIR%%/filter
+@dir %%WWWDIR%%/debian
+@dir %%WWWDIR%%
+@owner
+@group