aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-04-09 18:29:48 +0800
committerbapt <bapt@FreeBSD.org>2014-04-09 18:29:48 +0800
commit36fc2e4cd965a9f68372d8e5ae8d15aeebfcf2f8 (patch)
tree85d81b83d23ab7b2efc21a25ff0ceebc8c0906d3
parentaa9c9ce4f5fe6a0f5103be9a1d4e63a85f98e672 (diff)
downloadfreebsd-ports-gnome-36fc2e4cd965a9f68372d8e5ae8d15aeebfcf2f8.tar.gz
freebsd-ports-gnome-36fc2e4cd965a9f68372d8e5ae8d15aeebfcf2f8.tar.zst
freebsd-ports-gnome-36fc2e4cd965a9f68372d8e5ae8d15aeebfcf2f8.zip
Convert from USE_GECKO to USES=gecko
While here stagify what was not staged yet Convert to USES=webplugin where needed and add desktop-file-utils dependency to icedtea-web
-rw-r--r--editors/morla/Makefile26
-rw-r--r--editors/morla/pkg-plist2
-rw-r--r--java/icedtea-web/Makefile7
-rw-r--r--science/gchemutils/Makefile19
-rw-r--r--www/gecko-mediaplayer/Makefile12
-rw-r--r--www/gecko-mediaplayer/pkg-plist12
-rw-r--r--x11-toolkits/swt-devel/Makefile9
-rw-r--r--x11-toolkits/swt/Makefile11
8 files changed, 39 insertions, 59 deletions
diff --git a/editors/morla/Makefile b/editors/morla/Makefile
index 223f21066e8e..22cc9f8d0e37 100644
--- a/editors/morla/Makefile
+++ b/editors/morla/Makefile
@@ -9,12 +9,12 @@ MASTER_SITES= http://www.morlardf.net/src/ \
http://nivi.interfree.it/distfiles/${PORTNAME}/${PORTVERSION}/
MAINTAINER= nivit@FreeBSD.org
-COMMENT= A RDF editor
+COMMENT= RDF editor
-LIB_DEPENDS= nxml.18:${PORTSDIR}/textproc/libnxml \
- rdf.0:${PORTSDIR}/textproc/redland \
- raptor2.0:${PORTSDIR}/textproc/raptor2 \
- curl:${PORTSDIR}/ftp/curl
+LIB_DEPENDS= libnxml.so:${PORTSDIR}/textproc/libnxml \
+ librdf.so:${PORTSDIR}/textproc/redland \
+ libraptor2.so:${PORTSDIR}/textproc/raptor2 \
+ libcurl.so:${PORTSDIR}/ftp/curl
BUILD_DEPENDS= dot:${PORTSDIR}/graphics/graphviz
RUN_DEPENDS= dot:${PORTSDIR}/graphics/graphviz
@@ -29,8 +29,6 @@ USES= gettext pkgconfig
USE_GNOME= gconf2 libgtkhtml libxslt
USE_LDCONFIG= ${PREFIX}/lib/${PORTNAME}
-MAN1= morla.1
-
DESKTOP_ENTRIES="morla" \
"Edit RDF documents" \
"${DATADIR}/icons/128_color.png" \
@@ -38,18 +36,12 @@ DESKTOP_ENTRIES="morla" \
"WebDevelopment;" \
true
-NO_STAGE= yes
+XULRUNNER_USES= gecko
+XULRUNNER_CONFIGURE_ON= --with-javascript=xulrunner
+XULRUNNER_CONFIGURE_OFF= --with-javascript=none
+
post-patch:
@${REINPLACE_CMD} -e 's|-D.*_DISABLE_DEPRECATED||g' \
${WRKSRC}/configure
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MXULRUNNER}
-USE_GECKO= libxul
-CONFIGURE_ARGS+= --with-javascript=xulrunner
-.else
-CONFIGURE_ARGS+= --with-javascript=none
-.endif
-
.include <bsd.port.mk>
diff --git a/editors/morla/pkg-plist b/editors/morla/pkg-plist
index 83839f221a9b..34b6b86e615c 100644
--- a/editors/morla/pkg-plist
+++ b/editors/morla/pkg-plist
@@ -4,7 +4,7 @@ lib/morla/index.xml
lib/morla/libmorla_test.a
lib/morla/libmorla_test.la
lib/morla/libmorla_test.so
-libdata/ldconfig/morla
+man/man1/morla.1.gz
share/locale/it/LC_MESSAGES/morla.mo
%%DATADIR%%/bootsplash.png
%%DATADIR%%/icons/128_BN.png
diff --git a/java/icedtea-web/Makefile b/java/icedtea-web/Makefile
index 84fdcc893e89..86aff635dbf7 100644
--- a/java/icedtea-web/Makefile
+++ b/java/icedtea-web/Makefile
@@ -2,7 +2,7 @@
PORTNAME= icedtea-web
PORTVERSION= 1.4.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= java www
MASTER_SITES= http://icedtea.wildebeest.org/download/source/ \
http://icedtea.classpath.org/download/source/
@@ -23,7 +23,7 @@ JAVA_VENDOR= openjdk
JAVA_VERSION= 1.6+
USE_PERL5= build
USE_XORG= x11
-USES= gmake perl5 pkgconfig shebangfix
+USES= gmake perl5 pkgconfig shebangfix desktop-file-utils
SHEBANG_FILES= javac.in jrunscript.in
WANT_GNOME= yes
@@ -57,9 +57,8 @@ CONFIGURE_ARGS+=--disable-docs
.endif
.if ${PORT_OPTIONS:MPLUGIN}
-USE_GECKO= libxul
USE_GNOME= glib20
-USES+= webplugin:native
+USES+= webplugin:native gecko
WEBPLUGIN_DIR= ${PREFIX}/lib
WEBPLUGIN_FILES=IcedTeaPlugin.so
diff --git a/science/gchemutils/Makefile b/science/gchemutils/Makefile
index 35629c531b0d..c036a90f6561 100644
--- a/science/gchemutils/Makefile
+++ b/science/gchemutils/Makefile
@@ -21,11 +21,10 @@ RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/bodr.pc:${PORTSDIR}/science/bodr \
PORTSCOUT= limitw:1,even
-USE_XZ= yes
USE_XORG= x11
USE_GNOME= gnomedocutils gtk30 intlhack libgsf libxml2
USES= desktop-file-utils gettext gmake libtool pathfix pkgconfig \
- shared-mime-info
+ shared-mime-info tar:xz
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
@@ -42,20 +41,16 @@ VER= ${PORTVERSION:R}
PLIST_SUB= VER=${VER} GOFFICE=0.10 VERSION=${PORTVERSION}
OPTIONS_DEFINE= GNUMERIC XUL
+OPTIONS_SUB= yes
GNUMERIC_DESC= Build gnumeric plugin
XUL_DESC= Build browser plugin (requires libxul)
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MXUL}
-USE_GECKO= libxul
-CONFIGURE_ARGS+=--enable-mozilla-plugin \
+XUL_USES= gecko
+XUL_CONFIGURE_ON=--enable-mozilla-plugin \
--with-mozilla-libdir=${PREFIX}/lib/xulrunner
-PLIST_SUB+= XUL=""
-.else
-CONFIGURE_ARGS+=--disable-mozilla-plugin
-PLIST_SUB+= XUL="@comment "
-.endif
+XUL_CONFIGURE_OFF=--disable-mozilla-plugin
+
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MGNUMERIC} || exists(${LOCALBASE}/lib/libspreadsheet.so)
LIB_DEPENDS+= libspreadsheet.so:${PORTSDIR}/math/gnumeric
diff --git a/www/gecko-mediaplayer/Makefile b/www/gecko-mediaplayer/Makefile
index 6b78211c64df..433039ad8597 100644
--- a/www/gecko-mediaplayer/Makefile
+++ b/www/gecko-mediaplayer/Makefile
@@ -23,23 +23,20 @@ OPTIONS_DEFAULT=CACHE
CACHE_DESC= Enable caching of remote media to local storage
GNU_CONFIGURE= yes
-USES= compiler:c++11-lang pkgconfig
+USES= compiler:c++11-lang pkgconfig gecko webplugin:native
USE_GNOME= glib20
-USE_GECKO= libxul
-USE_WEBPLUGINS= native
-WEBPLUGINS_FILES= ${PORTNAME}.so
+WEBPLUGIN_FILES= ${PORTNAME}.so
.for p in dvx rm qt wmp
-WEBPLUGINS_FILES+= ${PORTNAME}-${p}.so
+WEBPLUGIN_FILES+= ${PORTNAME}-${p}.so
.endfor
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ARGS+=--with-plugin_dir="${WEBPLUGINS_DIR}"
+CONFIGURE_ARGS+=--with-plugin_dir="${WEBPLUGIN_DIR}"
PORTDOCS= README COPYING AUTHORS ChangeLog INSTALL NEWS javascript.txt
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MCACHE}
@@ -70,5 +67,4 @@ post-patch:
${WRKSRC}/configure
.endif
-.include "${PORTSDIR}/www/firefox/Makefile.webplugins"
.include <bsd.port.mk>
diff --git a/www/gecko-mediaplayer/pkg-plist b/www/gecko-mediaplayer/pkg-plist
index 3f0dfcdca124..4a5a611953a4 100644
--- a/www/gecko-mediaplayer/pkg-plist
+++ b/www/gecko-mediaplayer/pkg-plist
@@ -1,8 +1,8 @@
-%%WEBPLUGINS_DIR%%/gecko-mediaplayer-dvx.so
-%%WEBPLUGINS_DIR%%/gecko-mediaplayer-qt.so
-%%WEBPLUGINS_DIR%%/gecko-mediaplayer-rm.so
-%%WEBPLUGINS_DIR%%/gecko-mediaplayer-wmp.so
-%%WEBPLUGINS_DIR%%/gecko-mediaplayer.so
+%%WEBPLUGIN_DIR%%/gecko-mediaplayer-dvx.so
+%%WEBPLUGIN_DIR%%/gecko-mediaplayer-qt.so
+%%WEBPLUGIN_DIR%%/gecko-mediaplayer-rm.so
+%%WEBPLUGIN_DIR%%/gecko-mediaplayer-wmp.so
+%%WEBPLUGIN_DIR%%/gecko-mediaplayer.so
%%NLS%%share/locale/cs/LC_MESSAGES/gecko-mediaplayer.mo
%%NLS%%share/locale/de/LC_MESSAGES/gecko-mediaplayer.mo
%%NLS%%share/locale/es/LC_MESSAGES/gecko-mediaplayer.mo
@@ -14,4 +14,4 @@
%%NLS%%share/locale/pt/LC_MESSAGES/gecko-mediaplayer.mo
%%NLS%%share/locale/pt_BR/LC_MESSAGES/gecko-mediaplayer.mo
%%NLS%%share/locale/tr/LC_MESSAGES/gecko-mediaplayer.mo
-@dirrmtry %%WEBPLUGINS_DIR%%
+@dirrmtry %%WEBPLUGIN_DIR%%
diff --git a/x11-toolkits/swt-devel/Makefile b/x11-toolkits/swt-devel/Makefile
index 286ab06c3afe..8291a87e4110 100644
--- a/x11-toolkits/swt-devel/Makefile
+++ b/x11-toolkits/swt-devel/Makefile
@@ -45,7 +45,6 @@ MOZILLA_DESC= Gecko browser support
OPTIONS_DEFAULT=CAIRO GNOMEVFS
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MCAIRO}
@@ -61,7 +60,7 @@ MAKE_GNOME= make_gnome
.endif
.if ${PORT_OPTIONS:MMOZILLA}
-USE_GECKO= libxul
+USES= gecko
BROKEN= Does now work with newer libxul
PLIST_FILES+= lib/libswt-xulrunner-gtk-%%BUILD%%.so
MAKE_MOZILLA= make_xulrunner
@@ -96,8 +95,8 @@ post-patch:
${FILESDIR}/build.xml > ${WRKSRC}/build.xml
do-install:
- ${MKDIR} ${JAVAJARDIR}
- ${INSTALL_DATA} ${WRKSRC}/libswt-*.so ${PREFIX}/lib
- ${INSTALL_DATA} ${WRKSRC}/${OUTPUT_JAR} ${JAVAJARDIR}/
+ @${MKDIR} ${STAGEDIR}${JAVAJARDIR}
+ ${INSTALL_LIB} ${WRKSRC}/libswt-*.so ${STAGEDIR}${PREFIX}/lib
+ ${INSTALL_DATA} ${WRKSRC}/${OUTPUT_JAR} ${STAGEDIR}${JAVAJARDIR}/
.include <bsd.port.post.mk>
diff --git a/x11-toolkits/swt/Makefile b/x11-toolkits/swt/Makefile
index f03bda814436..216bd7e8bd30 100644
--- a/x11-toolkits/swt/Makefile
+++ b/x11-toolkits/swt/Makefile
@@ -47,11 +47,10 @@ OPTIONS_DEFAULT= CAIRO GNOMEVFS
GNOMEVFS_DESC= Gnome VFS Support
BROWSER_DESC= Gecko Browser Support
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MCAIRO}
-LIB_DEPENDS+= cairo.2:${PORTSDIR}/graphics/cairo
+LIB_DEPENDS+= libcairo.so:${PORTSDIR}/graphics/cairo
PLIST_FILES+= lib/libswt-cairo-gtk-%%BUILD%%.so
MAKE_CAIRO= make_cairo
.endif
@@ -63,7 +62,7 @@ MAKE_GNOME= make_gnome
.endif
.if ${PORT_OPTIONS:MBROWSER}
-USE_GECKO= libxul
+USES= gecko
BROKEN= Does not build with newer libxul
PLIST_FILES+= lib/libswt-xulrunner-gtk-%%BUILD%%.so
MAKE_MOZILLA= make_xulrunner
@@ -85,8 +84,8 @@ post-extract:
@${RM} -f ${WRKSRC}/*.o ${WRKSRC}/*.so ${WRKSRC}/*.jar
do-install:
- ${MKDIR} ${JAVAJARDIR}
- ${INSTALL_DATA} ${WRKSRC}/libswt-*.so ${PREFIX}/lib
- ${INSTALL_DATA} ${WRKSRC}/${OUTPUT_JAR} ${JAVAJARDIR}/
+ @${MKDIR} ${STAGEDIR}${JAVAJARDIR}
+ ${INSTALL_LIB} ${WRKSRC}/libswt-*.so ${STAGEDIR}${PREFIX}/lib
+ ${INSTALL_DATA} ${WRKSRC}/${OUTPUT_JAR} ${STAGEDIR}${JAVAJARDIR}/
.include <bsd.port.mk>