aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormmoll <mmoll@FreeBSD.org>2015-10-07 05:19:38 +0800
committermmoll <mmoll@FreeBSD.org>2015-10-07 05:19:38 +0800
commit37772859d21f29dca7fe3fc90595988c96821551 (patch)
treedc6474ae6ab317aacd56a75f58bbc7e4f0c49317
parent1f3a6a444f38668af278c8a2440b9d0438ff08f9 (diff)
downloadfreebsd-ports-gnome-37772859d21f29dca7fe3fc90595988c96821551.tar.gz
freebsd-ports-gnome-37772859d21f29dca7fe3fc90595988c96821551.tar.zst
freebsd-ports-gnome-37772859d21f29dca7fe3fc90595988c96821551.zip
new port: devel/rubygem-ruby-progressbar
Ruby/ProgressBar is an extremely flexible text progress bar library for Ruby. The output can be customized with a flexible formatting system including percentage, bars of various formats, elapsed time and estimated time remaining. WWW: https://github.com/jfelchner/ruby-progressbar As this gem is based on the code that's available as misc/ruby-progressbar, conflict with it, to avoid problems.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-ruby-progressbar/Makefile21
-rw-r--r--devel/rubygem-ruby-progressbar/distinfo2
-rw-r--r--devel/rubygem-ruby-progressbar/pkg-descr5
-rw-r--r--misc/ruby-progressbar/Makefile2
5 files changed, 31 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 01b2a6793679..59c565528f08 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4907,6 +4907,7 @@
SUBDIR += rubygem-ruby-filemagic
SUBDIR += rubygem-ruby-ole
SUBDIR += rubygem-ruby-prof
+ SUBDIR += rubygem-ruby-progressbar
SUBDIR += rubygem-ruby-sdl-ffi
SUBDIR += rubygem-ruby2ruby
SUBDIR += rubygem-ruby_parser
diff --git a/devel/rubygem-ruby-progressbar/Makefile b/devel/rubygem-ruby-progressbar/Makefile
new file mode 100644
index 000000000000..ff620acb87de
--- /dev/null
+++ b/devel/rubygem-ruby-progressbar/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= ruby-progressbar
+PORTVERSION= 1.7.5
+CATEGORIES= devel ruby
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Progressbar library for Ruby
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+CONFLICTS_INSTALL= ${RUBY_PKGNAMEPREFIX}progressbar-*
+
+NO_ARCH= yes
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-ruby-progressbar/distinfo b/devel/rubygem-ruby-progressbar/distinfo
new file mode 100644
index 000000000000..16306cbbca5b
--- /dev/null
+++ b/devel/rubygem-ruby-progressbar/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/ruby-progressbar-1.7.5.gem) = 71c754e2e3f26b87f307e360dee8f2267800b88327a7def0098d7e6cb752d643
+SIZE (rubygem/ruby-progressbar-1.7.5.gem) = 21504
diff --git a/devel/rubygem-ruby-progressbar/pkg-descr b/devel/rubygem-ruby-progressbar/pkg-descr
new file mode 100644
index 000000000000..91fac8416242
--- /dev/null
+++ b/devel/rubygem-ruby-progressbar/pkg-descr
@@ -0,0 +1,5 @@
+Ruby/ProgressBar is an extremely flexible text progress bar library for Ruby.
+The output can be customized with a flexible formatting system including
+percentage, bars of various formats, elapsed time and estimated time remaining.
+
+WWW: https://github.com/jfelchner/ruby-progressbar
diff --git a/misc/ruby-progressbar/Makefile b/misc/ruby-progressbar/Makefile
index dbafc5c0b75d..f508d63b42f3 100644
--- a/misc/ruby-progressbar/Makefile
+++ b/misc/ruby-progressbar/Makefile
@@ -3,6 +3,7 @@
PORTNAME= progressbar
PORTVERSION= 0.9
+PORTREVISION= 1
CATEGORIES= misc ruby
MASTER_SITES= http://0xcc.net/ruby-progressbar/ \
LOCAL/tota/progressbar
@@ -12,6 +13,7 @@ DISTNAME= ruby-${PORTNAME}-${PORTVERSION}
MAINTAINER= tota@FreeBSD.org
COMMENT= Text progress bar library for Ruby
+CONFLICTS_INSTALL= rubygem-ruby-progressbar-*
USE_RUBY= yes
NO_BUILD= yes