aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoranholt <anholt@FreeBSD.org>2003-12-22 08:39:02 +0800
committeranholt <anholt@FreeBSD.org>2003-12-22 08:39:02 +0800
commit3942b3fd58b10719d2f5f308104e55a8342ef833 (patch)
tree7b7cbd34fa1506f9249b90156601d03ca586e8b8
parent23dc120cf7b1d577d1302877c5db280b106251aa (diff)
downloadfreebsd-ports-gnome-3942b3fd58b10719d2f5f308104e55a8342ef833.tar.gz
freebsd-ports-gnome-3942b3fd58b10719d2f5f308104e55a8342ef833.tar.zst
freebsd-ports-gnome-3942b3fd58b10719d2f5f308104e55a8342ef833.zip
New port: Prerelease version of libXv from freedesktop.org:
X Video extension library Testing is encouraged, but please do not use these ports as dependencies until they are updated to release tarballs and the XFree86 ports have been updated to depend on them.
-rw-r--r--x11/Makefile1
-rw-r--r--x11/libXv/Makefile33
-rw-r--r--x11/libXv/distinfo1
-rw-r--r--x11/libXv/files/patch-Makefile.in11
-rw-r--r--x11/libXv/pkg-descr6
-rw-r--r--x11/libXv/pkg-plist6
6 files changed, 58 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 757a01ab925f..5c119b0f2759 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -81,6 +81,7 @@
SUBDIR += libXfont
SUBDIR += libXres
SUBDIR += libXtrans
+ SUBDIR += libXv
SUBDIR += libcapplet
SUBDIR += libdnd
SUBDIR += libgnome
diff --git a/x11/libXv/Makefile b/x11/libXv/Makefile
new file mode 100644
index 000000000000..9b9889fb229e
--- /dev/null
+++ b/x11/libXv/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: libXv
+# Date Created: 13 Nov, 2003
+# Whom: Eric Anholt <anholt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libXv
+PORTVERSION= 2.2.1.p1
+CATEGORIES= x11
+MASTER_SITES= http://pdx.freedesktop.org/~xlibs/dist/
+DISTNAME= ${PORTNAME}-${REALVERSION}
+
+MAINTAINER= x11@FreeBSD.org
+COMMENT= X11 Extension library
+
+LIB_PC_DEPENDS= ${X11BASE}/libdata/pkgconfig/x11.pc:${PORTSDIR}/x11/libX11
+BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig \
+ ${X11BASE}/libdata/pkgconfig/xextensions.pc:${PORTSDIR}/x11/xextensions \
+ ${LIB_PC_DEPENDS}
+RUN_DEPENDS= ${LIB_PC_DEPENDS}
+
+USE_BZIP2= yes
+PREFIX?= ${X11BASE}
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+CFLAGS+= -DMALLOC_0_RETURNS_NULL
+WRKSRC= ${WRKDIR}/${PORTNAME}-2.2.1
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>
diff --git a/x11/libXv/distinfo b/x11/libXv/distinfo
new file mode 100644
index 000000000000..e0bdc76e9174
--- /dev/null
+++ b/x11/libXv/distinfo
@@ -0,0 +1 @@
+MD5 (libXv-2.2.1.tar.bz2) = 8f0f856eaae66c8d16666123691b5e6e
diff --git a/x11/libXv/files/patch-Makefile.in b/x11/libXv/files/patch-Makefile.in
new file mode 100644
index 000000000000..ed01a370f02e
--- /dev/null
+++ b/x11/libXv/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Thu Nov 6 23:58:12 2003
++++ Makefile.in Thu Nov 13 14:56:03 2003
+@@ -157,7 +157,7 @@
+ libXvincludedir = $(includedir)/X11/extensions
+ libXvinclude_HEADERS = Xvlib.h
+
+-pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = $(prefix)/libdata/pkgconfig
+ pkgconfig_DATA = xv.pc
+
+ EXTRA_DIST = xv.pc.in autogen.sh
diff --git a/x11/libXv/pkg-descr b/x11/libXv/pkg-descr
new file mode 100644
index 000000000000..cbd30172204a
--- /dev/null
+++ b/x11/libXv/pkg-descr
@@ -0,0 +1,6 @@
+This package contains the X Video Extension library.
+
+WWW: http://www.freedesktop.org/Software/xlibs
+
+- Eric Anholt
+anholt@FreeBSD.org
diff --git a/x11/libXv/pkg-plist b/x11/libXv/pkg-plist
new file mode 100644
index 000000000000..f33155ee28b9
--- /dev/null
+++ b/x11/libXv/pkg-plist
@@ -0,0 +1,6 @@
+include/X11/extensions/Xvlib.h
+lib/libXv.a
+lib/libXv.la
+lib/libXv.so
+lib/libXv.so.2
+libdata/pkgconfig/xv.pc