aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2018-06-11 09:44:15 +0800
committerlinimon <linimon@FreeBSD.org>2018-06-11 09:44:15 +0800
commit39e31de51fbf694ff20f162572dc22c61f7d1b9d (patch)
treed21fd4ee60da4c705d6bb2d4d0222a7e7af7ef7b
parent1ddd46af14a4033deba9f651fa531f8aa83ea3f7 (diff)
downloadfreebsd-ports-gnome-39e31de51fbf694ff20f162572dc22c61f7d1b9d.tar.gz
freebsd-ports-gnome-39e31de51fbf694ff20f162572dc22c61f7d1b9d.tar.zst
freebsd-ports-gnome-39e31de51fbf694ff20f162572dc22c61f7d1b9d.zip
Fix port builds for architectures which remain on gcc as the default compiler.
This will primarily help powerpc64. For archs where clang is the default compiler, these changes will have no effect, as the base compiler already has these capabilities (primarily, but not exclusively, c++-11). Tested for no-harm on amd64. While here, pet portlint. Approved by: portmgr (tier-2 blanket)
-rw-r--r--audio/faust/Makefile2
-rw-r--r--audio/gxplugins-lv2/Makefile2
-rw-r--r--benchmarks/polygraph/Makefile4
-rw-r--r--comms/svxlink/Makefile2
-rw-r--r--devel/aegis/Makefile2
-rw-r--r--devel/astyle/Makefile2
-rw-r--r--devel/codequery/Makefile2
-rw-r--r--devel/geany/Makefile4
-rw-r--r--devel/liborcus/Makefile2
-rw-r--r--devel/oclgrind/Makefile7
-rw-r--r--devel/woff2/Makefile2
-rw-r--r--games/gnome-sudoku/Makefile2
-rw-r--r--games/qqwing/Makefile4
-rw-r--r--graphics/gegl/Makefile6
-rw-r--r--graphics/gegl3/Makefile4
-rw-r--r--graphics/libwpg03/Makefile2
-rw-r--r--graphics/opencollada/Makefile10
-rw-r--r--mail/cone/Makefile3
-rw-r--r--math/ambit/Makefile3
-rw-r--r--math/clblast/Makefile3
-rw-r--r--math/glm/Makefile3
-rw-r--r--net-im/ekiga/Makefile4
-rw-r--r--net-mgmt/icinga2/Makefile5
-rw-r--r--net-mgmt/metronome/Makefile2
-rw-r--r--net/libcmis/Makefile6
-rw-r--r--print/qpdf/Makefile3
-rw-r--r--sysutils/cdrdao/Makefile6
-rw-r--r--sysutils/fsearch/Makefile4
-rw-r--r--sysutils/gigolo/Makefile6
-rw-r--r--sysutils/polkit/Makefile3
-rw-r--r--sysutils/smartmontools/Makefile2
-rw-r--r--sysutils/tracker/Makefile5
-rw-r--r--textproc/kiss-templates/Makefile5
-rw-r--r--textproc/libwpd010/Makefile2
-rw-r--r--textproc/mythes/Makefile2
-rw-r--r--textproc/rubygem-liquid-tag-parser/Makefile2
-rw-r--r--x11-fm/nautilus/Makefile4
-rw-r--r--x11-toolkits/gtkmm30-reference/Makefile2
-rw-r--r--x11/babl/Makefile2
-rw-r--r--x11/yelp/Makefile4
40 files changed, 64 insertions, 76 deletions
diff --git a/audio/faust/Makefile b/audio/faust/Makefile
index d5cf839295ba..09ddcaf3f08d 100644
--- a/audio/faust/Makefile
+++ b/audio/faust/Makefile
@@ -13,7 +13,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libLLVM-${LLVM_VERSION:C/([1-9])([0-9])/\1.\2/}.so:devel/llvm${LLVM_VERSION}
-USES= gmake ncurses python pkgconfig shebangfix
+USES= compiler:c++11-lang gmake ncurses python pkgconfig shebangfix
USE_GITHUB= yes
GH_ACCOUNT= grame-cncm
GH_TUPLE= grame-cncm:faustlibraries:f889fe1:libs/libraries \
diff --git a/audio/gxplugins-lv2/Makefile b/audio/gxplugins-lv2/Makefile
index 3ef7a035988e..d6e6019a6634 100644
--- a/audio/gxplugins-lv2/Makefile
+++ b/audio/gxplugins-lv2/Makefile
@@ -16,7 +16,7 @@ BUILD_DEPENDS= lv2>0:audio/lv2
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
-USES= gettext-runtime gmake localbase pkgconfig
+USES= compiler:c++11-lang gettext-runtime gmake localbase pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= brummer10
GH_PROJECT= GxPlugins.lv2
diff --git a/benchmarks/polygraph/Makefile b/benchmarks/polygraph/Makefile
index 03e8bd4e9cce..430b527902e9 100644
--- a/benchmarks/polygraph/Makefile
+++ b/benchmarks/polygraph/Makefile
@@ -3,8 +3,8 @@
PORTNAME= polygraph
PORTVERSION= 4.11.0
-PORTREVISION= 1
DISTVERSIONSUFFIX= -src
+PORTREVISION= 1
CATEGORIES= benchmarks www
MASTER_SITES= http://www.web-polygraph.org/downloads/srcs/
@@ -19,7 +19,7 @@ BROKEN_SSL_REASON_openssl-devel= configure: error: OpenSSL libraries and/or dire
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-USES= gmake ncurses shebangfix tar:tgz
+USES= compiler:c++0x gmake ncurses shebangfix tar:tgz
SHEBANG_FILES= tools/*.pl
USE_GCC= any
GNU_CONFIGURE= yes
diff --git a/comms/svxlink/Makefile b/comms/svxlink/Makefile
index 50f170890da4..dbbb7cca32c5 100644
--- a/comms/svxlink/Makefile
+++ b/comms/svxlink/Makefile
@@ -22,11 +22,11 @@ LIB_DEPENDS?= libgsm.so:audio/gsm \
BUILD_DEPENDS= pkg-config:devel/pkgconf \
${LOCALBASE}/include/linux/input.h:multimedia/v4l_compat
+USES= cmake compiler:c++11-lang tcl groff
USE_GITHUB= yes
GH_ACCOUNT= sm0svx
GH_PROJECT= svxlink
-USES= cmake tcl groff
CMAKE_SOURCE_PATH= ${WRKSRC}/src
CMAKE_ARGS+= -DMAN_INSTALL_DIR:FILEPATH=${MANDIRS} \
-DLOCAL_STATE_DIR=/var
diff --git a/devel/aegis/Makefile b/devel/aegis/Makefile
index 462f8bbdf58a..2ea56659bd65 100644
--- a/devel/aegis/Makefile
+++ b/devel/aegis/Makefile
@@ -16,7 +16,7 @@ LICENSE= GPLv3
LIB_DEPENDS= libcurl.so:ftp/curl
RUN_DEPENDS= tkdiff:textproc/tkdiff
-USES= gettext ghostscript groff perl5 tk
+USES= compiler:c++0x gettext ghostscript groff perl5 tk
USE_GNOME= libxml2
USE_GCC= any
GNU_CONFIGURE= yes
diff --git a/devel/astyle/Makefile b/devel/astyle/Makefile
index a5a38603e95c..724bcdfefa6c 100644
--- a/devel/astyle/Makefile
+++ b/devel/astyle/Makefile
@@ -13,7 +13,7 @@ COMMENT= Source code indenter and formatter for C, C++, C\#, and Java
LICENSE= MIT
LICENSE_FILE= ${WRKDIR}/astyle/LICENSE.md
-USES= compiler dos2unix gmake
+USES= compiler:c++11-lang dos2unix gmake
ALL_TARGET= astyle
DOS2UNIX_GLOB= *.ini
diff --git a/devel/codequery/Makefile b/devel/codequery/Makefile
index 3cc1a150e350..ffefda493b19 100644
--- a/devel/codequery/Makefile
+++ b/devel/codequery/Makefile
@@ -14,7 +14,7 @@ LICENSE_COMB= multi
LICENSE_FILE_MPL20= ${WRKSRC}/LICENSE.md
LICENSE_FILE_MIT= ${WRKSRC}/querylib/README.txt
-USES= cmake ninja sqlite
+USES= cmake compiler:c++11-lang ninja sqlite
USE_GITHUB= yes
GH_ACCOUNT= ruben2020
diff --git a/devel/geany/Makefile b/devel/geany/Makefile
index 053b119dfedf..e22fb1c38c0c 100644
--- a/devel/geany/Makefile
+++ b/devel/geany/Makefile
@@ -15,11 +15,11 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
+USES= compiler:c++11-lang desktop-file-utils gettext-tools gmake libtool \
+ localbase pathfix pkgconfig tar:bzip2
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
USE_GNOME= cairo gtk20 intltool
-USES= desktop-file-utils gettext-tools gmake libtool \
- localbase pathfix pkgconfig tar:bzip2
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
diff --git a/devel/liborcus/Makefile b/devel/liborcus/Makefile
index 7bdef4d290e7..64a05d3bfe31 100644
--- a/devel/liborcus/Makefile
+++ b/devel/liborcus/Makefile
@@ -14,8 +14,6 @@ LICENSE= MPL20
BUILD_DEPENDS= ${LOCALBASE}/include/mdds-1.2/mdds/global.hpp:devel/mdds
LIB_DEPENDS= libboost_system.so:devel/boost-libs
-BROKEN_powerpc64= fails to configure: checking for the Boost program_options library... no
-
GNU_CONFIGURE= yes
USES= compiler:c++11-lib libtool pathfix pkgconfig tar:xz
USE_LDCONFIG= yes
diff --git a/devel/oclgrind/Makefile b/devel/oclgrind/Makefile
index 13a398d35da5..25eedcda6363 100644
--- a/devel/oclgrind/Makefile
+++ b/devel/oclgrind/Makefile
@@ -12,20 +12,19 @@ COMMENT= SPIR interpreter and virtual OpenCL device simulator
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+BROKEN_FreeBSD_10= oclgrind is only supported on FreeBSD 11.0 and newer, crashes LLVM 3.4
+
BUILD_DEPENDS= opencl>=0:devel/opencl \
llvm-config50:devel/llvm50
LIB_DEPENDS= libOpenCL.so:devel/ocl-icd
RUN_DEPENDS= opencl>=0:devel/opencl
-BROKEN_FreeBSD_10= oclgrind is only supported on FreeBSD 11.0 and newer, crashes LLVM 3.4
-
+USES= cmake compiler:c++11-lang
USE_GITHUB= yes
GH_ACCOUNT= jrprice
GH_PROJECT= Oclgrind
GH_TAGNAME= e99899d
-
USE_LDCONFIG= yes
-USES= cmake
CMAKE_ARGS+= -DLLVM_DIR=${LOCALBASE}/llvm50/share/llvm/cmake
diff --git a/devel/woff2/Makefile b/devel/woff2/Makefile
index 6830b1c62e7b..27720ce6744d 100644
--- a/devel/woff2/Makefile
+++ b/devel/woff2/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libbrotlidec.so:archivers/brotli
-USES= cmake:outsource
+USES= cmake:outsource compiler:c++11-lib
USE_GITHUB= yes
GH_ACCOUNT= google
USE_LDCONFIG= yes
diff --git a/games/gnome-sudoku/Makefile b/games/gnome-sudoku/Makefile
index e35629bdaed1..2879cc0425c9 100644
--- a/games/gnome-sudoku/Makefile
+++ b/games/gnome-sudoku/Makefile
@@ -22,7 +22,7 @@ LIB_DEPENDS= libgee-0.8.so:devel/libgee \
PORTSCOUT= limitw:1,even
-USES= gettext gmake gnome localbase pathfix \
+USES= compiler:c++11-lang gettext gmake gnome localbase pathfix \
pkgconfig python:3.3+ shebangfix tar:xz
USE_GNOME= cairo gtk30 intlhack libxml2:build pygobject3
INSTALLS_ICONS= yes
diff --git a/games/qqwing/Makefile b/games/qqwing/Makefile
index 09b8e9dad7d0..48567228a712 100644
--- a/games/qqwing/Makefile
+++ b/games/qqwing/Makefile
@@ -3,17 +3,17 @@
PORTNAME= qqwing
PORTVERSION= 1.3.4
DISTVERSIONPREFIX= v
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games gnome
DIST_SUBDIR= gnome3
MAINTAINER= gnome@FreeBSD.org
COMMENT= Sudoku generating and solving software
+USES= autoreconf compiler:c++11-lang gmake libtool pathfix pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= stephenostermiller
-USES= autoreconf gmake libtool pathfix pkgconfig
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_OUTSOURCE= yes
diff --git a/graphics/gegl/Makefile b/graphics/gegl/Makefile
index c6515d273e21..2c5e0507d290 100644
--- a/graphics/gegl/Makefile
+++ b/graphics/gegl/Makefile
@@ -15,10 +15,10 @@ LICENSE_COMB= multi
LICENSE_FILE_GPLv3+ = ${WRKSRC}/COPYING
LICENSE_FILE_LGPL3+ = ${WRKSRC}/COPYING.LESSER
-LIB_DEPENDS= libbabl-0.1.so:x11/babl
-
BROKEN_aarch64= fails to build: gmake index.html: Segmentation fault in docs/gallery/
+LIB_DEPENDS= libbabl-0.1.so:x11/babl
+
# ignore new versions until we can replace this version with gegl 3.x
PORTSCOUT= ignore:1
@@ -41,7 +41,7 @@ CONFIGURE_ARGS= --without-vala --disable-docs
INSTALL_TARGET= install-strip
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -lintl
+LDFLAGS+= -L${LOCALBASE}/lib -lintl -lm
GEGL_MINOR= 199
GEGL_VER= 0.2
diff --git a/graphics/gegl3/Makefile b/graphics/gegl3/Makefile
index eecc3b9cbe04..9367e5a64dd7 100644
--- a/graphics/gegl3/Makefile
+++ b/graphics/gegl3/Makefile
@@ -19,8 +19,8 @@ LIB_DEPENDS= libbabl-0.1.so:x11/babl \
libjson-glib-1.0.so:devel/json-glib \
libpng.so:graphics/png
-USES= cpe gettext gmake jpeg libtool localbase pathfix pkgconfig \
- shebangfix uniquefiles tar:bzip2
+USES= cpe gettext gmake jpeg libtool localbase \
+ pathfix pkgconfig shebangfix uniquefiles tar:bzip2
USE_GNOME= glib20 intltool introspection:build
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/graphics/libwpg03/Makefile b/graphics/libwpg03/Makefile
index 703dc7aad199..3534d9bce5d3 100644
--- a/graphics/libwpg03/Makefile
+++ b/graphics/libwpg03/Makefile
@@ -17,7 +17,7 @@ LICENSE_FILE_MPL20= ${WRKSRC}/COPYING.MPL
LIB_DEPENDS= librevenge-0.0.so:textproc/librevenge \
libwpd-0.10.so:textproc/libwpd010
-USES= libtool pathfix perl5 pkgconfig shebangfix tar:bzip2
+USES= compiler:c++11-lang libtool pathfix perl5 pkgconfig shebangfix tar:bzip2
SHEBANG_FILES= ${WRKSRC}/src/conv/svg/wpg2svgbatch.pl
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/graphics/opencollada/Makefile b/graphics/opencollada/Makefile
index 8f130cef01f7..14e10db3f66b 100644
--- a/graphics/opencollada/Makefile
+++ b/graphics/opencollada/Makefile
@@ -11,11 +11,11 @@ COMMENT= Library for reading and writing COLLADA files
LICENSE= MIT
-LIB_DEPENDS= libpcre.so:devel/pcre
+BROKEN_sparc64= cannot build: runaway process
-BROKEN_powerpc64= Does not build: c++: Internal error: Killed (program cc1plus)
+LIB_DEPENDS= libpcre.so:devel/pcre
-USES= cmake:outsource compiler dos2unix iconv pkgconfig
+USES= cmake:outsource compiler:c++11-lib dos2unix iconv pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= KhronosGroup
@@ -23,11 +23,9 @@ GH_PROJECT= OpenCOLLADA
USE_GNOME= libxml2
USE_LDCONFIG= ${PREFIX}/lib/opencollada
-CFLAGS+= -I/${LOCALBASE}/include
+CFLAGS+= -I/${LOCALBASE}/include -Wno-narrowing
CMAKE_ARGS+= -DUSE_SHARED:BOOL=ON -DUSE_STATIC:BOOL=OFF
-BROKEN_sparc64= cannot build: runaway process
-
# for files/patch-2d66943
DOS2UNIX_FILES= COLLADABaseUtils/include/COLLADABUPcreCompiledPattern.h \
COLLADABaseUtils/src/COLLADABUURI.cpp
diff --git a/mail/cone/Makefile b/mail/cone/Makefile
index 2a1789590227..e9198de1b39a 100644
--- a/mail/cone/Makefile
+++ b/mail/cone/Makefile
@@ -21,7 +21,8 @@ LIB_DEPENDS= libaspell.so:textproc/aspell \
BUILD_DEPENDS= gpgv:security/gnupg1
RUN_DEPENDS= gpgv:security/gnupg1
-USES= fam gettext gmake iconv localbase:ldflags ncurses perl5 shebangfix ssl tar:bzip2
+USES= compiler:c++11-lang fam gettext gmake iconv localbase:ldflags \
+ ncurses perl5 shebangfix ssl tar:bzip2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-certdb=${PREFIX}/share/cone/rootcerts --exec-prefix=${PREFIX}
SHEBANG_FILES= sysconftool
diff --git a/math/ambit/Makefile b/math/ambit/Makefile
index 7e492e2e5ed3..061d3719e2c8 100644
--- a/math/ambit/Makefile
+++ b/math/ambit/Makefile
@@ -17,7 +17,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libhdf5.so:science/hdf5 \
libsz.so:science/szip
-USES= cmake:outsource
+USES= cmake:outsource compiler:c++11-lang
+USE_GCC= yes
USE_GITHUB= yes
GH_ACCOUNT= jturney
diff --git a/math/clblast/Makefile b/math/clblast/Makefile
index f4e49bd9914b..4772f70d3cf1 100644
--- a/math/clblast/Makefile
+++ b/math/clblast/Makefile
@@ -19,7 +19,8 @@ USE_GITHUB= yes
GH_ACCOUNT= CNugteren
GH_PROJECT= CLBlast
-USE_LDCONFIG= yes
USES= cmake
+USE_GCC= yes
+USE_LDCONFIG= yes
.include <bsd.port.mk>
diff --git a/math/glm/Makefile b/math/glm/Makefile
index 2ce69ac04385..c782e9cea49e 100644
--- a/math/glm/Makefile
+++ b/math/glm/Makefile
@@ -12,13 +12,12 @@ COMMENT= C++ mathematics library for software based on the OpenGL GLSL
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/copying.txt
+USES= cmake:outsource compiler:c++11-lang pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= g-truc
NO_ARCH= yes
-USES= cmake:outsource pkgconfig
-
OPTIONS_DEFINE= TEST
TEST_CMAKE_BOOL= GLM_TEST_ENABLE
TEST_TEST_TARGET= test
diff --git a/net-im/ekiga/Makefile b/net-im/ekiga/Makefile
index 965d6ad93ee0..792eb14c662c 100644
--- a/net-im/ekiga/Makefile
+++ b/net-im/ekiga/Makefile
@@ -23,8 +23,8 @@ LIB_DEPENDS= libboost_signals.so:devel/boost-libs \
RUN_DEPENDS= gnome-icon-theme>=3.0.0:misc/gnome-icon-theme
GNU_CONFIGURE= yes
-USES= cpe gettext gmake kde:4 libtool localbase pathfix \
- perl5 pkgconfig tar:xz
+USES= compiler:c++11-lang cpe gettext gmake kde:4 libtool localbase \
+ pathfix perl5 pkgconfig tar:xz
USE_XORG= xv
USE_GNOME= gtk20 intlhack libxml2
INSTALLS_ICONS= yes
diff --git a/net-mgmt/icinga2/Makefile b/net-mgmt/icinga2/Makefile
index dd5090b90726..98c81810d3da 100644
--- a/net-mgmt/icinga2/Makefile
+++ b/net-mgmt/icinga2/Makefile
@@ -11,14 +11,11 @@ COMMENT= Monitoring and management system for hosts, services and networks
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_powerpc64= does not build: Your version of GCC (4.2.1) is too old for building Icinga 2 (GCC >= 4.6.0)
-
LIB_DEPENDS= libboost_system.so:devel/boost-libs \
libyajl.so:devel/yajl
RUN_DEPENDS= ${LOCALBASE}/bin/bash:shells/bash
-USES= alias bison cmake libedit ssl
-
+USES= alias bison cmake compiler:c++0x libedit ssl
USE_GITHUB= yes
GH_ACCOUNT= icinga
diff --git a/net-mgmt/metronome/Makefile b/net-mgmt/metronome/Makefile
index 2cffad26ad07..894ae632938c 100644
--- a/net-mgmt/metronome/Makefile
+++ b/net-mgmt/metronome/Makefile
@@ -13,7 +13,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libboost_thread.so:devel/boost-libs
-USES= autoreconf:build eigen:3 libtool:build pathfix pkgconfig
+USES= autoreconf:build compiler:c++11-lang eigen:3 libtool:build pathfix pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= ahupowerdns
diff --git a/net/libcmis/Makefile b/net/libcmis/Makefile
index 2978ad585c3d..5e08ff74ed4f 100644
--- a/net/libcmis/Makefile
+++ b/net/libcmis/Makefile
@@ -12,15 +12,15 @@ COMMENT= Client library for the CMIS interface
LICENSE= LGPL20 MPL11 GPLv2
LICENSE_COMB= dual
+BROKEN_sparc64= cannot link with boost
+
LIB_DEPENDS= libcurl.so:ftp/curl
BUILD_DEPENDS= cppunit-config:devel/cppunit \
${LOCALBASE}/lib/libboost_regex.a:devel/boost-libs
-BROKEN_sparc64= cannot link with boost
-
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-USES= gmake libtool pathfix pkgconfig
+USES= compiler:c++11-lib gmake libtool pathfix pkgconfig
USE_GNOME= libxml2
USE_LDCONFIG= yes
diff --git a/print/qpdf/Makefile b/print/qpdf/Makefile
index 97627e43254e..98801783a538 100644
--- a/print/qpdf/Makefile
+++ b/print/qpdf/Makefile
@@ -3,6 +3,7 @@
PORTNAME= qpdf
DISTVERSION= 8.0.1
+PORTREVISION= 1
CATEGORIES= print
MASTER_SITES= SF
@@ -14,7 +15,7 @@ LICENSE_COMB= dual
LICENSE_FILE_ART20= ${WRKSRC}/Artistic-2.0
LICENSE_FILE_APACHE20= ${WRKSRC}/LICENSE.txt
-USES= gmake jpeg libtool localbase
+USES= compiler:c++11-lang gmake jpeg libtool localbase
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-static
USE_LDCONFIG= yes
diff --git a/sysutils/cdrdao/Makefile b/sysutils/cdrdao/Makefile
index 0ee2053f5e36..34b3cf38d694 100644
--- a/sysutils/cdrdao/Makefile
+++ b/sysutils/cdrdao/Makefile
@@ -13,13 +13,9 @@ COMMENT?= Record CD-R[W]s in disk-at-once mode
LICENSE= GPLv2
-BROKEN_mips= fails to compile: cc1plus: error: unrecognized command line option "-std=c++11"
-BROKEN_mips64= fails to compile: cc1plus: error: unrecognized command line option "-std=c++11"
-BROKEN_powerpc64= fails to compile: cc1plus: error: unrecognized command line option "-std=c++11"
-
+USES= alias compiler:c++11-lang gmake tar:bzip2
GNU_CONFIGURE= yes
USE_CXXSTD= c++11
-USES= alias gmake tar:bzip2
MP3OGG_LIB_DEPENDS= libao.so:audio/libao \
libmad.so:audio/libmad \
diff --git a/sysutils/fsearch/Makefile b/sysutils/fsearch/Makefile
index 94d4bcc046f3..7fe8b5914442 100644
--- a/sysutils/fsearch/Makefile
+++ b/sysutils/fsearch/Makefile
@@ -14,12 +14,10 @@ LICENSE_FILE= ${WRKSRC}/License
BUILD_DEPENDS= ${LOCALBASE}/share/aclocal/ax_check_compile_flag.m4:devel/autoconf-archive
LIB_DEPENDS= libpcre.so:devel/pcre
-BROKEN_powerpc64= fails to configure: checking whether C compiler accepts -std=c11... no
-
USE_GITHUB= yes
GH_ACCOUNT= cboxdoerfer
-USES= autoreconf gettext gmake pkgconfig
+USES= autoreconf compiler:c++11-lang gettext gmake pkgconfig
GNU_CONFIGURE= yes
USE_GNOME= cairo gdkpixbuf2 gtk30 intltool
diff --git a/sysutils/gigolo/Makefile b/sysutils/gigolo/Makefile
index 54902eaa334d..2d905fccd78e 100644
--- a/sysutils/gigolo/Makefile
+++ b/sysutils/gigolo/Makefile
@@ -12,6 +12,9 @@ COMMENT= Frontend to easily manage filesystem connections
LICENSE= GPLv2
+ONLY_FOR_ARCHS= amd64 i386 powerpc64
+ONLY_FOR_ARCHS_REASON= Does not compile
+
BUILD_DEPENDS= p5-XML-Parser>=0:textproc/p5-XML-Parser
USES= gmake fuse pkgconfig gettext-tools xfce tar:bzip2
@@ -27,9 +30,6 @@ OPTIONS_SUB= yes
NLS_CONFIGURE_ENABLE= nls
NLS_USES= gettext-runtime
-ONLY_FOR_ARCHS= i386 amd64
-ONLY_FOR_ARCHS_REASON= Does not compile
-
post-patch:
@${REINPLACE_CMD} -e 's|^DOCFILES.*|DOCFILES =|' \
${WRKSRC}/Makefile.in
diff --git a/sysutils/polkit/Makefile b/sysutils/polkit/Makefile
index 8e041dd7adcc..5103e5bd6085 100644
--- a/sysutils/polkit/Makefile
+++ b/sysutils/polkit/Makefile
@@ -19,8 +19,9 @@ RUN_DEPENDS= dbus-launch:devel/dbus
USERS= polkitd
GROUPS= polkitd
+USES= compiler:c++11-lib gettext gmake libtool localbase pathfix \
+ pkgconfig shebangfix
USE_GNOME= glib20 intlhack introspection:build
-USES= gettext gmake libtool localbase pathfix pkgconfig shebangfix
SHEBANG_FILES= ${WRKSRC}/src/polkitbackend/toarray.pl
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/sysutils/smartmontools/Makefile b/sysutils/smartmontools/Makefile
index 8d1e8ded4514..307993917e89 100644
--- a/sysutils/smartmontools/Makefile
+++ b/sysutils/smartmontools/Makefile
@@ -17,7 +17,7 @@ CONFLICTS= smartmontools-devel-[0-9]*
OPTIONS_DEFINE= DOCS
-USES= alias gmake shebangfix
+USES= alias compiler:c++11-lib gmake shebangfix
SHEBANG_FILES= examplescripts/Example5
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-dependency-tracking \
diff --git a/sysutils/tracker/Makefile b/sysutils/tracker/Makefile
index fa0d942b82f0..996be96ebf81 100644
--- a/sysutils/tracker/Makefile
+++ b/sysutils/tracker/Makefile
@@ -25,8 +25,9 @@ RUN_DEPENDS= xdg-desktop-icon:devel/xdg-utils \
PORTSCOUT= limitw:1,even
-USES= desktop-file-utils gettext gmake gnome libarchive libtool \
- pathfix pkgconfig python:run shebangfix sqlite tar:xz
+USES= compiler:c++11-lib desktop-file-utils gettext gmake gnome \
+ libarchive libtool pathfix pkgconfig python:run shebangfix \
+ sqlite tar:xz
USE_GNOME= gtk30 intltool introspection:build libxslt:build
USE_LDCONFIG= yes
USE_GSTREAMER1= yes
diff --git a/textproc/kiss-templates/Makefile b/textproc/kiss-templates/Makefile
index 5a12bd9c2049..60c7c966579a 100644
--- a/textproc/kiss-templates/Makefile
+++ b/textproc/kiss-templates/Makefile
@@ -12,8 +12,7 @@ COMMENT= Type safe "Keep it simple, stupid" text templates for C++
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN_powerpc64= fails to compile: No known features for CXX compiler GNU
-
+USES= cmake compiler:c++11-lang
USE_GITHUB= yes
GH_ACCOUNT= rbock
@@ -26,8 +25,6 @@ PLIST_FILES= bin/kiste2cpp \
include/kiste/serializer_builder.h \
include/kiste/terminal.h
-USES= cmake
-
OPTIONS_DEFINE= TEST
TEST_DESC= Build with unit tests
TEST_BUILD_DEPENDS= boost-libs>=1.55:devel/boost-libs
diff --git a/textproc/libwpd010/Makefile b/textproc/libwpd010/Makefile
index 9c8aa662822f..66d113ac42e9 100644
--- a/textproc/libwpd010/Makefile
+++ b/textproc/libwpd010/Makefile
@@ -19,7 +19,7 @@ LICENSE_FILE_MPL20= ${WRKSRC}/COPYING.MPL
BUILD_DEPENDS= ${LOCALBASE}/include/boost/spirit/include/qi.hpp:devel/boost-libs
LIB_DEPENDS= librevenge-0.0.so:textproc/librevenge
-USES= libtool pathfix pkgconfig tar:bzip2
+USES= compiler:c++11-lang libtool pathfix pkgconfig tar:bzip2
GNU_CONFIGURE= yes
USE_GNOME= libgsf
USE_LDCONFIG= yes
diff --git a/textproc/mythes/Makefile b/textproc/mythes/Makefile
index 23dbc153b0fa..77c7089966ec 100644
--- a/textproc/mythes/Makefile
+++ b/textproc/mythes/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libhunspell-1.6.so:textproc/hunspell
-USES= libtool pathfix perl5 pkgconfig shebangfix
+USES= compiler:c++11-lib libtool pathfix perl5 pkgconfig shebangfix
USE_LDCONFIG= yes
USE_PERL5= run
SHEBANG_FILES= th_gen_idx.pl
diff --git a/textproc/rubygem-liquid-tag-parser/Makefile b/textproc/rubygem-liquid-tag-parser/Makefile
index 4d6e2d31ca87..e5677fab77d9 100644
--- a/textproc/rubygem-liquid-tag-parser/Makefile
+++ b/textproc/rubygem-liquid-tag-parser/Makefile
@@ -15,8 +15,8 @@ RUN_DEPENDS= rubygem-extras>=0.3:devel/rubygem-extras \
rubygem-liquid>=3.0:textproc/rubygem-liquid
NO_ARCH= yes
+USES= compiler:c++11-lang gem
USE_RUBY= yes
-USES= gem
# Disable rdoc
OPTIONS_EXCLUDE=DOCS
diff --git a/x11-fm/nautilus/Makefile b/x11-fm/nautilus/Makefile
index 64818ad58352..0ce796ceb691 100644
--- a/x11-fm/nautilus/Makefile
+++ b/x11-fm/nautilus/Makefile
@@ -18,8 +18,8 @@ RUN_DEPENDS= gsettings-desktop-schemas>=0:devel/gsettings-desktop-schemas
PORTSCOUT= limitw:1,even
-USES= desktop-file-utils gettext gmake gnome libtool pathfix \
- pkgconfig tar:xz
+USES= compiler:c11 desktop-file-utils gettext gmake gnome \
+ libtool pathfix pkgconfig tar:xz
USE_GNOME= intlhack gnomedesktop3 libxml2 gvfs introspection:build
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/x11-toolkits/gtkmm30-reference/Makefile b/x11-toolkits/gtkmm30-reference/Makefile
index 518684efb0f5..3d1bcc210e71 100644
--- a/x11-toolkits/gtkmm30-reference/Makefile
+++ b/x11-toolkits/gtkmm30-reference/Makefile
@@ -6,7 +6,7 @@ PORTREVISION= 0
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/gtkmm-3.0.pc:x11-toolkits/gtkmm30 \
glibmm-reference>=0:devel/glibmm-reference
-USES= gmake pkgconfig
+USES= compiler:c++11-lang gmake pkgconfig
GNU_CONFIGURE= yes
DOCSDIR= ${PREFIX}/share/doc/gtkmm-3.0
diff --git a/x11/babl/Makefile b/x11/babl/Makefile
index 6c56a2454b3d..7e22d65c12d4 100644
--- a/x11/babl/Makefile
+++ b/x11/babl/Makefile
@@ -12,7 +12,7 @@ COMMENT= Dynamic pixel format conversion library
LICENSE= LGPL3
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= gmake libtool pathfix pkgconfig tar:bzip2
+USES= compiler:c11 gmake libtool pathfix pkgconfig tar:bzip2
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
diff --git a/x11/yelp/Makefile b/x11/yelp/Makefile
index 80aa6a117b26..2c7e7ffe43e2 100644
--- a/x11/yelp/Makefile
+++ b/x11/yelp/Makefile
@@ -24,8 +24,8 @@ RUN_DEPENDS= yelp-xsl>=0:textproc/yelp-xsl
PORTSCOUT= limitw:1,even
-USES= desktop-file-utils gettext gmake gnome libtool pathfix \
- pkgconfig sqlite tar:xz
+USES= compiler:c11 desktop-file-utils gettext gmake gnome \
+ libtool pathfix pkgconfig sqlite tar:xz
USE_XORG= x11 ice
USE_GNOME= cairo gtk30 intlhack libxml2 libxslt
GNU_CONFIGURE= yes