aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2018-05-02 21:36:21 +0800
committerrm <rm@FreeBSD.org>2018-05-02 21:36:21 +0800
commit3af8570256171a6a464a94eee0793ff32b1ed708 (patch)
tree2833ae287e73b9c1a9cf585c1517b6be1fafb77a
parent9b921430aada737023e16b4beeeef11e13bd131c (diff)
downloadfreebsd-ports-gnome-3af8570256171a6a464a94eee0793ff32b1ed708.tar.gz
freebsd-ports-gnome-3af8570256171a6a464a94eee0793ff32b1ed708.tar.zst
freebsd-ports-gnome-3af8570256171a6a464a94eee0793ff32b1ed708.zip
net/py-ldap: update to 3.0.0
-rw-r--r--net/py-ldap/Makefile8
-rw-r--r--net/py-ldap/distinfo6
-rw-r--r--net/py-ldap/files/patch-setup.py11
3 files changed, 18 insertions, 7 deletions
diff --git a/net/py-ldap/Makefile b/net/py-ldap/Makefile
index 2916a6b0659a..e9cedd2498d7 100644
--- a/net/py-ldap/Makefile
+++ b/net/py-ldap/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= ldap
-PORTVERSION= 2.5.2
+PORTVERSION= 3.0.0
CATEGORIES= net python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -17,7 +17,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyasn1>0:devel/py-pyasn1@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pyasn1-modules>0:devel/py-pyasn1-modules@${FLAVOR}
CONFLICTS_INSTALL= py27-pyldap
-USES= python:-2.7
+USES= python
USE_PYTHON= autoplist distutils
USE_OPENLDAP= yes
WANT_OPENLDAP_VER= 24
@@ -27,8 +27,8 @@ OPTIONS_DEFINE= SASL
SASL_VARS= WANT_OPENLDAP_SASL=yes
SASL_CONFLICTS= openldap24-client-2.*
-do-configure:
- @${REINPLACE_CMD} -e 's,/usr/local,${LOCALBASE},' ${WRKSRC}/setup.cfg
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/setup.py
do-configure-SASL-off:
@cd ${WRKSRC} && ${PYTHON_CMD} setup.py -q setopt -c _ldap -s HAVE_TLS -o defines
diff --git a/net/py-ldap/distinfo b/net/py-ldap/distinfo
index 0ebbdedfbfba..df7a99995782 100644
--- a/net/py-ldap/distinfo
+++ b/net/py-ldap/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1516650844
-SHA256 (python-ldap-2.5.2.tar.gz) = b8c134dfedaef0e6ff4a4b94277708dcadb758b448905a83b8946df077356ed2
-SIZE (python-ldap-2.5.2.tar.gz) = 297976
+TIMESTAMP = 1521151033
+SHA256 (python-ldap-3.0.0.tar.gz) = 86746b912a2cd37a54b06c694f021b0c8556d4caeab75ef50435ada152e2fbe1
+SIZE (python-ldap-3.0.0.tar.gz) = 364733
diff --git a/net/py-ldap/files/patch-setup.py b/net/py-ldap/files/patch-setup.py
new file mode 100644
index 000000000000..5c5f82de9fe3
--- /dev/null
+++ b/net/py-ldap/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig 2018-02-14 10:21:57 UTC
++++ setup.py
+@@ -23,7 +23,7 @@ import pkginfo
+ #-- A class describing the features and requirements of OpenLDAP 2.0
+ class OpenLDAP2:
+ library_dirs = []
+- include_dirs = []
++ include_dirs = ['%%LOCALBASE%%/include']
+ extra_compile_args = []
+ extra_link_args = []
+ extra_objects = []