aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2017-06-22 02:07:19 +0800
committertcberner <tcberner@FreeBSD.org>2017-06-22 02:07:19 +0800
commit40977b902969ac1b1c88b2c93532d9c65828b795 (patch)
treec9a86b3af6f6a86761a1f2a37061dc739f689680
parent52cbe83f54e2534b355e6430def4d1fd3016848a (diff)
downloadfreebsd-ports-gnome-40977b902969ac1b1c88b2c93532d9c65828b795.tar.gz
freebsd-ports-gnome-40977b902969ac1b1c88b2c93532d9c65828b795.tar.zst
freebsd-ports-gnome-40977b902969ac1b1c88b2c93532d9c65828b795.zip
Add two new ports: sysutils/qt5-qtdiag and sysutils/qt5-qtplugininfo
* qtdiag outputs diagnostics on the current Qt installation and can be helpful to find issues. * qtpluginfo is useful while writing plugins for Qt5/KDE Plasma Reviewed by: rakuco, mat Differential Revision: https://reviews.freebsd.org/D11280
-rw-r--r--Mk/bsd.qt.mk10
-rw-r--r--sysutils/Makefile2
-rw-r--r--sysutils/qt5-qtdiag/Makefile26
-rw-r--r--sysutils/qt5-qtplugininfo/Makefile26
4 files changed, 62 insertions, 2 deletions
diff --git a/Mk/bsd.qt.mk b/Mk/bsd.qt.mk
index ff72f63db4c6..7c9a6d099fcc 100644
--- a/Mk/bsd.qt.mk
+++ b/Mk/bsd.qt.mk
@@ -316,8 +316,8 @@ _USE_QT4_ONLY= accessible assistant-adp assistantclient clucene codecs-cn codecs
qtestlib qvfb rcc uic uic3 xmlpatterns-tool
_USE_QT5_ONLY= 3d buildtools canvas3d charts concurrent connectivity \
- core datavis3d declarative-render2d examples gamepad \
- graphicaleffects location paths phonon4 printsupport \
+ core datavis3d declarative-render2d diag examples gamepad \
+ graphicaleffects location paths phonon4 plugininfo printsupport \
qdbus qdoc qdoc-data qev qml quick quickcontrols \
quickcontrols2 scxml sensors serialbus serialport \
sql-tds uiplugin uitools virtualkeyboard webchannel \
@@ -392,6 +392,9 @@ demo_PATH= ${QT_BINDIR}/qtdemo
designer_PORT= devel/${_QT_RELNAME}-designer
designer_PATH= ${QT_BINDIR}/designer
+diag_PORT= sysutils/${_QT_RELNAME}-qtdiag
+diag_PATH= ${QT_BINDIR}/qtdiag
+
doc_PORT= misc/${_QT_RELNAME}-doc
doc_PATH= ${_QT_RELNAME}-doc>=${_QT_VERSION:R:R}
@@ -467,6 +470,9 @@ phonon4_LIB= libphonon4${_QT_RELNAME}.so
phonon-gst_PORT= multimedia/phonon-gstreamer
phonon-gst_PATH= ${QT_PLUGINDIR}/phonon_backend/libphonon_gstreamer.so
+plugininfo_PORT= sysutils/${_QT_RELNAME}-qtplugininfo
+plugininfo_PATH= ${QT_BINDIR}/qtplugininfo
+
porting_PORT= devel/${_QT_RELNAME}-porting
porting_PATH= ${QT_BINDIR}/qt3to4
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 10d0f480cdae..acd693713045 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -914,7 +914,9 @@
SUBDIR += qlogtools
SUBDIR += qpxtool
SUBDIR += qsynergy
+ SUBDIR += qt5-qtdiag
SUBDIR += qt5-qtpaths
+ SUBDIR += qt5-qtplugininfo
SUBDIR += qtpass
SUBDIR += quicksynergy
SUBDIR += qzeitgeist
diff --git a/sysutils/qt5-qtdiag/Makefile b/sysutils/qt5-qtdiag/Makefile
new file mode 100644
index 000000000000..a43ed488648c
--- /dev/null
+++ b/sysutils/qt5-qtdiag/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= qtdiag
+DISTVERSION= ${QT5_VERSION}
+CATEGORIES= sysutils
+PKGNAMEPREFIX= qt5-
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Tool for reporting diagnostic information about Qt and its environment
+
+USES= qmake:outsource
+USE_QT5= core gui
+QT_DIST= tools
+
+PLIST_FILES= ${QT_BINDIR}/qtdiag
+
+# Similarly to x11/qt5-qev, it makes more sense to just run the build system
+# from the qtdiag directory. If we run it from the top of the source tree, it
+# will look for a lot more dependencies for other tools such as lupdate, which
+# we do not really have to depend on.
+WRKSRC_SUBDIR= src/${PORTNAME}
+
+post-patch:
+ ${CP} ${WRKSRC}/../../.qmake.conf ${WRKSRC}
+
+.include <bsd.port.mk>
diff --git a/sysutils/qt5-qtplugininfo/Makefile b/sysutils/qt5-qtplugininfo/Makefile
new file mode 100644
index 000000000000..fc0dece6c193
--- /dev/null
+++ b/sysutils/qt5-qtplugininfo/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= qtplugininfo
+DISTVERSION= ${QT5_VERSION}
+CATEGORIES= sysutils
+PKGNAMEPREFIX= qt5-
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Qt5 plugin metadata dumper
+
+USES= qmake:outsource
+USE_QT5= core
+QT_DIST= tools
+
+PLIST_FILES= ${QT_BINDIR}/qtplugininfo
+
+# Similarly to x11/qt5-qev, it makes more sense to just run the build system
+# from the qtplugininfo directory. If we run it from the top of the source tree, it
+# will look for a lot more dependencies for other tools such as lupdate, which
+# we do not really have to depend on.
+WRKSRC_SUBDIR= src/${PORTNAME}
+
+post-patch:
+ ${CP} ${WRKSRC}/../../.qmake.conf ${WRKSRC}
+
+.include <bsd.port.mk>