aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-03-08 10:33:17 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-03-08 10:33:17 +0800
commit48b5543ddd3dd29023d25de0eb903e6bb8a7d61c (patch)
tree8557a0f3c42d2fd04695ea51b2a1c450c74d8687
parent3696485c8d57fc3ddd25e0601d867ebb4c133ca2 (diff)
downloadfreebsd-ports-gnome-48b5543ddd3dd29023d25de0eb903e6bb8a7d61c.tar.gz
freebsd-ports-gnome-48b5543ddd3dd29023d25de0eb903e6bb8a7d61c.tar.zst
freebsd-ports-gnome-48b5543ddd3dd29023d25de0eb903e6bb8a7d61c.zip
- Clarify LICENSE
- Add LICENSE_FILE - Strip binary
-rw-r--r--audio/cddb-bundle/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/audio/cddb-bundle/Makefile b/audio/cddb-bundle/Makefile
index 402d2f6658c0..2722d217a971 100644
--- a/audio/cddb-bundle/Makefile
+++ b/audio/cddb-bundle/Makefile
@@ -11,7 +11,8 @@ DISTNAME= cdplayer-${CDPLAYER_VERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= CDDB client bundle GNUstep
-LICENSE= GPLv2
+LICENSE= GPLv2 # or later
+LICENSE_FILE= ${WRKSRC}/COPYING
USES= tar:bzip2
USE_GNUSTEP= yes
@@ -23,4 +24,7 @@ CDPLAYER_VERSION= 0.5.1
WRKSRC= ${WRKDIR}/CDPlayer-${CDPLAYER_VERSION}/Cddb
MAKE_ENV+= GNUSTEP_INSTALLATION_DIR=${GNUSTEP_LOCAL_ROOT}
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/GNUstep/Local/Library/Bundles/Cddb.bundle/Cddb
+
.include <bsd.port.mk>