aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormartymac <martymac@FreeBSD.org>2018-04-23 19:26:24 +0800
committermartymac <martymac@FreeBSD.org>2018-04-23 19:26:24 +0800
commit4a3ed03104938a5e728fb97e966fe4899a7c3b11 (patch)
treec9b71b17fa70d464159004c63b02b765213bf396
parent074310ec7493da640ba44c22292b8c1d37160a05 (diff)
downloadfreebsd-ports-gnome-4a3ed03104938a5e728fb97e966fe4899a7c3b11.tar.gz
freebsd-ports-gnome-4a3ed03104938a5e728fb97e966fe4899a7c3b11.tar.zst
freebsd-ports-gnome-4a3ed03104938a5e728fb97e966fe4899a7c3b11.zip
Update Simgear & Flightgear ports to 2018.1.1
-rw-r--r--devel/simgear/Makefile12
-rw-r--r--devel/simgear/distinfo6
-rw-r--r--devel/simgear/pkg-plist16
-rw-r--r--games/flightgear-data/Makefile2
-rw-r--r--games/flightgear-data/distinfo6
-rw-r--r--games/flightgear/Makefile14
-rw-r--r--games/flightgear/distinfo6
7 files changed, 38 insertions, 24 deletions
diff --git a/devel/simgear/Makefile b/devel/simgear/Makefile
index 8956fbfdb20c..36c4d19ea171 100644
--- a/devel/simgear/Makefile
+++ b/devel/simgear/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= simgear
-PORTVERSION= 2017.3.1
-PORTREVISION= 3
+PORTVERSION= 2018.1.1
CATEGORIES= devel games
MASTER_SITES= SF/flightgear/release-${PORTVERSION:R}
@@ -22,6 +21,15 @@ USE_GL= gl glu glut
.include <bsd.port.pre.mk>
+# Needs Clang 4.0+ to build, see:
+# https://sourceforge.net/p/flightgear/codetickets/2015/
+.if ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} < 40
+BUILD_DEPENDS+= ${LOCALBASE}/bin/clang40:devel/llvm40
+CPP= ${LOCALBASE}/bin/clang-cpp40
+CC= ${LOCALBASE}/bin/clang40
+CXX= ${LOCALBASE}/bin/clang++40
+.endif
+
# Work around "'to_string' is not a member of 'std'" when building with Gcc < 6
.if ${COMPILER_TYPE} == gcc && ${COMPILER_VERSION} < 60
CFLAGS+= -D_GLIBCXX_USE_C99
diff --git a/devel/simgear/distinfo b/devel/simgear/distinfo
index cf42a245112b..66f18611bff7 100644
--- a/devel/simgear/distinfo
+++ b/devel/simgear/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1506362997
-SHA256 (simgear-2017.3.1.tar.bz2) = 0ee08550b737b249dcc91590ec0cb9c5dc9080998f6ba66a7d7209cdfce6e1f4
-SIZE (simgear-2017.3.1.tar.bz2) = 1302704
+TIMESTAMP = 1523304226
+SHA256 (simgear-2018.1.1.tar.bz2) = d403cbd8688782780c50461ea233f26ea3bb8242ff681674e69ac1da05226656
+SIZE (simgear-2018.1.1.tar.bz2) = 1303653
diff --git a/devel/simgear/pkg-plist b/devel/simgear/pkg-plist
index 1056ce64df41..1868c8481664 100644
--- a/devel/simgear/pkg-plist
+++ b/devel/simgear/pkg-plist
@@ -1,7 +1,3 @@
-include/simgear/3rdparty/utf8/utf8.h
-include/simgear/3rdparty/utf8/utf8/checked.h
-include/simgear/3rdparty/utf8/utf8/core.h
-include/simgear/3rdparty/utf8/utf8/unchecked.h
include/simgear/bucket/newbucket.hxx
include/simgear/bvh/BVHBoundingBoxVisitor.hxx
include/simgear/bvh/BVHGroup.hxx
@@ -45,7 +41,6 @@ include/simgear/canvas/elements/CanvasImage.hxx
include/simgear/canvas/elements/CanvasMap.hxx
include/simgear/canvas/elements/CanvasPath.hxx
include/simgear/canvas/elements/CanvasText.hxx
-include/simgear/canvas/elements/detail/add_segment_variadic.hxx
include/simgear/canvas/events/CustomEvent.hxx
include/simgear/canvas/events/DeviceEvent.hxx
include/simgear/canvas/events/KeyboardEvent.hxx
@@ -63,6 +58,7 @@ include/simgear/debug/debug_types.h
include/simgear/debug/logstream.hxx
include/simgear/embedded_resources/EmbeddedResource.hxx
include/simgear/embedded_resources/EmbeddedResourceManager.hxx
+include/simgear/embedded_resources/EmbeddedResourceProxy.hxx
include/simgear/environment/metar.hxx
include/simgear/environment/precipitation.hxx
include/simgear/ephemeris/celestialBody.hxx
@@ -156,15 +152,15 @@ include/simgear/nasal/cppbind/Ghost.hxx
include/simgear/nasal/cppbind/NasalCallContext.hxx
include/simgear/nasal/cppbind/NasalContext.hxx
include/simgear/nasal/cppbind/NasalHash.hxx
+include/simgear/nasal/cppbind/NasalMe.hxx
+include/simgear/nasal/cppbind/NasalMethodHolder.hxx
include/simgear/nasal/cppbind/NasalObject.hxx
include/simgear/nasal/cppbind/NasalObjectHolder.hxx
include/simgear/nasal/cppbind/NasalString.hxx
-include/simgear/nasal/cppbind/detail/NasalObject_callMethod_templates.hxx
-include/simgear/nasal/cppbind/detail/from_nasal_function_templates.hxx
include/simgear/nasal/cppbind/detail/from_nasal_helper.hxx
-include/simgear/nasal/cppbind/detail/functor_templates.hxx
include/simgear/nasal/cppbind/detail/nasal_traits.hxx
include/simgear/nasal/cppbind/detail/to_nasal_helper.hxx
+include/simgear/nasal/cppbind/cppbind_fwd.hxx
include/simgear/nasal/cppbind/from_nasal.hxx
include/simgear/nasal/cppbind/to_nasal.hxx
include/simgear/nasal/iolib.h
@@ -294,11 +290,14 @@ include/simgear/screen/tr.h
include/simgear/serial/serial.hxx
include/simgear/sg_inlines.h
include/simgear/simgear_config.h
+include/simgear/sound/filters.hxx
include/simgear/sound/readwav.hxx
include/simgear/sound/sample.hxx
include/simgear/sound/sample_group.hxx
include/simgear/sound/soundmgr.hxx
include/simgear/sound/xmlsound.hxx
+include/simgear/std/integer_sequence.hxx
+include/simgear/std/type_traits.hxx
include/simgear/structure/OSGUtils.hxx
include/simgear/structure/OSGVersion.hxx
include/simgear/structure/SGAtomic.hxx
@@ -316,7 +315,6 @@ include/simgear/structure/StateMachine.hxx
include/simgear/structure/StringTable.hxx
include/simgear/structure/callback.hxx
include/simgear/structure/commands.hxx
-include/simgear/structure/detail/function_list_template.hxx
include/simgear/structure/event_mgr.hxx
include/simgear/structure/exception.hxx
include/simgear/structure/function_list.hxx
diff --git a/games/flightgear-data/Makefile b/games/flightgear-data/Makefile
index 62314c729d68..379964067497 100644
--- a/games/flightgear-data/Makefile
+++ b/games/flightgear-data/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= flightgear-data
-PORTVERSION= 2017.3.1
+PORTVERSION= 2018.1.1
CATEGORIES= games
MASTER_SITES= SF/flightgear/release-${PORTVERSION:R}
DISTNAME= FlightGear-${PORTVERSION}-data
diff --git a/games/flightgear-data/distinfo b/games/flightgear-data/distinfo
index ad0ecef06073..6de046ba27f5 100644
--- a/games/flightgear-data/distinfo
+++ b/games/flightgear-data/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1506363053
-SHA256 (FlightGear-2017.3.1-data.tar.bz2) = df08b06e88a29a9f80f29186afd54d278636a663281a1b68e8f484bbb403d898
-SIZE (FlightGear-2017.3.1-data.tar.bz2) = 1560855079
+TIMESTAMP = 1523304831
+SHA256 (FlightGear-2018.1.1-data.tar.bz2) = dfd80e09f6bf04bd25604788c080716007969d127d46d0e10c43c2f709fb8db8
+SIZE (FlightGear-2018.1.1-data.tar.bz2) = 1576049981
diff --git a/games/flightgear/Makefile b/games/flightgear/Makefile
index 775c6815739a..2bd0e92fd2f1 100644
--- a/games/flightgear/Makefile
+++ b/games/flightgear/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= flightgear
-PORTVERSION= 2017.3.1
-PORTREVISION= 4
+PORTVERSION= 2018.1.1
CATEGORIES= games
MASTER_SITES= SF/flightgear/release-${PORTVERSION:R}
@@ -49,10 +48,19 @@ DBUS_CMAKE_ON= -DUSE_DBUS:BOOL=ON
DBUS_CMAKE_OFF= -DUSE_DBUS:BOOL=OFF
QT5_CMAKE_ON= -DENABLE_QT:BOOL=ON
QT5_CMAKE_OFF= -DENABLE_QT:BOOL=OFF
-QT5_USE= QT5=core,buildtools,gui,qmake,qml,widgets
+QT5_USE= QT5=core,buildtools,gui,qmake,qml,quick,widgets
.include <bsd.port.pre.mk>
+# Needs Clang 4.0+ to build, see:
+# https://sourceforge.net/p/flightgear/codetickets/2015/
+.if ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} < 40
+BUILD_DEPENDS+= ${LOCALBASE}/bin/clang40:devel/llvm40
+CPP= ${LOCALBASE}/bin/clang-cpp40
+CC= ${LOCALBASE}/bin/clang40
+CXX= ${LOCALBASE}/bin/clang++40
+.endif
+
# Chase devel/simgear compiler version
.if ${COMPILER_TYPE} == gcc && ${COMPILER_VERSION} < 46
USE_GCC= yes
diff --git a/games/flightgear/distinfo b/games/flightgear/distinfo
index 156adfa817d2..e1bce5b9e8c5 100644
--- a/games/flightgear/distinfo
+++ b/games/flightgear/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1506363097
-SHA256 (flightgear-2017.3.1.tar.bz2) = 6f2e1d992e2f202b8f9c918c9fb19124ef06824ea0e767e2f4dff6ba43728ccd
-SIZE (flightgear-2017.3.1.tar.bz2) = 8098283
+TIMESTAMP = 1523305013
+SHA256 (flightgear-2018.1.1.tar.bz2) = ed1aa7867e89757622f3faaab996028c4be2f79006dfb89a3059c77b9831aab9
+SIZE (flightgear-2018.1.1.tar.bz2) = 8158999