aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2019-05-01 03:13:59 +0800
committerPiotr Kubaj <pkubaj@FreeBSD.org>2019-05-01 03:13:59 +0800
commit4b3cdd38b6598d9a66f29a7cc5069b2ae485afad (patch)
treee6cff0676e06cdfb7259c61a6ea3aa28894d371d
parent3dc217b8c88267b32dea2eeecc4c38261ea89108 (diff)
downloadfreebsd-ports-gnome-4b3cdd38b6598d9a66f29a7cc5069b2ae485afad.tar.gz
freebsd-ports-gnome-4b3cdd38b6598d9a66f29a7cc5069b2ae485afad.tar.zst
freebsd-ports-gnome-4b3cdd38b6598d9a66f29a7cc5069b2ae485afad.zip
graphics/delaboratory: fix build with GCC-based architectures
Respect LDFLAGS to fix build on GCC architectures: //usr/local/lib/libwebkitgtk-1.0.so.0: undefined reference to `vtable for std::__cxx11::basic_ostringstream<char, std::char_traits<char>, std::allocator<char> >@GLIBCXX_3.4.21' //usr/local/lib/libwebkitgtk-1.0.so.0: undefined reference to `std::condition_variable::notify_one()@GLIBCXX_3.4.11' //usr/local/lib/libwebkitgtk-1.0.so.0: undefined reference to `std::__once_call@GLIBCXX_3.4.11' While here, add USES=gnome. PR: 237145 Approved by: portmaster@bsdforge.com (maintainer timeout), mat (mentor) Differential Revision: https://reviews.freebsd.org/D20105
-rw-r--r--graphics/delaboratory/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/graphics/delaboratory/Makefile b/graphics/delaboratory/Makefile
index 68ef122a7b19..75e12cae18fb 100644
--- a/graphics/delaboratory/Makefile
+++ b/graphics/delaboratory/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libtiff.so:graphics/tiff
-USES= compiler:c++11-lib gmake
+USES= compiler:c++11-lib gmake gnome
MAKE_ARGS= CXX="${CXX}" WXCONFIG="${WX_CONFIG}"
USE_WX= 3.0
USE_CXXSTD= c++11
@@ -25,7 +25,8 @@ PLIST_FILES= bin/${PORTNAME}
post-patch:
@${REINPLACE_CMD} -e 's|-Ofast.*}|${CXXFLAGS}| ; \
- s|CXXFLAGS_WX +=|& ${CXXFLAGS} -I${LOCALBASE}/include|' \
+ s|CXXFLAGS_WX +=|& ${CXXFLAGS} -I${LOCALBASE}/include| ;\
+ s|LDFLAGS=|LDFLAGS+=|' \
${WRKSRC}/${MAKEFILE}
do-install: