aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2007-10-24 21:21:22 +0800
committerale <ale@FreeBSD.org>2007-10-24 21:21:22 +0800
commit4c5797ed16b97a20e95474affbcabc6480f6acba (patch)
tree7a0735d382943fbd3f4b2bde07ba89ff7d9da08c
parent8785c2b13c849ba2091f26581867a5e34ff176ed (diff)
downloadfreebsd-ports-gnome-4c5797ed16b97a20e95474affbcabc6480f6acba.tar.gz
freebsd-ports-gnome-4c5797ed16b97a20e95474affbcabc6480f6acba.tar.zst
freebsd-ports-gnome-4c5797ed16b97a20e95474affbcabc6480f6acba.zip
The package com.ice.tar implements a tar archive io package.
This package allows you to create, and extract tar archives. Since the package uses InputStream and OutputStream, it is possible to combine this package with the java.util.zip package to handle .tar.gz files. WWW: http://www.trustice.com/java/tar/
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/javatar/Makefile41
-rw-r--r--archivers/javatar/distinfo3
-rw-r--r--archivers/javatar/pkg-descr10
4 files changed, 55 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index f008e4d69904..9ef729d9e986 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -35,6 +35,7 @@
SUBDIR += hffzip
SUBDIR += hlextract
SUBDIR += hpack.non-usa.only
+ SUBDIR += javatar
SUBDIR += jzip.org
SUBDIR += jzlib
SUBDIR += kbackup
diff --git a/archivers/javatar/Makefile b/archivers/javatar/Makefile
new file mode 100644
index 000000000000..e1a5786f454c
--- /dev/null
+++ b/archivers/javatar/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: Java Tar
+# Date created: 24 Oct 2007
+# Whom: Alex Dupre <ale@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= javatar
+PORTVERSION= 2.5
+CATEGORIES= archivers java
+MASTER_SITES= http://www.gjt.org/download/time/java/tar/ \
+ ftp://ftp.gjt.org/pub/time/java/tar/
+
+MAINTAINER= ale@FreeBSD.org
+COMMENT= A Java tar archive io package
+
+RUN_DEPENDS= ${JAVALIBDIR}/activation.jar:${PORTSDIR}/java/jaf
+
+USE_JAVA= yes
+JAVA_VERSION= 1.4+
+
+NO_BUILD= yes
+
+PORTDOCS= api LICENSE License.html readme.html tarman.html
+
+JARFILES= tar.jar
+PLIST_FILES= ${JARFILES:S,^,%%JAVAJARDIR%%/,}
+
+do-install:
+ @${ECHO_MSG} -n ">> Install JAR file in ${JAVAJARDIR}..."
+ @${INSTALL_DATA} ${WRKSRC}/jars/tar.jar ${JAVAJARDIR}/
+ @${ECHO_MSG} " [ DONE ]"
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} -n ">> Installing documentation in ${DOCSDIR}..."
+ @${MKDIR} ${DOCSDIR}
+ @cd ${WRKSRC}/doc && ${FIND} ${PORTDOCS} \
+ | ${CPIO} -pdmu -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR} > /dev/null 2>&1
+ @${ECHO_MSG} " [ DONE ]"
+.endif
+
+.include <bsd.port.mk>
diff --git a/archivers/javatar/distinfo b/archivers/javatar/distinfo
new file mode 100644
index 000000000000..81e3aa4786a5
--- /dev/null
+++ b/archivers/javatar/distinfo
@@ -0,0 +1,3 @@
+MD5 (javatar-2.5.tar.gz) = 7dae3b92b70c30cfb6fd9699a79f821c
+SHA256 (javatar-2.5.tar.gz) = ecb1987a57590714f098fa30342d84dfe234354d45f651e559f9965985654c0e
+SIZE (javatar-2.5.tar.gz) = 168790
diff --git a/archivers/javatar/pkg-descr b/archivers/javatar/pkg-descr
new file mode 100644
index 000000000000..ee7bcf246f3c
--- /dev/null
+++ b/archivers/javatar/pkg-descr
@@ -0,0 +1,10 @@
+The package com.ice.tar implements a tar archive io package.
+This package allows you to create, and extract tar archives.
+Since the package uses InputStream and OutputStream, it is possible
+to combine this package with the java.util.zip package to handle
+.tar.gz files.
+
+WWW: http://www.trustice.com/java/tar/
+
+- Alex Dupre
+ale@FreeBSD.org