aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorse <se@FreeBSD.org>2018-05-19 15:59:57 +0800
committerse <se@FreeBSD.org>2018-05-19 15:59:57 +0800
commit4d5411681a094e99743ac2031176306802a2d2cc (patch)
tree9ba5cde3c1f59717fafd743cc09ec87e5e9b5466
parent297fab981ba6e73777079409aecdb4f17af684a2 (diff)
downloadfreebsd-ports-gnome-4d5411681a094e99743ac2031176306802a2d2cc.tar.gz
freebsd-ports-gnome-4d5411681a094e99743ac2031176306802a2d2cc.tar.zst
freebsd-ports-gnome-4d5411681a094e99743ac2031176306802a2d2cc.zip
Add CONFLICTS entries that prevent simultaneous installation of normal
and devel versions of these ports. While these are allowed when the devel versions are newer than the normal versions, this is not always the case and especially not at this time. Instead of only conflicting with the same version of each port, a version wildcard is used, to prevent unexpected behavior if the non-devel version is updated to match the devel version when both are installed. Approved by: gerald (maintainer)
-rw-r--r--emulators/wine-gecko-devel/Makefile4
-rw-r--r--emulators/wine-gecko/Makefile4
-rw-r--r--emulators/wine-mono-devel/Makefile4
-rw-r--r--emulators/wine-mono/Makefile4
4 files changed, 12 insertions, 4 deletions
diff --git a/emulators/wine-gecko-devel/Makefile b/emulators/wine-gecko-devel/Makefile
index c0614c2ae3a9..3a34dc229ac6 100644
--- a/emulators/wine-gecko-devel/Makefile
+++ b/emulators/wine-gecko-devel/Makefile
@@ -16,10 +16,12 @@ COMMENT= Gecko Layout Engine for Wine development branch (HTML support)
LICENSE= MPL20 GPLv2 GPLv3 LGPL21 LGPL3
LICENSE_COMB= multi
+CONFLICTS_INSTALL= wine-gecko-[0-9]*
+
NO_BUILD= yes
PLIST_SUB+= GECKO_VERSION="${DISTVERSION}"
DATADIR= ${PREFIX}/share/wine
-PLIST_FILES= %%DATADIR%%/gecko/wine_gecko-%%GECKO_VERSION%%-x86.msi
+PLIST_FILES= ${DATADIR}/gecko/wine_gecko-${DISTVERSION}-x86.msi
do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}/gecko
diff --git a/emulators/wine-gecko/Makefile b/emulators/wine-gecko/Makefile
index d7339a745bbd..2276ccdb1156 100644
--- a/emulators/wine-gecko/Makefile
+++ b/emulators/wine-gecko/Makefile
@@ -17,10 +17,12 @@ LICENSE_COMB= multi
PORTSCOUT= ignore:1 # for newer versions see emulators/wine-gecko-devel
+CONFLICTS_INSTALL= wine-gecko-devel-[0-9]*
+
NO_BUILD= yes
PLIST_SUB+= GECKO_VERSION="${DISTVERSION}"
DATADIR= ${PREFIX}/share/wine
-PLIST_FILES= %%DATADIR%%/gecko/wine_gecko-%%GECKO_VERSION%%-x86.msi
+PLIST_FILES= ${DATADIR}/gecko/wine_gecko-${DISTVERSION}-x86.msi
do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}/gecko
diff --git a/emulators/wine-mono-devel/Makefile b/emulators/wine-mono-devel/Makefile
index a8a13e1d65d9..d2b8232cec0e 100644
--- a/emulators/wine-mono-devel/Makefile
+++ b/emulators/wine-mono-devel/Makefile
@@ -15,10 +15,12 @@ COMMENT= Mono .NET implementation for Wine development branch (HTML support)
LICENSE= MIT GPLv2 LGPL20
LICENSE_COMB= multi
+CONFLICTS_INSTALL= wine-mono-[0-9]*
+
NO_BUILD= yes
PLIST_SUB+= MONO_VERSION="${DISTVERSION}"
DATADIR= ${PREFIX}/share/wine
-PLIST_FILES= %%DATADIR%%/mono/wine-mono-%%MONO_VERSION%%.msi
+PLIST_FILES= ${DATADIR}/mono/wine-mono-${DISTVERSION}.msi
do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}/mono
diff --git a/emulators/wine-mono/Makefile b/emulators/wine-mono/Makefile
index b232ad7670f9..91465f58c99f 100644
--- a/emulators/wine-mono/Makefile
+++ b/emulators/wine-mono/Makefile
@@ -16,10 +16,12 @@ LICENSE_COMB= multi
PORTSCOUT= ignore:1 # for newer versions see emulators/wine-mono-devel
+CONFLICTS_INSTALL= wine-mono-devel-[0-9]*
+
NO_BUILD= yes
PLIST_SUB+= MONO_VERSION="${DISTVERSION}"
DATADIR= ${PREFIX}/share/wine
-PLIST_FILES= %%DATADIR%%/mono/wine-mono-%%MONO_VERSION%%.msi
+PLIST_FILES= ${DATADIR}/mono/wine-mono-${DISTVERSION}.msi
do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}/mono