aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-01-03 04:12:37 +0800
committerpav <pav@FreeBSD.org>2004-01-03 04:12:37 +0800
commit4f18c7af2f193c8f12a96c1cad718f9f9fd20b9d (patch)
tree2b8615530b0b6b944b5f4c636b3376bc192ba2d8
parent8ad747f79c39b9b2d83f072cd830a3451980e16b (diff)
downloadfreebsd-ports-gnome-4f18c7af2f193c8f12a96c1cad718f9f9fd20b9d.tar.gz
freebsd-ports-gnome-4f18c7af2f193c8f12a96c1cad718f9f9fd20b9d.tar.zst
freebsd-ports-gnome-4f18c7af2f193c8f12a96c1cad718f9f9fd20b9d.zip
- Add patch for this problem:
The XMLPlatformUtils::openFile function opens files with fopen and passes it "r+" string as mode argument. This makes(according to fopen(3)) it try to open file for reading and writing while it should be opened for reading only. As a result you can't work with files not owned by you which is rather common case for dtd files. - Raise PORTREVISION PR: ports/59499 Submitted by: Konstantin Oznobihin <bork@rsu.ru> Approved by: maintainer
-rw-r--r--textproc/xerces-c2-devel/Makefile1
-rw-r--r--textproc/xerces-c2-devel/files/patch-src-xercesc-util-Platforms-FreeBSD-FreeBSDPlatformUtils.cpp20
-rw-r--r--textproc/xerces-c2/Makefile1
-rw-r--r--textproc/xerces-c2/files/patch-src-xercesc-util-Platforms-FreeBSD-FreeBSDPlatformUtils.cpp20
-rw-r--r--textproc/xerces-c27/Makefile1
-rw-r--r--textproc/xerces-c27/files/patch-src-xercesc-util-Platforms-FreeBSD-FreeBSDPlatformUtils.cpp20
6 files changed, 63 insertions, 0 deletions
diff --git a/textproc/xerces-c2-devel/Makefile b/textproc/xerces-c2-devel/Makefile
index 51264bbe808a..9966df9232dc 100644
--- a/textproc/xerces-c2-devel/Makefile
+++ b/textproc/xerces-c2-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xerces-c2
PORTVERSION= 2.3.0
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_APACHE_XML}
MASTER_SITE_SUBDIR= xerces-c/source
diff --git a/textproc/xerces-c2-devel/files/patch-src-xercesc-util-Platforms-FreeBSD-FreeBSDPlatformUtils.cpp b/textproc/xerces-c2-devel/files/patch-src-xercesc-util-Platforms-FreeBSD-FreeBSDPlatformUtils.cpp
new file mode 100644
index 000000000000..9b0f6629c8af
--- /dev/null
+++ b/textproc/xerces-c2-devel/files/patch-src-xercesc-util-Platforms-FreeBSD-FreeBSDPlatformUtils.cpp
@@ -0,0 +1,20 @@
+--- src/xercesc/util/Platforms/FreeBSD/FreeBSDPlatformUtils.cpp Wed Nov 12 20:32:33 2003
++++ src/xercesc/util/Platforms/FreeBSD/FreeBSDPlatformUtils.cpp Wed Nov 12 20:31:16 2003
+@@ -298,7 +298,7 @@
+ XMLExcepts::CPtr_PointerIsZero);
+ const char* tmpFileName = XMLString::transcode(fileName, fgMemoryManager);
+ ArrayJanitor<char> janText((char*)tmpFileName, fgMemoryManager);
+- FileHandle retVal = (FileHandle)fopen( tmpFileName , "r+" );
++ FileHandle retVal = (FileHandle)fopen( tmpFileName , "r" );
+ return retVal;
+ }
+
+@@ -307,7 +307,7 @@
+ if (fileName == NULL)
+ ThrowXML(XMLPlatformUtilsException,
+ XMLExcepts::CPtr_PointerIsZero);
+- FileHandle retVal = (FileHandle)fopen( fileName , "r+" );
++ FileHandle retVal = (FileHandle)fopen( fileName , "r" );
+ return retVal;
+ }
+
diff --git a/textproc/xerces-c2/Makefile b/textproc/xerces-c2/Makefile
index 51264bbe808a..9966df9232dc 100644
--- a/textproc/xerces-c2/Makefile
+++ b/textproc/xerces-c2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xerces-c2
PORTVERSION= 2.3.0
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_APACHE_XML}
MASTER_SITE_SUBDIR= xerces-c/source
diff --git a/textproc/xerces-c2/files/patch-src-xercesc-util-Platforms-FreeBSD-FreeBSDPlatformUtils.cpp b/textproc/xerces-c2/files/patch-src-xercesc-util-Platforms-FreeBSD-FreeBSDPlatformUtils.cpp
new file mode 100644
index 000000000000..9b0f6629c8af
--- /dev/null
+++ b/textproc/xerces-c2/files/patch-src-xercesc-util-Platforms-FreeBSD-FreeBSDPlatformUtils.cpp
@@ -0,0 +1,20 @@
+--- src/xercesc/util/Platforms/FreeBSD/FreeBSDPlatformUtils.cpp Wed Nov 12 20:32:33 2003
++++ src/xercesc/util/Platforms/FreeBSD/FreeBSDPlatformUtils.cpp Wed Nov 12 20:31:16 2003
+@@ -298,7 +298,7 @@
+ XMLExcepts::CPtr_PointerIsZero);
+ const char* tmpFileName = XMLString::transcode(fileName, fgMemoryManager);
+ ArrayJanitor<char> janText((char*)tmpFileName, fgMemoryManager);
+- FileHandle retVal = (FileHandle)fopen( tmpFileName , "r+" );
++ FileHandle retVal = (FileHandle)fopen( tmpFileName , "r" );
+ return retVal;
+ }
+
+@@ -307,7 +307,7 @@
+ if (fileName == NULL)
+ ThrowXML(XMLPlatformUtilsException,
+ XMLExcepts::CPtr_PointerIsZero);
+- FileHandle retVal = (FileHandle)fopen( fileName , "r+" );
++ FileHandle retVal = (FileHandle)fopen( fileName , "r" );
+ return retVal;
+ }
+
diff --git a/textproc/xerces-c27/Makefile b/textproc/xerces-c27/Makefile
index 51264bbe808a..9966df9232dc 100644
--- a/textproc/xerces-c27/Makefile
+++ b/textproc/xerces-c27/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xerces-c2
PORTVERSION= 2.3.0
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_APACHE_XML}
MASTER_SITE_SUBDIR= xerces-c/source
diff --git a/textproc/xerces-c27/files/patch-src-xercesc-util-Platforms-FreeBSD-FreeBSDPlatformUtils.cpp b/textproc/xerces-c27/files/patch-src-xercesc-util-Platforms-FreeBSD-FreeBSDPlatformUtils.cpp
new file mode 100644
index 000000000000..9b0f6629c8af
--- /dev/null
+++ b/textproc/xerces-c27/files/patch-src-xercesc-util-Platforms-FreeBSD-FreeBSDPlatformUtils.cpp
@@ -0,0 +1,20 @@
+--- src/xercesc/util/Platforms/FreeBSD/FreeBSDPlatformUtils.cpp Wed Nov 12 20:32:33 2003
++++ src/xercesc/util/Platforms/FreeBSD/FreeBSDPlatformUtils.cpp Wed Nov 12 20:31:16 2003
+@@ -298,7 +298,7 @@
+ XMLExcepts::CPtr_PointerIsZero);
+ const char* tmpFileName = XMLString::transcode(fileName, fgMemoryManager);
+ ArrayJanitor<char> janText((char*)tmpFileName, fgMemoryManager);
+- FileHandle retVal = (FileHandle)fopen( tmpFileName , "r+" );
++ FileHandle retVal = (FileHandle)fopen( tmpFileName , "r" );
+ return retVal;
+ }
+
+@@ -307,7 +307,7 @@
+ if (fileName == NULL)
+ ThrowXML(XMLPlatformUtilsException,
+ XMLExcepts::CPtr_PointerIsZero);
+- FileHandle retVal = (FileHandle)fopen( fileName , "r+" );
++ FileHandle retVal = (FileHandle)fopen( fileName , "r" );
+ return retVal;
+ }
+