aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2017-04-07 23:26:29 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2017-04-09 21:34:05 +0800
commit4f8a76af66def92aa65a1330cd7527e71598b474 (patch)
tree26a960f52554422ab15b9f672f3748352f7f870b
parent9ed608b2873e4e6d7738ed96c252671a9e2c3344 (diff)
downloadfreebsd-ports-gnome-4f8a76af66def92aa65a1330cd7527e71598b474.tar.gz
freebsd-ports-gnome-4f8a76af66def92aa65a1330cd7527e71598b474.tar.zst
freebsd-ports-gnome-4f8a76af66def92aa65a1330cd7527e71598b474.zip
- Add LICENSE_FILE
- Switch to USES=localbase - Switch to options helpers
-rw-r--r--games/bomberclone/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/games/bomberclone/Makefile b/games/bomberclone/Makefile
index bf328842e5e6..93ec25ec6e41 100644
--- a/games/bomberclone/Makefile
+++ b/games/bomberclone/Makefile
@@ -11,13 +11,14 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Reimplementation of Atomic Bomber Man
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
-USES= gmake
+USES= gmake localbase
USE_SDL= image mixer sdl
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --target="" --disable-werror
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib -lm
+CONFIGURE_ARGS= --disable-werror
+
+LIBS+= -lm
PORTDOCS= AUTHORS ChangeLog README TODO
@@ -33,13 +34,14 @@ post-patch:
@${REINPLACE_CMD} -e 's|share/games/${PACKAGE}|share/${PACKAGE}|' \
${WRKSRC}/configure
@${REINPLACE_CMD} \
- -e 's|install-data-am: install-bomberclonedocDATA|install-data-am: |' \
+ -e 's|install-data-am: install-bomberclonedocDATA|install-data-am: |' \
${WRKSRC}/Makefile.in
post-install:
${LN} -sf ${DATADIR}/pixmaps/${PORTNAME}.png \
${STAGEDIR}${PREFIX}/share/pixmaps/
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}