aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoop Mast <kwm@rainbow-runner.nl>2017-01-01 06:28:18 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2017-01-01 06:28:18 +0800
commit4fd42467e77d9b29de9951b3e0bbbb19b9501582 (patch)
tree4faf8f17cf6e094f98e77f722a15789ea4cc9698
parentb709a6d292d0cca6e5ef8b32588759780fe77f3a (diff)
downloadfreebsd-ports-gnome-4fd42467e77d9b29de9951b3e0bbbb19b9501582.tar.gz
freebsd-ports-gnome-4fd42467e77d9b29de9951b3e0bbbb19b9501582.tar.zst
freebsd-ports-gnome-4fd42467e77d9b29de9951b3e0bbbb19b9501582.zip
Unbreak yelp.
-rw-r--r--x11/yelp/Makefile14
-rw-r--r--x11/yelp/files/patch-Makefile.am18
-rw-r--r--x11/yelp/files/patch-libyelp_yelp-man-parser.c2
-rw-r--r--x11/yelp/pkg-plist1
4 files changed, 10 insertions, 25 deletions
diff --git a/x11/yelp/Makefile b/x11/yelp/Makefile
index 70eb974cfa38..35f8a9039f56 100644
--- a/x11/yelp/Makefile
+++ b/x11/yelp/Makefile
@@ -15,15 +15,18 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= yelp-xsl>=0:textproc/yelp-xsl \
itstool:textproc/itstool
-LIB_DEPENDS= libwebkit2gtk-4.0.so:www/webkit2-gtk3
+LIB_DEPENDS= libwebkit2gtk-4.0.so:www/webkit2-gtk3 \
+ libgcrypt.so:security/libgcrypt \
+ libgpg-error.so:security/libgpg-error \
+ libsoup-2.4.so:devel/libsoup
RUN_DEPENDS= yelp-xsl>=0:textproc/yelp-xsl
PORTSCOUT= limitw:1,even
-USES= autoreconf desktop-file-utils gettext gmake gnome libtool pathfix \
- pkgconfig tar:xz
+USES= desktop-file-utils gettext gmake gnome libtool pathfix \
+ pkgconfig sqlite tar:xz
USE_XORG= x11 ice
-USE_GNOME= gtk30 intlhack libxml2 libxslt
+USE_GNOME= cairo gtk30 intlhack libxml2 libxslt
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
USE_LDCONFIG= yes
@@ -38,7 +41,8 @@ CONFIGURE_ENV+= YELP_LZMA_CFLAGS="-I/usr/include" \
.endif
post-patch:
- @${CP} ${FILESDIR}/yelp-groff ${WRKSRC}
+ @${REINPLACE_CMD} -e 's|%%LIBEXECDIR%%|${PREFIX}/libexec|g' \
+ ${WRKSRC}/libyelp/yelp-man-parser.c
post-install:
${INSTALL_SCRIPT} ${FILESDIR}/yelp-groff ${STAGEDIR}${PREFIX}/libexec
diff --git a/x11/yelp/files/patch-Makefile.am b/x11/yelp/files/patch-Makefile.am
deleted file mode 100644
index bf8e6641c1cf..000000000000
--- a/x11/yelp/files/patch-Makefile.am
+++ /dev/null
@@ -1,18 +0,0 @@
---- Makefile.am.orig 2016-11-21 13:27:30.186706000 +0100
-+++ Makefile.am 2016-11-21 13:26:53.438361000 +0100
-@@ -6,6 +6,7 @@
- $(nodist_libyelp_libyelp_la_SOURCES)
-
- lib_LTLIBRARIES = libyelp/libyelp.la
-+libexec_SCRIPTS = yelp-groff
-
- libyelp_libyelp_la_SOURCES = \
- libyelp/yelp-bookmarks.c \
-@@ -54,6 +55,7 @@
- libyelp_libyelp_la_CFLAGS = \
- $(WARN_CFLAGS) \
- $(YELP_CFLAGS) \
-+ -DLIBEXECDIR=\"$(libexecdir)" \
- -Wno-deprecated-declarations
-
- libyelp_libyelp_la_CPPFLAGS = \
diff --git a/x11/yelp/files/patch-libyelp_yelp-man-parser.c b/x11/yelp/files/patch-libyelp_yelp-man-parser.c
index 0f2d63662c16..276f1372989e 100644
--- a/x11/yelp/files/patch-libyelp_yelp-man-parser.c
+++ b/x11/yelp/files/patch-libyelp_yelp-man-parser.c
@@ -5,7 +5,7 @@
gint ystdout;
GError *err = NULL;
- const gchar *argv[] = { "man", "-Z", "-Tutf8", "-EUTF-8", path, NULL };
-+ const gchar *argv[] = { LIBEXECDIR "/yelp-groff", path, NULL };
++ const gchar *argv[] = { "%%LIBEXECDIR%%", "/yelp-groff", path, NULL };
gchar **my_argv;
/* g_strdupv() should accept a "const gchar **". */
diff --git a/x11/yelp/pkg-plist b/x11/yelp/pkg-plist
index 19e7c4a0ae1a..102e56e6449e 100644
--- a/x11/yelp/pkg-plist
+++ b/x11/yelp/pkg-plist
@@ -35,7 +35,6 @@ share/gtk-doc/html/libyelp/ch01.html
share/gtk-doc/html/libyelp/ch01s02.html
share/gtk-doc/html/libyelp/home.png
share/gtk-doc/html/libyelp/index.html
-share/gtk-doc/html/libyelp/index.sgml
share/gtk-doc/html/libyelp/left-insensitive.png
share/gtk-doc/html/libyelp/left.png
share/gtk-doc/html/libyelp/libyelp-yelp-error.html