aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2017-07-17 03:58:15 +0800
committerpi <pi@FreeBSD.org>2017-07-17 03:58:15 +0800
commit4ffe306e1dd97bad6bdd2dc8c172ef832d329ee6 (patch)
tree5496b6aca7422563c29dc9714d77f678af7812f4
parent1f1a61ce3cf3996a56ee6cd58143101f4cd5eee8 (diff)
downloadfreebsd-ports-gnome-4ffe306e1dd97bad6bdd2dc8c172ef832d329ee6.tar.gz
freebsd-ports-gnome-4ffe306e1dd97bad6bdd2dc8c172ef832d329ee6.tar.zst
freebsd-ports-gnome-4ffe306e1dd97bad6bdd2dc8c172ef832d329ee6.zip
textproc/wbxml2: update 0.11.4 -> 0.11.5
PR: 220177 Changes: https://github.com/libwbxml/libwbxml/releases Submitted by: Martin Waschbuesch <martin@waschbuesch.de> Approved by: flo (maintainer timeout)
-rw-r--r--textproc/wbxml2/Makefile3
-rw-r--r--textproc/wbxml2/distinfo5
-rw-r--r--textproc/wbxml2/files/patch-src__CMakeLists.txt27
3 files changed, 22 insertions, 13 deletions
diff --git a/textproc/wbxml2/Makefile b/textproc/wbxml2/Makefile
index 49de82f0d11e..fa90b059ffaa 100644
--- a/textproc/wbxml2/Makefile
+++ b/textproc/wbxml2/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= wbxml2
-PORTVERSION= 0.11.4
-PORTREVISION= 1
+PORTVERSION= 0.11.5
CATEGORIES= textproc devel
MASTER_SITES= SF/libwbxml/libwbxml/${PORTVERSION}
DISTNAME= libwbxml-${PORTVERSION}
diff --git a/textproc/wbxml2/distinfo b/textproc/wbxml2/distinfo
index 3d9bc2bc7459..83431b9104cd 100644
--- a/textproc/wbxml2/distinfo
+++ b/textproc/wbxml2/distinfo
@@ -1,2 +1,3 @@
-SHA256 (libwbxml-0.11.4.tar.bz2) = 8057998042b8a724328346a50c326010ba011a40e18e2df7043e87498a679c28
-SIZE (libwbxml-0.11.4.tar.bz2) = 354388
+TIMESTAMP = 1498517632
+SHA256 (libwbxml-0.11.5.tar.bz2) = 5f8fabc0152d73b725e16211ccd74263c1c2f9f1dc36a2fd916a8deb4ee577e2
+SIZE (libwbxml-0.11.5.tar.bz2) = 359663
diff --git a/textproc/wbxml2/files/patch-src__CMakeLists.txt b/textproc/wbxml2/files/patch-src__CMakeLists.txt
index 28e0ad2cda5d..9d50eba7899c 100644
--- a/textproc/wbxml2/files/patch-src__CMakeLists.txt
+++ b/textproc/wbxml2/files/patch-src__CMakeLists.txt
@@ -1,11 +1,20 @@
---- src/CMakeLists.txt.orig 2014-08-11 16:01:40 UTC
-+++ src/CMakeLists.txt
-@@ -24,7 +24,7 @@ ADD_LIBRARY( wbxml2 SHARED ${libwbxml_LI
+--- src/CMakeLists.txt.orig 2017-02-12 14:08:00.000000000 +0100
++++ src/CMakeLists.txt 2017-06-27 01:06:36.975987000 +0200
+@@ -30,7 +30,7 @@
- SET_TARGET_PROPERTIES( wbxml2 PROPERTIES SOVERSION ${LIBWBXML_LIBVERSION_SOVERSION} )
- SET_TARGET_PROPERTIES( wbxml2 PROPERTIES VERSION ${LIBWBXML_LIBVERSION_VERSION} )
--TARGET_LINK_LIBRARIES( wbxml2 ${EXPAT_LIBRARIES} )
-+TARGET_LINK_LIBRARIES( wbxml2 ${EXPAT_LIBRARIES} ${ICONV_LIBRARIES} )
+ SET_TARGET_PROPERTIES( wbxml2 PROPERTIES SOVERSION ${LIBWBXML_LIBVERSION_SOVERSION} )
+ SET_TARGET_PROPERTIES( wbxml2 PROPERTIES VERSION ${LIBWBXML_LIBVERSION_VERSION} )
+- TARGET_LINK_LIBRARIES( wbxml2 ${EXPAT_LIBRARIES} )
++ TARGET_LINK_LIBRARIES( wbxml2 ${EXPAT_LIBRARIES} ${ICONV_LIBRARIES} )
- INSTALL( TARGETS wbxml2
- RUNTIME DESTINATION ${LIBWBXML_BIN_DIR}
+ INSTALL( TARGETS wbxml2
+ RUNTIME DESTINATION ${LIBWBXML_BIN_DIR}
+@@ -44,7 +44,7 @@
+
+ SET_TARGET_PROPERTIES( wbxml2_static PROPERTIES SOVERSION ${LIBWBXML_LIBVERSION_SOVERSION} )
+ SET_TARGET_PROPERTIES( wbxml2_static PROPERTIES VERSION ${LIBWBXML_LIBVERSION_VERSION} )
+- TARGET_LINK_LIBRARIES( wbxml2_static ${EXPAT_LIBRARIES} )
++ TARGET_LINK_LIBRARIES( wbxml2_static ${EXPAT_LIBRARIES} ${ICONV_LIBRARIES} )
+ SET_TARGET_PROPERTIES( wbxml2_static PROPERTIES OUTPUT_NAME wbxml2 )
+
+ INSTALL( TARGETS wbxml2_static