aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2017-03-19 20:28:00 +0800
committerdinoex <dinoex@FreeBSD.org>2017-03-19 20:28:00 +0800
commit52eacce2c206e41eecad6ca544ddf09dd0044d37 (patch)
tree848e70c3558b98c187453ed70a6c2cf388d897ad
parent781431f74b565c43399e1f37801765c536948b05 (diff)
downloadfreebsd-ports-gnome-52eacce2c206e41eecad6ca544ddf09dd0044d37.tar.gz
freebsd-ports-gnome-52eacce2c206e41eecad6ca544ddf09dd0044d37.tar.zst
freebsd-ports-gnome-52eacce2c206e41eecad6ca544ddf09dd0044d37.zip
- update to 20170319
-rw-r--r--net/tinyldap/Makefile9
-rw-r--r--net/tinyldap/distinfo5
-rw-r--r--net/tinyldap/files/patch-Makefile35
-rw-r--r--net/tinyldap/files/patch-auth.c18
-rw-r--r--net/tinyldap/files/patch-ldif.h8
-rw-r--r--net/tinyldap/files/patch-md5password.c18
6 files changed, 27 insertions, 66 deletions
diff --git a/net/tinyldap/Makefile b/net/tinyldap/Makefile
index fb8f8baf5b59..ff1368ceab9d 100644
--- a/net/tinyldap/Makefile
+++ b/net/tinyldap/Makefile
@@ -2,7 +2,6 @@
PORTNAME= tinyldap
PORTVERSION= 0.0.${SNAPSHOT}
-PORTREVISION= 1
CATEGORIES= net ipv6
MASTER_SITES= ftp://ftp.dinoex.de/pub/tinyldap/
DISTNAME= ${PORTNAME}-${SNAPSHOT}
@@ -10,12 +9,12 @@ DISTNAME= ${PORTNAME}-${SNAPSHOT}
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Small LDAP implementation
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libowfat.a:${LIBOWFAT_PORT}
-
LICENSE= GPLv2
-SNAPSHOT= 20091122
-USES= tar:bzip2 gmake
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libowfat.a:${LIBOWFAT_PORT}
+
+SNAPSHOT= 20170319
+USES= tar:bzip2 gmake ssl
WRKSRC= ${WRKDIR}/${PORTNAME}
CFLAGS+= -DATTRIBS=512
SBINFILES= acl addindex bindrequest dumpacls dumpidx idx2ldif parse \
diff --git a/net/tinyldap/distinfo b/net/tinyldap/distinfo
index 8cb8fdc25507..8347084b00aa 100644
--- a/net/tinyldap/distinfo
+++ b/net/tinyldap/distinfo
@@ -1,2 +1,3 @@
-SHA256 (tinyldap-20091122.tar.bz2) = a369db5678aa828e629dd98b546eb031adfffa641fd85bfe6d59c1c30851a996
-SIZE (tinyldap-20091122.tar.bz2) = 54088
+TIMESTAMP = 1489925452
+SHA256 (tinyldap-20170319.tar.bz2) = 99ab02728c4a8940d7e696cd46a26f6b4cda7df3c4ace2633b68356f893e2113
+SIZE (tinyldap-20170319.tar.bz2) = 74096
diff --git a/net/tinyldap/files/patch-Makefile b/net/tinyldap/files/patch-Makefile
index dfee68d63f23..1eaa3166519f 100644
--- a/net/tinyldap/files/patch-Makefile
+++ b/net/tinyldap/files/patch-Makefile
@@ -1,19 +1,22 @@
---- Makefile.orig 2008-04-25 13:09:33.000000000 +0200
-+++ Makefile 2009-11-22 22:24:42.000000000 +0100
-@@ -35,22 +35,26 @@
-
- auth.a: auth.o
+--- Makefile.orig 2017-03-19 11:47:19 UTC
++++ Makefile
+@@ -43,20 +43,23 @@ tls_cipherprio.o fmt_tls_alert_pkt.o fmt
+ fmt_tls_handshake_certs_header.o fmt_tls_serverhellodone.o \
+ tls_accept.o tls_connect.o tls_doread.o tls_dowrite.o
-DIET=/opt/diet/bin/diet -Os
--CC=gcc
+DIET=
-+CC?=gcc
- CFLAGS=-pipe -I. -Wall -W -Wextra
+ CROSS=
+ #CROSS=i686-mingw32-
+-CC=$(CROSS)gcc
+-CFLAGS=-pipe -I. -Wall -W -Wextra
++CC?=$(CROSS)gcc
++CFLAGS?=-pipe -I. -Wall -W -Wextra
ifneq ($(DEBUG),)
-DIET=/opt/diet/bin/diet
--CFLAGS=-pipe -I. -Wall -W -g -fstack-protector
+-CFLAGS=-pipe -I. -Wall -W -Wextra -g -fstack-protector
+DIET=
-+CFLAGS?=-pipe -I. -Wall -W -g -fstack-protector
++CFLAGS?=-pipe -I. -Wall -W -Wextra -g -fstack-protector
endif
ifeq ($(COVERAGE),1)
DIET=
@@ -23,22 +26,16 @@
+CFLAGS+=-I. -I${LOCALBASE}/include/libowfat -Os
+LDFLAGS+=-L${LOCALBASE}/lib
-+LIBS+=-lmd
+
ifneq ($(DIET),)
LIBS+=-llatin1
else
--LIBS+=-lcrypto -lcrypt
-+LIBS+=-lcrypt
- endif
-
- %.o: %.c
-@@ -79,7 +83,7 @@
+@@ -97,7 +100,7 @@ tinyldap_debug: tinyldap.c
$(DIET) $(CC) $(CFLAGS) -DSTANDALONE -DDEBUG -o $@ $^ $(LDFLAGS) -lowfat $(LIBS)
acl: acl.c ldap.a asn1.a
- $(DIET) $(CC) $(CFLAGS) -o acl acl.c -I. ldap.a asn1.a -lowfat $(LIBS)
+ $(DIET) $(CC) $(CFLAGS) -o acl acl.c -I. ldap.a asn1.a $(LDFLAGS) -lowfat $(LIBS)
-
- .PHONY: clean tar
+ .PHONY: test
+ test: test/bind test/ebind
diff --git a/net/tinyldap/files/patch-auth.c b/net/tinyldap/files/patch-auth.c
deleted file mode 100644
index 3160404e6d48..000000000000
--- a/net/tinyldap/files/patch-auth.c
+++ /dev/null
@@ -1,18 +0,0 @@
---- auth.c.orig 2008-04-25 13:09:34.000000000 +0200
-+++ auth.c 2009-11-22 22:28:37.000000000 +0100
-@@ -2,11 +2,15 @@
- #ifdef __dietlibc__
- #include <md5.h>
- #else
-+#ifdef __FreeBSD__
-+#include <md5.h>
-+#else
- #include <openssl/md5.h>
- #define MD5Init MD5_Init
- #define MD5Update MD5_Update
- #define MD5Final MD5_Final
- #endif
-+#endif
- #define _XOPEN_SOURCE
- #include <unistd.h>
- #include <stdlib.h>
diff --git a/net/tinyldap/files/patch-ldif.h b/net/tinyldap/files/patch-ldif.h
index 22f4dcf3a6e0..f3aa943fc438 100644
--- a/net/tinyldap/files/patch-ldif.h
+++ b/net/tinyldap/files/patch-ldif.h
@@ -1,7 +1,7 @@
---- ldif.h.orig 2008-04-25 13:09:34.000000000 +0200
-+++ ldif.h 2008-04-25 21:36:30.000000000 +0200
-@@ -4,7 +4,9 @@
- #include <ldap.h>
+--- ldif.h.orig 2017-03-19 11:47:19 UTC
++++ ldif.h
+@@ -5,7 +5,9 @@
+ #include "ldap.h"
/* how many attributes do we allow per record? */
+#ifndef ATTRIBS
diff --git a/net/tinyldap/files/patch-md5password.c b/net/tinyldap/files/patch-md5password.c
deleted file mode 100644
index fde33fb00610..000000000000
--- a/net/tinyldap/files/patch-md5password.c
+++ /dev/null
@@ -1,18 +0,0 @@
---- md5password.c.orig 2008-04-25 13:09:34.000000000 +0200
-+++ md5password.c 2009-11-22 22:28:50.000000000 +0100
-@@ -2,11 +2,15 @@
- #ifdef __dietlibc__
- #include <md5.h>
- #else
-+#ifdef __FreeBSD__
-+#include <md5.h>
-+#else
- #include <openssl/md5.h>
- #define MD5Init MD5_Init
- #define MD5Update MD5_Update
- #define MD5Final MD5_Final
- #endif
-+#endif
- #include <string.h>
- #include "buffer.h"
- #include "str.h"