aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordelphij <delphij@FreeBSD.org>2015-04-04 04:56:52 +0800
committerdelphij <delphij@FreeBSD.org>2015-04-04 04:56:52 +0800
commit54f5825ec6cd54c6f75ef12868c9f69cafaaa4d7 (patch)
tree51074a7ce347fc4189c8329db351a6617e75ed16
parentc6c506ca385aa9d5c438360c763efb6d35285e10 (diff)
downloadfreebsd-ports-gnome-54f5825ec6cd54c6f75ef12868c9f69cafaaa4d7.tar.gz
freebsd-ports-gnome-54f5825ec6cd54c6f75ef12868c9f69cafaaa4d7.tar.zst
freebsd-ports-gnome-54f5825ec6cd54c6f75ef12868c9f69cafaaa4d7.zip
Fix build when building in an environment with old version of fcitx
present. PR: ports/199112 Submitted by: maintainer
-rw-r--r--chinese/fcitx/Makefile3
-rw-r--r--chinese/fcitx/files/patch-cmake__FindLibiconv.cmake11
2 files changed, 12 insertions, 2 deletions
diff --git a/chinese/fcitx/Makefile b/chinese/fcitx/Makefile
index a11ff9d35927..0f32ce55d5fd 100644
--- a/chinese/fcitx/Makefile
+++ b/chinese/fcitx/Makefile
@@ -33,10 +33,9 @@ CONFLICTS= zh-scim-fcitx-3.*
USE_GNOME= pango intltool libxml2 introspection
USE_XORG= x11 xext xkbfile
USE_LDCONFIG= yes
-USES= tar:xz cmake desktop-file-utils execinfo gettext iconv \
+USES= tar:xz cmake desktop-file-utils execinfo gettext iconv:wchar_t \
pathfix pkgconfig shared-mime-info
INSTALLS_ICONS= yes
-LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}
OPTIONS_DEFINE= GTK2 GTK3 QT4 OPENCC TPUNC DOCS
OPTIONS_DEFAULT=GTK2 QT4
diff --git a/chinese/fcitx/files/patch-cmake__FindLibiconv.cmake b/chinese/fcitx/files/patch-cmake__FindLibiconv.cmake
new file mode 100644
index 000000000000..5c90942bc345
--- /dev/null
+++ b/chinese/fcitx/files/patch-cmake__FindLibiconv.cmake
@@ -0,0 +1,11 @@
+--- cmake/FindLibiconv.cmake.orig 2015-04-03 02:44:55.321687654 +0000
++++ cmake/FindLibiconv.cmake 2015-04-03 02:46:05.734216729 +0000
+@@ -30,7 +30,7 @@ set(LIBICONV_LIB_FOUND FALSE)
+
+ if(LIBICONV_INCLUDE_DIR)
+ include(CheckFunctionExists)
+- check_function_exists(iconv_open LIBICONV_LIBC_HAS_ICONV_OPEN)
++ set(LIBICONV_LIBC_HAS_ICONV_OPEN FALSE)
+
+ if (LIBICONV_LIBC_HAS_ICONV_OPEN)
+ set(LIBICONV_LIBRARIES)