aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorleres <leres@FreeBSD.org>2019-02-14 08:45:52 +0800
committerleres <leres@FreeBSD.org>2019-02-14 08:45:52 +0800
commit55c5fb74156a13f3e8c553dbbd47d79b3390511e (patch)
treeb6b8e74deba7045d31a7d5301cd30d85fa6e46f9
parent9f3ec55f820ea4d7b2210fc026b9a5e48759c396 (diff)
downloadfreebsd-ports-gnome-55c5fb74156a13f3e8c553dbbd47d79b3390511e.tar.gz
freebsd-ports-gnome-55c5fb74156a13f3e8c553dbbd47d79b3390511e.tar.zst
freebsd-ports-gnome-55c5fb74156a13f3e8c553dbbd47d79b3390511e.zip
Upgrade to 2.8.0:
- New indexer 'response_time' - Support for MaxMind DB (GeoIP2) - Update 'pcap_layers' with fixes for 'scan-build' warnings - Fix port in debug output of DNS message Changes made in addition to the PR supplied patch: - The port had USES=shebangfix but none of the SHEBANG_ variables were set; replace the cron_upload-prep.pl patch with a working shebangfix setup and then use REINPLACE_CMD to adjust the conf path in upload-prep.pl - While we're here use REINPLACE_CMD to obey PREFIX in other files PR: 235711 Submitted by: Leo Vandewoestijne (maintainer) Reviewed by: ler (mentor) Approved by: ler (mentor) Differential Revision: https://reviews.freebsd.org/D19187
-rw-r--r--dns/dsc/Makefile16
-rw-r--r--dns/dsc/distinfo6
-rw-r--r--dns/dsc/files/patch-cron_upload-prep.pl17
3 files changed, 16 insertions, 23 deletions
diff --git a/dns/dsc/Makefile b/dns/dsc/Makefile
index ed6adcfb313a..d703fe1f1986 100644
--- a/dns/dsc/Makefile
+++ b/dns/dsc/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= dsc
-PORTVERSION= 2.7.0
-PORTREVISION= 1
+PORTVERSION= 2.8.0
CATEGORIES= dns
MASTER_SITES= https://www.dns-oarc.net/files/dsc/ \
https://dns.company/files/dsc/
@@ -26,9 +25,20 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-extra-cflags=-I${LOCALBASE}/include
SUB_FILES= pkg-message
+SHEBANG_FILES= cron/upload-prep.pl
-USE_RC_SUBR= dsc
+USE_RC_SUBR= dsc
OPTIONS_DEFINE= DOCS
+post-extract:
+ ${REINPLACE_CMD} -e 's|/usr/local/dsc/etc|${PREFIX}/etc/dsc|' \
+ ${WRKSRC}/cron/upload-prep.pl
+ ${REINPLACE_CMD} -e 's|/usr/local/|${PREFIX}/|' \
+ ${WRKSRC}/cron/upload-rsync.sh \
+ ${WRKSRC}/cron/upload-ssh.sh \
+ ${WRKSRC}/cron/upload-x509.sh \
+ ${WRKSRC}/src/dsc.conf.5.in \
+ ${WRKSRC}/src/dsc.sh
+
.include <bsd.port.mk>
diff --git a/dns/dsc/distinfo b/dns/dsc/distinfo
index fe9344b710e0..8a12c125fa03 100644
--- a/dns/dsc/distinfo
+++ b/dns/dsc/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1534374842
-SHA256 (dsc-2.7.0.tar.gz) = eab7f79229a800087d96cb8bac39927558f1d512428d7825d5edb5f7064d2c31
-SIZE (dsc-2.7.0.tar.gz) = 325520
+TIMESTAMP = 1550048113
+SHA256 (dsc-2.8.0.tar.gz) = a8e7ee0063f1ac34f686bdba773ec209a0a974ccdf0e032ba10163800ec86880
+SIZE (dsc-2.8.0.tar.gz) = 333408
diff --git a/dns/dsc/files/patch-cron_upload-prep.pl b/dns/dsc/files/patch-cron_upload-prep.pl
deleted file mode 100644
index 4d5b102dce83..000000000000
--- a/dns/dsc/files/patch-cron_upload-prep.pl
+++ /dev/null
@@ -1,17 +0,0 @@
---- cron/upload-prep.pl.orig 2017-08-21 08:14:08 UTC
-+++ cron/upload-prep.pl
-@@ -1,4 +1,4 @@
--#!/usr/bin/perl
-+#!/usr/local/bin/perl
- #
- # Copyright (c) 2016-2017, OARC, Inc.
- # Copyright (c) 2007, The Measurement Factory, Inc.
-@@ -54,7 +54,7 @@ exit 0 if Proc::PID::File->running(dir =
- sleep 3;
-
-
--foreach my $conf (</usr/local/dsc/etc/*.conf>) {
-+foreach my $conf (</usr/local/etc/dsc/*.conf>) {
- next unless open (CONF, $conf);
- my $rundir = undef;
- while (<CONF>) {