aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2017-04-20 17:17:37 +0800
committerbapt <bapt@FreeBSD.org>2017-04-20 17:17:37 +0800
commit571d87c2c1d4295f07ecb5a501d9ac4cdf0af99c (patch)
tree9907641accbf70c6a9080f6cecb2cf0106d1e7ac
parent8dfc3ba838651cc14358c10a467f7cba79815c42 (diff)
downloadfreebsd-ports-gnome-571d87c2c1d4295f07ecb5a501d9ac4cdf0af99c.tar.gz
freebsd-ports-gnome-571d87c2c1d4295f07ecb5a501d9ac4cdf0af99c.tar.zst
freebsd-ports-gnome-571d87c2c1d4295f07ecb5a501d9ac4cdf0af99c.zip
Update to 0.6.0:
Changes: https://github.com/andmarti1424/sc-im/releases/tag/v0.6.0
-rw-r--r--math/sc-im/Makefile14
-rw-r--r--math/sc-im/distinfo6
-rw-r--r--math/sc-im/files/patch-Makefile22
3 files changed, 31 insertions, 11 deletions
diff --git a/math/sc-im/Makefile b/math/sc-im/Makefile
index 0d6c3daac16f..006a89dfd5f5 100644
--- a/math/sc-im/Makefile
+++ b/math/sc-im/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= sc-im
-PORTVERSION= 0.5.0
-PORTREVISION= 1
+PORTVERSION= 0.6.0
DISTVERSIONPREFIX= v
CATEGORIES= math
@@ -12,15 +11,17 @@ COMMENT= Ncurses spreadsheet program for terminal
LICENSE= BSD4CLAUSE
LIB_DEPENDS= libxlsreader.so:math/libxls \
- libzip.so:archivers/libzip
+ libzip.so:archivers/libzip \
+ libxlsxwriter.so:math/libxlsxwriter
-USES= gmake localbase pkgconfig
+USES= gmake pkgconfig lua:51
USE_GITHUB= yes
GH_ACCOUNT= andmarti1424
USE_GNOME= libxml2
WRKSRC_SUBDIR= src
-CFLAGS+= -I${LOCALBASE}/include/libxml2
+CFLAGS+= -DXLSX_EXPORT -DXLS
+LIBS+= -lxlsreader -lxlsxwriter
MAKE_ENV+= LDLIBS="${LIBS}"
MAKE_ARGS+= CC="${CC}" prefix="${PREFIX}" MANDIR="${MANPREFIX}/man/man1"
@@ -28,4 +29,7 @@ PLIST_FILES= bin/scim \
man/man1/scim.1.gz \
share/scim/scim_help
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/scim
+
.include <bsd.port.mk>
diff --git a/math/sc-im/distinfo b/math/sc-im/distinfo
index e680a307036e..774baca99aa5 100644
--- a/math/sc-im/distinfo
+++ b/math/sc-im/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1487579247
-SHA256 (andmarti1424-sc-im-v0.5.0_GH0.tar.gz) = d7a31c5225e02239e925b50b414d7e69d12bc3554f218621823782872ccc5e4d
-SIZE (andmarti1424-sc-im-v0.5.0_GH0.tar.gz) = 867157
+TIMESTAMP = 1492677830
+SHA256 (andmarti1424-sc-im-v0.6.0_GH0.tar.gz) = 5da644d380ab3752de283b83cce18c3ba12b068d0762c44193c34367a0dcbc38
+SIZE (andmarti1424-sc-im-v0.6.0_GH0.tar.gz) = 903846
diff --git a/math/sc-im/files/patch-Makefile b/math/sc-im/files/patch-Makefile
index b75c64e404fb..ff5e326552b8 100644
--- a/math/sc-im/files/patch-Makefile
+++ b/math/sc-im/files/patch-Makefile
@@ -1,6 +1,22 @@
---- Makefile.orig 2017-02-19 16:32:00 UTC
+--- Makefile.orig 2017-04-20 00:14:03 UTC
+++ Makefile
-@@ -70,13 +70,13 @@ install :
+@@ -69,12 +69,10 @@ LDLIBS += -lxlsxwriter
+ endif
+
+ # NOTE: lua support
+-ifneq ($(shell pkg-config --exists lua51 || echo 'no'),no)
+-CFLAGS += -DXLUA $(shell pkg-config --cflags lua51)
+-LDLIBS += $(shell pkg-config --libs lua51) -Wl,--export-dynamic
++ifneq ($(shell pkg-config --exists lua-5.1 || echo 'no'),no)
++CFLAGS += -DXLUA $(shell pkg-config --cflags lua-5.1)
++LDLIBS += $(shell pkg-config --libs lua-5.1) -Wl,--export-dynamic
+ endif
+-# dynamic linking
+-LDLIBS += -ldl
+
+
+ OBJS = $(patsubst %.c, %.o, $(wildcard *.c) $(wildcard utils/*.c)) gram.o
+@@ -88,13 +86,13 @@ install :
install $(name) $(DESTDIR)$(prefix)/bin/$(name)
install -d $(DESTDIR)$(HELPDIR)
install doc $(DESTDIR)$(HELPDIR)/$(name)_help
@@ -16,4 +32,4 @@
+ -rm $(DESTDIR)$(prefix)$(MANDIR)/$(name).1
$(name) : $(OBJS)
- $(CC) $(LDFLAGS) $^ -o $@ $(LDLIBS)
+ $(CC) $(LDFLAGS) $^ -o $@ $(LDLIBS)