aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2000-05-15 05:31:58 +0800
committerobrien <obrien@FreeBSD.org>2000-05-15 05:31:58 +0800
commit5a3c9a00225160714a79e87052e09af8af4d9c6b (patch)
treef488e9812dc76ef0b557a8153c885b351d7c6893
parente8ba4a8a0ccf277cefd17ee97ea10484a746faa6 (diff)
downloadfreebsd-ports-gnome-5a3c9a00225160714a79e87052e09af8af4d9c6b.tar.gz
freebsd-ports-gnome-5a3c9a00225160714a79e87052e09af8af4d9c6b.tar.zst
freebsd-ports-gnome-5a3c9a00225160714a79e87052e09af8af4d9c6b.zip
Don't strip Linux binary with FreeBSD strip, as it then brands the binary
as a FreeBSD one. PR: 18489 Submitted by: FUJISHIMA Satsuki <k5@cheerful.com> (this fix and the PR)
-rw-r--r--audio/linux-realplayer/Makefile3
-rw-r--r--multimedia/linux-realplayer/Makefile3
2 files changed, 6 insertions, 0 deletions
diff --git a/audio/linux-realplayer/Makefile b/audio/linux-realplayer/Makefile
index f059ef49f093..0ddc1adddc5b 100644
--- a/audio/linux-realplayer/Makefile
+++ b/audio/linux-realplayer/Makefile
@@ -20,6 +20,8 @@ NO_CDROM= "Redistribution not allowed"
NO_BUILD= yes
WRKSRC= ${WRKDIR}/rvplayer5.0/
+STRIP= # Linux binary should not be stripped by INSTALL_PROGRAM as it uses /usr/bin/strip which then brands the binary as a FreeBSD ELF one.
+
LIBFILES= libdecdnet.so libra14_4.so libra28_8.so libradnet.so \
librarv10.so librasipr.so librv10dec.so librvcore.so \
librvplayer.so
@@ -58,6 +60,7 @@ do-install:
.endfor
${INSTALL_PROGRAM} ${WRKSRC}/rvplayer ${PREFIX}/bin/
+ /compat/linux/usr/bin/strip ${PREFIX}/bin/rvplayer
/usr/bin/brandelf -t Linux ${PREFIX}/bin/rvplayer
${INSTALL_DATA} ${WRKSRC}/welcome.rm ${PREFIX}/share/rvplayer5.0/
diff --git a/multimedia/linux-realplayer/Makefile b/multimedia/linux-realplayer/Makefile
index f059ef49f093..0ddc1adddc5b 100644
--- a/multimedia/linux-realplayer/Makefile
+++ b/multimedia/linux-realplayer/Makefile
@@ -20,6 +20,8 @@ NO_CDROM= "Redistribution not allowed"
NO_BUILD= yes
WRKSRC= ${WRKDIR}/rvplayer5.0/
+STRIP= # Linux binary should not be stripped by INSTALL_PROGRAM as it uses /usr/bin/strip which then brands the binary as a FreeBSD ELF one.
+
LIBFILES= libdecdnet.so libra14_4.so libra28_8.so libradnet.so \
librarv10.so librasipr.so librv10dec.so librvcore.so \
librvplayer.so
@@ -58,6 +60,7 @@ do-install:
.endfor
${INSTALL_PROGRAM} ${WRKSRC}/rvplayer ${PREFIX}/bin/
+ /compat/linux/usr/bin/strip ${PREFIX}/bin/rvplayer
/usr/bin/brandelf -t Linux ${PREFIX}/bin/rvplayer
${INSTALL_DATA} ${WRKSRC}/welcome.rm ${PREFIX}/share/rvplayer5.0/